summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-11-18 11:54:22 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-11-18 11:54:22 +0000
commitc2743fad1ad5393e49139f099dea2c8adc85d4f1 (patch)
tree46b532adb02e0020685a8d212481e141ff2023cb /net-libs
parenteapi problem - bug #247164 - thanks en.ABCD (diff)
downloadgentoo-2-c2743fad1ad5393e49139f099dea2c8adc85d4f1.tar.gz
gentoo-2-c2743fad1ad5393e49139f099dea2c8adc85d4f1.tar.bz2
gentoo-2-c2743fad1ad5393e49139f099dea2c8adc85d4f1.zip
fixed cve patch as per bug #246976 - thanks parafin
(Portage version: 2.2_rc14/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/ChangeLog10
-rw-r--r--net-libs/gnutls/files/gnutls-2.2.5-CVE-2008-4989-V2.patch20
-rw-r--r--net-libs/gnutls/gnutls-2.4.1-r2.ebuild76
-rw-r--r--net-libs/gnutls/gnutls-2.6.0-r2.ebuild (renamed from net-libs/gnutls/gnutls-2.6.1.ebuild)5
4 files changed, 108 insertions, 3 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 0ccd14bf0749..1184907f35c1 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.173 2008/11/18 11:26:11 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.174 2008/11/18 11:54:22 dragonheart Exp $
+
+*gnutls-2.6.0-r2 (18 Nov 2008)
+*gnutls-2.4.1-r2 (18 Nov 2008)
+
+ 18 Nov 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/gnutls-2.2.5-CVE-2008-4989-V2.patch, +gnutls-2.4.1-r2.ebuild,
+ +gnutls-2.6.0-r2.ebuild, -gnutls-2.6.1.ebuild:
+ fixed cve patch as per bug #246976 - thanks parafin
18 Nov 2008; Daniel Black <dragonheart@gentoo.org> gnutls-2.6.2.ebuild:
eapi problem - bug #247164 - thanks en.ABCD
diff --git a/net-libs/gnutls/files/gnutls-2.2.5-CVE-2008-4989-V2.patch b/net-libs/gnutls/files/gnutls-2.2.5-CVE-2008-4989-V2.patch
new file mode 100644
index 000000000000..154f1ba79ff3
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.2.5-CVE-2008-4989-V2.patch
@@ -0,0 +1,20 @@
+--- gnutls-2.4.1/lib/x509/verify.c.orig 2008-07-01 06:45:51.000000000 +1000
++++ gnutls-2.4.1/lib/x509/verify.c 2008-11-07 16:48:08.000000000 +1100
+@@ -414,17 +425,6 @@
+ }
+ #endif
+
+- /* Check if the last certificate in the path is self signed.
+- * In that case ignore it (a certificate is trusted only if it
+- * leads to a trusted party by us, not the server's).
+- */
+- if (gnutls_x509_crt_check_issuer (certificate_list[clist_size - 1],
+- certificate_list[clist_size - 1]) > 0
+- && clist_size > 0)
+- {
+- clist_size--;
+- }
+-
+ /* Verify the certificate path (chain)
+ */
+ for (i = clist_size - 1; i > 0; i--)
diff --git a/net-libs/gnutls/gnutls-2.4.1-r2.ebuild b/net-libs/gnutls/gnutls-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..27ca8920504f
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.4.1-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.4.1-r2.ebuild,v 1.1 2008/11/18 11:54:22 dragonheart Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="http://www.gnu.org/software/gnutls/releases/${P}.tar.bz2"
+#SRC_URI="mirror://gnu/gnutls/${P}.tar.bz2"
+
+# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="zlib lzo doc nls guile bindist"
+
+RDEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.2.4
+ >=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )
+ guile? ( dev-scheme/guile )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use guile && ! built_with_use dev-scheme/guile networking; then
+ eerror "You are trying to compile ${PN} package with USE=\"guile\""
+ eerror "while dev-scheme/guile does not have USE=\"networking\""
+ die
+ fi
+ if use lzo && use bindist; then
+ ewarn "lzo support was disabled for binary distribution of gnutls"
+ ewarn "due to licensing issues. See Bug 202381 for details."
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.3.11+gcc-4.3.patch
+ epatch "${FILESDIR}"/gnutls-2.2.5-CVE-2008-4989-V2.patch
+
+ elibtoolize # for sane .so versioning on FreeBSD
+}
+
+src_compile() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+ econf \
+ $(use_with zlib) \
+ $(use_enable nls) \
+ $(use_enable guile) \
+ $(use_enable doc gtk-doc) \
+ ${myconf}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if use doc ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}
diff --git a/net-libs/gnutls/gnutls-2.6.1.ebuild b/net-libs/gnutls/gnutls-2.6.0-r2.ebuild
index a1ab3a4908c8..d8d250359ecd 100644
--- a/net-libs/gnutls/gnutls-2.6.1.ebuild
+++ b/net-libs/gnutls/gnutls-2.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.6.1.ebuild,v 1.1 2008/11/10 19:55:29 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.6.0-r2.ebuild,v 1.1 2008/11/18 11:54:22 dragonheart Exp $
inherit eutils libtool autotools
@@ -53,8 +53,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
rm m4/lt* m4/libtool.m4 build-aux/ltmain.sh
- epatch "${FILESDIR}"/gnutls-2.6.0-cxx-configure.in.patch
+ epatch "${FILESDIR}"/${P}-cxx-configure.in.patch
eautoreconf
+ epatch "${FILESDIR}"/gnutls-2.2.5-CVE-2008-4989-V2.patch
elibtoolize # for sane .so versioning on FreeBSD
}