summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-05-01 11:28:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-05-01 11:28:07 +0000
commitea1cd13f432c742dee4d2f7aef2b583a9fbed0ab (patch)
treed60c23efcb768c1d52839be07a70e5a34674b4d8 /net-libs
parentVersion bump (diff)
downloadgentoo-2-ea1cd13f432c742dee4d2f7aef2b583a9fbed0ab.tar.gz
gentoo-2-ea1cd13f432c742dee4d2f7aef2b583a9fbed0ab.tar.bz2
gentoo-2-ea1cd13f432c742dee4d2f7aef2b583a9fbed0ab.zip
seem to have missed this commit
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog10
-rw-r--r--net-libs/libpcap/files/libpcap-0.9.8-largefile.patch11
-rw-r--r--net-libs/libpcap/libpcap-0.9.8-r1.ebuild56
3 files changed, 75 insertions, 2 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index a1c39c5f8b19..98c89ab67c2f 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libpcap
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.96 2007/11/19 06:54:32 kumba Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.97 2008/05/01 11:28:06 dragonheart Exp $
+
+*libpcap-0.9.8-r1 (01 Apr 2008)
+
+ 01 Apr 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/libpcap-0.9.8-largefile.patch, +libpcap-0.9.8-r1.ebuild:
+ added large file support as per bug #175239
19 Nov 2007; Joshua Kinard <kumba@gentoo.org> libpcap-0.9.8.ebuild:
Stable on mips, per #198476.
diff --git a/net-libs/libpcap/files/libpcap-0.9.8-largefile.patch b/net-libs/libpcap/files/libpcap-0.9.8-largefile.patch
new file mode 100644
index 000000000000..756e369bdac8
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-0.9.8-largefile.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2008-04-02 03:15:24.000000000 +1100
++++ configure.in 2008-04-02 03:15:45.000000000 +1100
+@@ -786,6 +786,8 @@
+
+ esac
+
++AC_SYS_LARGEFILE
++
+ AC_PROG_RANLIB
+
+ AC_LBL_DEVEL(V_CCOPT)
diff --git a/net-libs/libpcap/libpcap-0.9.8-r1.ebuild b/net-libs/libpcap/libpcap-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..27b5e749162c
--- /dev/null
+++ b/net-libs/libpcap/libpcap-0.9.8-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-0.9.8-r1.ebuild,v 1.1 2008/05/01 11:28:06 dragonheart Exp $
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+DEPEND="!virtual/libpcap"
+PROVIDE="virtual/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.3-whitespace.diff
+ epatch "${FILESDIR}"/${PN}-0.8.1-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-cross-linux.patch
+ epatch "${FILESDIR}"/${P}-largefile.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable ipv6) || die "bad configure"
+ emake || die "compile problem"
+
+ # no provision for this in the Makefile, so...
+ $(tc-getCC) ${LDFLAGS} -Wl,-soname,libpcap.so.0 -shared -fPIC -o libpcap.so.${PV:0:3} *.o \
+ || die "couldn't make a shared lib"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h || die "failed to install pcap-int.h"
+ fi
+
+ insopts -m 755
+ insinto /usr/$(get_libdir)
+ doins libpcap.so.${PV:0:3}
+ dosym libpcap.so.${PV:0:3} /usr/$(get_libdir)/libpcap.so.0
+ dosym libpcap.so.${PV:0:3} /usr/$(get_libdir)/libpcap.so
+
+ # We are not installing README.{Win32,aix,hpux,tru64} (bug 183057)
+ dodoc CREDITS CHANGES FILES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+}