summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2006-07-12 21:45:32 +0000
committerTuan Van <langthang@gentoo.org>2006-07-12 21:45:32 +0000
commit05d5db5509fc43bad197576b878835c49a9df399 (patch)
tree09d573d5cc3cfa08f341bb7ae5c5bb104c7efb50 /net-mail/cyrus-imapd
parentadd autocreate, autosieve, nntp (diff)
downloadgentoo-2-05d5db5509fc43bad197576b878835c49a9df399.tar.gz
gentoo-2-05d5db5509fc43bad197576b878835c49a9df399.tar.bz2
gentoo-2-05d5db5509fc43bad197576b878835c49a9df399.zip
Add three new local USE flags:
autocreate. Bug #112912. Thanks to Jörn Dreyer <j.dreyer@butonic.de> and Mike Nerone <mike@nerone.org> autosieve. Bug #133187 requested by Martin Schlemme <azarah@gentoo.org> nntp. Bug #130159 reported and provided patch by W-Mark Kubacki <wmark.gentoo@hurrikane.de> Honor kerberos USE flag. Bug #129957 reported and provided patch by Peter Dinges <me@elwedgo.de> Remove unsupported-8bit.patch as it is included upstream and some cleanup. (Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-mail/cyrus-imapd')
-rw-r--r--net-mail/cyrus-imapd/ChangeLog18
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.3.7.ebuild261
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac.patch31
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac_with_autocreate.patch58
-rw-r--r--net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.76
5 files changed, 373 insertions, 1 deletions
diff --git a/net-mail/cyrus-imapd/ChangeLog b/net-mail/cyrus-imapd/ChangeLog
index f57de4d003e2..58f07cf59474 100644
--- a/net-mail/cyrus-imapd/ChangeLog
+++ b/net-mail/cyrus-imapd/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for net-mail/cyrus-imapd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.81 2006/06/12 20:06:53 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.82 2006/07/12 21:45:32 langthang Exp $
+
+*cyrus-imapd-2.3.7 (12 Jul 2006)
+
+ 12 Jul 2006; Tuấn Văn <langthang@gentoo.org>
+ +files/cyrus-imapd-2.3.7-drac.patch,
+ +files/cyrus-imapd-2.3.7-drac_with_autocreate.patch,
+ +cyrus-imapd-2.3.7.ebuild:
+ Add three new local USE flags:
+ autocreate. Bug #112912. Thanks to Jörn Dreyer <j.dreyer@butonic.de> and
+ Mike Nerone <mike@nerone.org>
+ autosieve. Bug #133187 requested by Martin Schlemme <azarah@gentoo.org>
+ nntp. Bug #130159 reported and provided patch by W-Mark Kubacki
+ <wmark.gentoo@hurrikane.de>
+ Honor kerberos USE flag. Bug #129957 reported and provided patch by Peter
+ Dinges <me@elwedgo.de>
+ Remove unsupported-8bit.patch as it is included upstream and some cleanup.
*cyrus-imapd-2.3.6 (12 Jun 2006)
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.3.7.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.3.7.ebuild
new file mode 100644
index 000000000000..965078893255
--- /dev/null
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.3.7.ebuild
@@ -0,0 +1,261 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.7.ebuild,v 1.1 2006/07/12 21:45:32 langthang Exp $
+
+inherit eutils ssl-cert gnuconfig fixheadtails
+
+DESCRIPTION="The Cyrus IMAP Server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz
+ mirror://gentoo/${P}-uoa.tbz2"
+LIBWRAP_PATCH_VER="2.2.10"
+DRAC_PATCH_VER="2.3.7"
+AUTOCREATE_PATCH_VER="2.3.7"
+AUTOSIEVE_PATCH_VER="2.3.7"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~hppa ~ppc64"
+IUSE="afs autocreate autosieve drac idled kerberos nntp pam snmp ssl tcpd"
+
+PROVIDE="virtual/imapd"
+RDEPEND=">=sys-libs/db-3.2
+ >=dev-libs/cyrus-sasl-2.1.13
+ afs? ( >=net-fs/openafs-1.2.2 )
+ pam? (
+ virtual/pam
+ >=net-mail/mailbase-1
+ )
+ kerberos? ( virtual/krb5 )
+ snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ drac? ( >=mail-client/drac-1.12-r1 )"
+
+DEPEND="$RDEPEND
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake"
+
+new_net-snmp_check() {
+ # tcpd USE flag check. Bug #68254.
+ if use tcpd ; then
+ if has_version net-analyzer/net-snmp && ! built_with_use net-analyzer/net-snmp tcpd ; then
+ eerror "You are emerging this package with USE=\"tcpd\""
+ eerror "but \"net-analyzer/net-snmp\" has been emerged with USE=\"-tcpd\""
+ fail_msg
+ fi
+ else
+ if has_version net-analyzer/net-snmp && built_with_use net-analyzer/net-snmp tcpd ; then
+ eerror "You are emerging this package with USE=\"-tcpd\""
+ eerror "but \"net-analyzer/net-snmp\" has been emerged with USE=\"tcpd\""
+ fail_msg
+ fi
+ fi
+ # DynaLoader check. Bug #67411
+
+ if [ -x "$(type -p net-snmp-config)" ]; then
+ einfo "$(type -p net-snmp-config) is found and executable."
+ NSC_AGENTLIBS="$(net-snmp-config --agent-libs)"
+ einfo "NSC_AGENTLIBS=\""${NSC_AGENTLIBS}"\""
+ if [ -z "$NSC_AGENTLIBS" ]; then
+ eerror "NSC_AGENTLIBS is null"
+ einfo "please report this to bugs.gentoo.org"
+ fi
+ for i in ${NSC_AGENTLIBS}; do
+ # check for the DynaLoader path.
+ if [ "$(expr "$i" : '.*\(DynaLoader\)')" == "DynaLoader" ] ; then
+ DYNALOADER_PATH="$i"
+ einfo "DYNALOADER_PATH=\""${DYNALOADER_PATH}"\""
+ if [[ ! -f "${DYNALOADER_PATH}" ]]; then
+ eerror "\""${DYNALOADER_PATH}"\" is not found."
+ einfo "Have you upgraded \"perl\" after"
+ einfo "you emerged \"net-snmp\". Please re-emerge"
+ einfo "\"net-snmp\" then try again. Bug #67411."
+ die "\""${DYNALOADER_PATH}"\" is not found."
+ fi
+ fi
+ done
+ else
+ eerror "\"net-snmp-config\" not found or not executable!"
+ die "You have \"net-snmp\" installed but \"net-snmp-config\" is not found or not executable. Please re-emerge \"net-snmp\" and try again!"
+ fi
+}
+
+fail_msg() {
+ eerror "enable "snmp" USE flag for this package requires"
+ eerror "that net-analyzer/net-snmp and this package both build with"
+ eerror "\"tcpd\" or \"-tcpd\". Bug #68254"
+ die "sanity check failed."
+}
+
+pkg_setup() {
+ use snmp && new_net-snmp_check
+ enewuser cyrus -1 -1 /usr/cyrus mail
+}
+
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ ht_fix_file ${S}/imap/xversion.sh
+
+ # Add unsupported patch wrt #18706 and #80630
+ # fixed upstream.
+ # use unsupported_8bit && epatch "${FILESDIR}/${PN}-${MY_8BIT_PATCH_VER}-unsupported-8bit.patch"
+
+ # Unsupported UoA patch. Bug #112912 .
+ # http://email.uoa.gr/projects/cyrus/autocreate/
+ if use autocreate ; then
+ epatch "${WORKDIR}/${PN}-${AUTOCREATE_PATCH_VER}-autocreate.patch"
+ use drac && epatch "${FILESDIR}/${PN}-${DRAC_PATCH_VER}-drac_with_autocreate.patch"
+ else
+ use drac && epatch "${FILESDIR}/${PN}-${DRAC_PATCH_VER}-drac.patch"
+ fi
+
+ # Unsupported UoA patch. Bug #133187 .
+ # http://email.uoa.gr/projects/cyrus/autosievefolder/
+ use autosieve && epatch "${WORKDIR}/${PN}-${AUTOSIEVE_PATCH_VER}-autosieve.patch"
+
+ # fix undefine symbols.
+ use afs && epatch "${FILESDIR}/cyrus-imapd-2.3.6-afs.patch"
+
+ # Add libwrap defines as we don't have a dynamicly linked library.
+ use tcpd && epatch "${FILESDIR}/${PN}-${LIBWRAP_PATCH_VER}-libwrap.patch"
+
+ # Fix master(8)->cyrusmaster(8) manpage.
+ for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+ sed -i -e 's:master\.8:cyrusmaster.8:g' \
+ -e 's:master(8):cyrusmaster(8):g' \
+ "${i}" || die "sed failed" || die "sed failed"
+ done
+ mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+ sed -i -e "s:MASTER:CYRUSMASTER:g" \
+ -e "s:Master:Cyrusmaster:g" \
+ -e "s:master:cyrusmaster:g" \
+ man/cyrusmaster.8 || die "sed failed"
+
+ # Recreate configure.
+ export WANT_AUTOCONF="2.5"
+ gnuconfig_update
+ rm -rf configure config.h.in autom4te.cache || die
+ ebegin "Recreating configure"
+ sh SMakefile &>/dev/null || die "SMakefile failed"
+ eend $?
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -i -e "s:lrpm:lrpm -lrpmio -lrpmdb:" configure || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ use afs && myconf="${myconf} -with-afs=/usr"
+ myconf="${myconf} $(use_with drac)"
+ myconf="${myconf} $(use_with ssl openssl)"
+ myconf="${myconf} $(use_with snmp ucdsnmp)"
+ myconf="${myconf} $(use_with tcpd libwrap)"
+ myconf="${myconf} $(use_enable kerberos gssapi) $(use_enable kerberos krb5afspts)"
+ myconf="${myconf} $(use_enable idled)"
+ myconf="${myconf} $(use_enable nntp nntp)"
+
+ if use kerberos; then
+ myconf="${myconf} --with-auth=krb5"
+ else
+ myconf="${myconf} --with-auth=unix"
+ fi
+
+ econf \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-extraident=Gentoo \
+ --with-service-path=/usr/lib/cyrus \
+ --with-cyrus-user=cyrus \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --without-perl \
+ --disable-cyradm \
+ ${myconf} || die "econf failed"
+
+ # needed for parallel make. Bug #72352.
+ cd ${S}/imap
+ emake xversion.h || die "emake xversion.h failed"
+
+ cd ${S}
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/bin /usr/lib
+ for subdir in master imap imtest timsieved notifyd sieve; do
+ make -C "${subdir}" DESTDIR="${D}" install || die "make install failed"
+ done
+
+ # Link master to cyrusmaster (postfix has a master too)
+ dosym /usr/lib/cyrus/master /usr/lib/cyrus/cyrusmaster
+
+ doman man/*.[0-8]
+ dodoc COPYRIGHT README*
+ dohtml doc/*.html doc/murder.png
+ cp doc/cyrusv2.mc "${D}/usr/share/doc/${PF}/html"
+ cp -r contrib tools "${D}/usr/share/doc/${PF}"
+ find "${D}/usr/share/doc" -name CVS -print0 | xargs -0 rm -rf
+
+ insinto /etc
+ doins "${FILESDIR}/cyrus.conf" "${FILESDIR}/imapd.conf"
+
+ newinitd "${FILESDIR}/cyrus.rc6" cyrus
+ newconfd "${FILESDIR}/cyrus.confd" cyrus
+ newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+ # do not install server.{key,pem) if they are exist.
+ if use ssl && [[ ! -f /etc/ssl/cyrus/server.key && ! -f /etc/ssl/cyrus/server.pem ]] ; then
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Cyrus IMAP Server}"
+ insinto /etc/ssl/cyrus
+ docert server
+ fowners cyrus:mail /etc/ssl/cyrus/server.{key,pem}
+ fi
+
+ for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+ keepdir "/var/${subdir}"
+ fowners cyrus:mail "/var/${subdir}"
+ fperms 0750 "/var/${subdir}"
+ done
+ for subdir in imap/{user,quota,sieve} spool/imap ; do
+ for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+ keepdir "/var/${subdir}/${i}"
+ fowners cyrus:mail "/var/${subdir}/${i}"
+ fperms 0750 "/var/${subdir}/${i}"
+ done
+ done
+}
+
+pkg_postinst() {
+
+ enewuser cyrus -1 -1 /usr/cyrus mail
+
+ if df -T /var/imap | grep -q ' ext[23] ' ; then
+ ebegin "Making /var/imap/user/* and /var/imap/quota/* synchronous."
+ chattr +S /var/imap/{user,quota}{,/*}
+ eend $?
+ fi
+
+ if df -T /var/spool/imap | grep -q ' ext[23] ' ; then
+ ebegin "Making /var/spool/imap/* synchronous."
+ chattr +S /var/spool/imap{,/*}
+ eend $?
+ fi
+
+ ewarn "If the queue directory of the mail daemon resides on an ext2"
+ ewarn "or ext3 filesystem you need to set it manually to update"
+ ewarn "synchronously. E.g. 'chattr +S /var/spool/mqueue'."
+ echo
+
+ elog "For correct logging add the following to /etc/syslog.conf:"
+ elog " local6.* /var/log/imapd.log"
+ elog " auth.debug /var/log/auth.log"
+ echo
+
+ elog "You have to add user cyrus to the sasldb2. Do this with:"
+ elog " saslpasswd2 cyrus"
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac.patch
new file mode 100644
index 000000000000..1ca22b85dba3
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac.patch
@@ -0,0 +1,31 @@
+--- contrib/drac_auth.patch.orig 2006-06-09 18:34:58.000000000 -0700
++++ contrib/drac_auth.patch 2006-06-09 18:35:54.000000000 -0700
+@@ -71,7 +71,7 @@
+ diff -u -r1.268.2.23 configure.in
+ --- configure.in 12 Apr 2005 20:05:20 -0000 1.268.2.23
+ +++ configure.in 23 May 2006 13:42:06 -0000
+-@@ -1003,6 +1003,19 @@
++@@ -1003,6 +1003,20 @@
+ SNMP_SUBDIRS=""
+ AC_SUBST(SNMP_SUBDIRS)
+
+@@ -80,12 +80,13 @@
+ +dnl
+ +DRACLIBS=
+ +AC_ARG_WITH(drac, [ --with-drac=DIR use DRAC library in <DIR> [no] ],
+-+ if test -d "$withval"; then
+-+ LDFLAGS="$LDFLAGS -L${withval}"
+-+ AC_CHECK_LIB(drac, dracauth,
+-+ AC_DEFINE(DRAC_AUTH,[],[Build DRAC support?])
+-+ DRACLIBS="-ldrac")
+-+ fi)
+++ drac="$withval",
+++ drac="no")
+++if test "$drac" != "no"; then
+++ AC_CHECK_LIB(drac, dracauth,
+++ AC_DEFINE(DRAC_AUTH,[],[Build DRAC support?])
+++ DRACLIBS="-ldrac")
+++fi
+ +AC_SUBST(DRACLIBS)
+ +
+ CMU_LIBWRAP
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac_with_autocreate.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac_with_autocreate.patch
new file mode 100644
index 000000000000..0bfc8b15dd5e
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-2.3.7-drac_with_autocreate.patch
@@ -0,0 +1,58 @@
+--- contrib/drac_auth.patch.orig 2006-06-09 18:34:58.000000000 -0700
++++ contrib/drac_auth.patch 2006-06-09 18:35:54.000000000 -0700
+@@ -71,7 +71,7 @@
+ diff -u -r1.268.2.23 configure.in
+ --- configure.in 12 Apr 2005 20:05:20 -0000 1.268.2.23
+ +++ configure.in 23 May 2006 13:42:06 -0000
+-@@ -1003,6 +1003,19 @@
++@@ -1003,6 +1003,20 @@
+ SNMP_SUBDIRS=""
+ AC_SUBST(SNMP_SUBDIRS)
+
+@@ -80,12 +80,13 @@
+ +dnl
+ +DRACLIBS=
+ +AC_ARG_WITH(drac, [ --with-drac=DIR use DRAC library in <DIR> [no] ],
+-+ if test -d "$withval"; then
+-+ LDFLAGS="$LDFLAGS -L${withval}"
+-+ AC_CHECK_LIB(drac, dracauth,
+-+ AC_DEFINE(DRAC_AUTH,[],[Build DRAC support?])
+-+ DRACLIBS="-ldrac")
+-+ fi)
+++ drac="$withval",
+++ drac="no")
+++if test "$drac" != "no"; then
+++ AC_CHECK_LIB(drac, dracauth,
+++ AC_DEFINE(DRAC_AUTH,[],[Build DRAC support?])
+++ DRACLIBS="-ldrac")
+++fi
+ +AC_SUBST(DRACLIBS)
+ +
+ CMU_LIBWRAP
+--- contrib/drac_auth.patch.new 2006-07-11 16:50:55.000000000 -0700
++++ contrib/drac_auth.patch 2006-07-11 16:58:36.000000000 -0700
+@@ -111,8 +111,8 @@
+ imapd: xversion $(IMAPDOBJS) mutex_fake.o libimap.a $(DEPLIBS) $(SERVICE)
+ $(CC) $(LDFLAGS) -o imapd \
+ $(SERVICE) $(IMAPDOBJS) mutex_fake.o \
+-- libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+ imapd.pure: $(IMAPDOBJS) mutex_fake.o libimap.a $(DEPLIBS) $(SERVICE)
+ $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) -o imapd.pure \
+@@ -130,10 +130,10 @@
+ libimap.a $(DEPLIBS)
+ @@ -230,7 +231,7 @@
+ pop3d: pop3d.o proxy.o backend.o tls.o mutex_fake.o libimap.a \
+- $(DEPLIBS) $(SERVICE)
++ $(SIEVE_LIBS) $(DEPLIBS) $(SERVICE)
+ $(CC) $(LDFLAGS) -o pop3d pop3d.o proxy.o backend.o tls.o $(SERVICE) \
+-- mutex_fake.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+-+ mutex_fake.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
++- mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP)
+++ mutex_fake.o libimap.a $(SIEVE_LIBS) $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(DRAC_LIBS)
+
+ nntpd: nntpd.o proxy.o backend.o index.o smtpclient.o spool.o tls.o \
+ mutex_fake.o nntp_err.o libimap.a $(DEPLIBS) $(SERVICE)
diff --git a/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.7 b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.7
new file mode 100644
index 000000000000..2fbfe0adf427
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/digest-cyrus-imapd-2.3.7
@@ -0,0 +1,6 @@
+MD5 0aa233c0b510cf48e1a8efb233c447c1 cyrus-imapd-2.3.7-uoa.tbz2 17788
+RMD160 22f2aa3f0755bc924e9bef8613e59924b3d971a6 cyrus-imapd-2.3.7-uoa.tbz2 17788
+SHA256 5a79970e70af26525d48c279ed53267c6a285bc259bf9201ff289a4c1050aca7 cyrus-imapd-2.3.7-uoa.tbz2 17788
+MD5 07990f3a78a3a9d728cae627e31a9caf cyrus-imapd-2.3.7.tar.gz 2254961
+RMD160 5f2170677f1a013a3707b1fbb07713a8f93fc3c6 cyrus-imapd-2.3.7.tar.gz 2254961
+SHA256 ff58c60999f2c6495e218b81a25b6f5ef1805e4a160122db2744a6645a753b6d cyrus-imapd-2.3.7.tar.gz 2254961