summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-08-24 09:15:18 +0000
committerEray Aslan <eras@gentoo.org>2011-08-24 09:15:18 +0000
commitfda9fe4b338f7f767a14ba84e24f9b4085312883 (patch)
tree4a05ffce8df0a106ea3beffe909d1458ff0cb76a /net-mail/fetchmail
parentInstall the dspamc binary setgid so it can read its config file when called b... (diff)
downloadgentoo-2-fda9fe4b338f7f767a14ba84e24f9b4085312883.tar.gz
gentoo-2-fda9fe4b338f7f767a14ba84e24f9b4085312883.tar.bz2
gentoo-2-fda9fe4b338f7f767a14ba84e24f9b4085312883.zip
Version bump. Add socks USE flag - bug #380405. Allow multiple deamons - bug #380371. Remove unused patches.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog10
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.21.ebuild96
-rw-r--r--net-mail/fetchmail/files/MD5_library_pickup.patch40
-rw-r--r--net-mail/fetchmail/files/debian-580796.patch15
-rw-r--r--net-mail/fetchmail/files/fetchmail.confd10
-rw-r--r--net-mail/fetchmail/files/fetchmail.initd44
-rw-r--r--net-mail/fetchmail/metadata.xml3
7 files changed, 161 insertions, 57 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index e29379baba9b..a1fe735adc23 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/fetchmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.216 2011/08/05 07:13:35 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.217 2011/08/24 09:15:17 eras Exp $
+
+*fetchmail-6.3.21 (24 Aug 2011)
+
+ 24 Aug 2011; Eray Aslan <eras@gentoo.org> +files/fetchmail.initd,
+ -files/MD5_library_pickup.patch, +fetchmail-6.3.21.ebuild,
+ -files/debian-580796.patch, +files/fetchmail.confd:
+ Version bump. Add socks USE flag - bug #380405. Allow multiple deamons - bug
+ #380371. Remove unused patches.
05 Aug 2011; Eray Aslan <eras@gentoo.org> files/fetchmail.new:
fix deprecated chuid option in init script - bug #377777
diff --git a/net-mail/fetchmail/fetchmail-6.3.21.ebuild b/net-mail/fetchmail/fetchmail-6.3.21.ebuild
new file mode 100644
index 000000000000..c222b7bd7cdf
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.21.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.21.ebuild,v 1.1 2011/08/24 09:15:17 eras Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="tk? 2"
+PYTHON_USE_WITH_OPT="tk"
+PYTHON_USE_WITH="tk"
+
+inherit python eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls kerberos hesiod tk socks"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+ if use tk; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # dont compile during src_install
+ : > "${S}"/py-compile
+}
+
+src_configure() {
+ if use tk ; then
+ export PYTHON=$(PYTHON -a )
+ else
+ export PYTHON=:
+ fi
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use kerberos && echo "--with-ssl" ) \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod) \
+ $(use_with socks)
+}
+
+src_install() {
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ keepdir /var/lib/${PN} || die
+ fowners ${PN}:${PN} /var/lib/${PN} || die
+ fperms 700 /var/lib/${PN} || die
+
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO || die
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail || die
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail || die
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ use tk && python_mod_optimize fetchmailconf.py
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
+
+pkg_postrm() {
+ use tk && python_mod_cleanup fetchmailconf.py
+}
diff --git a/net-mail/fetchmail/files/MD5_library_pickup.patch b/net-mail/fetchmail/files/MD5_library_pickup.patch
deleted file mode 100644
index 575572c68c1e..000000000000
--- a/net-mail/fetchmail/files/MD5_library_pickup.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Matthias Andree <matthias.andree@gmx.de>
-Date: Mon, 17 May 2010 21:10:16 +0200
-Subject: [PATCH] Fix MD5* library pickup.
-
-Avoid picking up libmd5, which fails if libwww is installed because libmd5
-uses "long" rather than fixed-width types. This fails on non-32-bit machines.
-
-Only probe libmd if md5.h is found.
-
-To fix Gentoo Bug #319283, reported by Karl Hakimian.
----
- NEWS | 4 ++++
- configure.ac | 12 +++++++++---
- 2 files changed, 13 insertions(+), 3 deletions(-)
-
-index 2ff315f..943eb3e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -171,9 +171,15 @@ dnl [LIBS="$LIBS -lintl"])
-
- AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat])
-
--AC_SEARCH_LIBS(MD5Init, [md5 md], [],
-- [AC_LIBSOURCE(md5c.c)
-- EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"])
-+have_md5=no
-+if test "$ac_cv_header_md5_h" != no ; then
-+ AC_SEARCH_LIBS(MD5Init, [md], [have_md5=yes])
-+fi
-+
-+if test "$have_md5" != yes ; then
-+ AC_LIBSOURCE(md5c.c)
-+ EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"
-+fi
-
- AC_CHECK_FUNC(getopt_long, [],
- [AC_LIBSOURCES([getopt.c, getopt1.c])
---
-1.6.1
-
diff --git a/net-mail/fetchmail/files/debian-580796.patch b/net-mail/fetchmail/files/debian-580796.patch
deleted file mode 100644
index 0bd65b1ca026..000000000000
--- a/net-mail/fetchmail/files/debian-580796.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/socket.c b/socket.c
-index a3adfd8..2ebdfc6 100644
---- a/socket.c
-+++ b/socket.c
-@@ -1009,8 +1009,8 @@ int SSLOpen(int sock, char *mycert, char *mykey, const char *myproto, int certck
- }
- }
-
-- if (!certck && (SSL_get_verify_result(_ssl_context[sock]) != X509_V_OK
--|| !_verify_ok)) {
-+ if (!certck && !fingerprint &&
-+ (SSL_get_verify_result(_ssl_context[sock]) != X509_V_OK || !_verify_ok)) {
- report(stderr, GT_("Warning: the connection is insecure, continuing anyways. (Better use --sslcertck!)\n"));
- }
-
diff --git a/net-mail/fetchmail/files/fetchmail.confd b/net-mail/fetchmail/files/fetchmail.confd
new file mode 100644
index 000000000000..b7be8e32b8cc
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.confd
@@ -0,0 +1,10 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/files/fetchmail.confd,v 1.1 2011/08/24 09:15:18 eras Exp $
+
+# Polling frequency in seconds
+# (fetchmail will daemonize and check for new mail at this interval)
+polling_period="60"
+
+# Directory where the pid file is kept
+pid_dir="/var/run/fetchmail"
diff --git a/net-mail/fetchmail/files/fetchmail.initd b/net-mail/fetchmail/files/fetchmail.initd
new file mode 100644
index 000000000000..889bcb61bb7d
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+
+piddir=${pid_dir:-/var/run/fetchmail}
+pid_file=${piddir}/${RC_SVCNAME}.pid
+rcfile=/etc/${RC_SVCNAME}rc
+
+depend() {
+ need net
+ use mta
+}
+
+checkconfig() {
+ if [ ! -f ${rcfile} ]; then
+ eerror "Configuration file ${rcfile} not found"
+ return 1
+ fi
+ local fetchmail_instance
+ fetchmail_instance=${RC_SVCNAME##*.}
+ if [ -n "${fetchmail_instance}" -a "${RC_SVCNAME}" != "fetchmail" ]; then
+ fidfile=/var/lib/fetchmail/.fetchids.${RC_SVCNAME}
+ else
+ fidfile=/var/lib/fetchmail/.fetchids
+ fi
+ if [ ! -d ${piddir} ]; then
+ checkpath -q -d -o fetchmail:fetchmail -m 0755 ${piddir} || return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${RC_SVCNAME}"
+ start-stop-daemon --start --pidfile ${pid_file} \
+ --user fetchmail --exec /usr/bin/fetchmail \
+ -- -d ${polling_period} -f ${rcfile} \
+ --pidfile ${pid_file} -i ${fidfile}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${RC_SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile ${pid_file}
+ eend ${?}
+}
+
diff --git a/net-mail/fetchmail/metadata.xml b/net-mail/fetchmail/metadata.xml
index a652eb292576..d0a743178b8a 100644
--- a/net-mail/fetchmail/metadata.xml
+++ b/net-mail/fetchmail/metadata.xml
@@ -4,6 +4,7 @@
<herd>net-mail</herd>
<use>
<flag name="hesiod">Enable support for hesiod</flag>
- <flag name="tk">Adds support for Tk GUI toolkit, in particular it installs fetchmailconf</flag>
+ <flag name="tk">Enable support for Tk GUI toolkit, in particular it installs fetchmailconf</flag>
+ <flag name="socks">Enable support for socks proxy</flag>
</use>
</pkgmetadata>