summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-05-04 12:26:22 +0000
committerEray Aslan <eras@gentoo.org>2012-05-04 12:26:22 +0000
commit49811cce6b5f3ff7043178fb72d246884a956ec6 (patch)
tree2bcc0185807dca37892d1172365183ac704c881b /net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild
parentversion bump (diff)
downloadgentoo-2-49811cce6b5f3ff7043178fb72d246884a956ec6.tar.gz
gentoo-2-49811cce6b5f3ff7043178fb72d246884a956ec6.tar.bz2
gentoo-2-49811cce6b5f3ff7043178fb72d246884a956ec6.zip
version bump and remove old
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild')
-rw-r--r--net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild b/net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild
new file mode 100644
index 000000000000..938521ce4073
--- /dev/null
+++ b/net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchyahoo/fetchyahoo-2.14.7.ebuild,v 1.1 2012/05/04 12:26:22 eras Exp $
+
+EAPI=4
+
+DESCRIPTION="Download mail from a Yahoo! webmail account to a local mail spool, an mbox file, or to procmail."
+HOMEPAGE="http://fetchyahoo.twizzler.org/"
+SRC_URI="http://fetchyahoo.twizzler.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/MIME-tools
+ virtual/perl-libnet
+ dev-perl/Crypt-SSLeay
+ dev-perl/URI
+ dev-perl/MailTools
+ dev-perl/IO-stringy
+ virtual/perl-MIME-Base64
+ dev-perl/TermReadKey"
+
+src_install() {
+ dobin fetchyahoo
+ doman fetchyahoo.1
+ insinto /etc
+ doins fetchyahoorc
+ dodoc ChangeLog Credits INSTALL TODO fetchyahoorc
+ dohtml index.html
+}
+
+pkg_postinst() {
+ elog "Edit /etc/fetchyahoorc or ~/.fetchyahoorc to configure fetchyahoo."
+ elog "The executable name has changed from fetchyahoo.pl to fetchyahoo."
+}