summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-03 18:17:55 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-03 18:17:55 +0000
commit285fe05029804d2e92aa207c75cd0eff75eb8629 (patch)
tree8415d5348d5efcfc2e64a9f187587a3992372edd /net-mail/imapsync/imapsync-1.350-r1.ebuild
parentalpha/arm/ia64/s390/sh/sparc stable wrt #337154 (diff)
downloadgentoo-2-285fe05029804d2e92aa207c75cd0eff75eb8629.tar.gz
gentoo-2-285fe05029804d2e92aa207c75cd0eff75eb8629.tar.bz2
gentoo-2-285fe05029804d2e92aa207c75cd0eff75eb8629.zip
Revision bump and remove old. Remove dev-perl/DateManip dependency as it is not used anymore.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/imapsync/imapsync-1.350-r1.ebuild')
-rw-r--r--net-mail/imapsync/imapsync-1.350-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/imapsync/imapsync-1.350-r1.ebuild b/net-mail/imapsync/imapsync-1.350-r1.ebuild
new file mode 100644
index 000000000000..f48a15ea9119
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.350-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.350-r1.ebuild,v 1.1 2010/10/03 18:17:55 radhermit Exp $
+
+EAPI=2
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another."
+HOMEPAGE="http://www.linux-france.org/prj/"
+SRC_URI="http://www.linux-france.org/prj/imapsync/dist/${P}.tgz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Digest-HMAC
+ dev-perl/IO-Socket-SSL
+ dev-perl/Mail-IMAPClient
+ dev-perl/Net-SSLeay
+ dev-perl/TermReadKey
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s/^install: testp/install:/" "${S}"/Makefile || die
+}
+
+src_compile() { : ; }
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make failed"
+ dodoc CREDITS ChangeLog FAQ README TODO || die "dodoc failed"
+}