summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-01-25 21:10:17 +0000
committerThilo Bangert <bangert@gentoo.org>2008-01-25 21:10:17 +0000
commit5ca882e5b882a499a9df733dedc830fdac2e1086 (patch)
tree9098e99a7d0ed6d787d92166abc8aab98364347e /net-mail/mailfront
parentadd a few more to the apache-2 mask (diff)
downloadgentoo-2-5ca882e5b882a499a9df733dedc830fdac2e1086.tar.gz
gentoo-2-5ca882e5b882a499a9df733dedc830fdac2e1086.tar.bz2
gentoo-2-5ca882e5b882a499a9df733dedc830fdac2e1086.zip
fix quoting, honor ROOT, use emake, einfo -> elog
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-mail/mailfront')
-rw-r--r--net-mail/mailfront/ChangeLog8
-rw-r--r--net-mail/mailfront/mailfront-0.88.ebuild21
-rw-r--r--net-mail/mailfront/mailfront-0.98.ebuild18
3 files changed, 26 insertions, 21 deletions
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
index b76fe74a1413..f6b48739c9fa 100644
--- a/net-mail/mailfront/ChangeLog
+++ b/net-mail/mailfront/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/mailfront
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.22 2007/02/22 15:56:41 bangert Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.23 2008/01/25 21:10:17 bangert Exp $
+
+ 25 Jan 2008; Thilo Bangert <bangert@gentoo.org> mailfront-0.88.ebuild,
+ mailfront-0.98.ebuild:
+ fix quoting, honor ROOT, use emake, einfo -> elog
22 Feb 2007; Thilo Bangert <bangert@gentoo.org> mailfront-0.98.ebuild:
einfo -> elog, fix SRC_URI
diff --git a/net-mail/mailfront/mailfront-0.88.ebuild b/net-mail/mailfront/mailfront-0.88.ebuild
index 779243300829..3ab71dd9edfe 100644
--- a/net-mail/mailfront/mailfront-0.88.ebuild
+++ b/net-mail/mailfront/mailfront-0.88.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.11 2006/10/28 12:38:48 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.12 2008/01/25 21:10:17 bangert Exp $
inherit fixheadtails toolchain-funcs
@@ -23,7 +23,7 @@ RDEPEND="
src_unpack() {
unpack ${A}
- ht_fix_file ${S}/Makefile
+ ht_fix_file "${S}"/Makefile
}
src_compile() {
@@ -43,9 +43,9 @@ src_install() {
#install new run files for qmail-smtpd and qmail-pop3
exeinto /var/qmail/supervise/qmail-smtpd
- newexe ${FILESDIR}/run-smtpfront run.mailfront
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
exeinto /var/qmail/supervise/qmail-pop3d
- newexe ${FILESDIR}/run-pop3front run.mailfront
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
dodoc ANNOUNCEMENT FILES NEWS README TARGETS TODO VERSION
@@ -62,9 +62,10 @@ pkg_config() {
}
pkg_postinst() {
- einfo
- einfo "Run emerge --config =${CATEGORY}/${PF}"
- einfo "to update you run files (backup are created) in"
- einfo " /var/qmail/supervise/qmail-pop3d and"
- einfo " /var/qmail/supervise/qmail-smtpd"
+ echo
+ elog "Run emerge --config =${CATEGORY}/${PF}"
+ elog "to update you run files (backup are created) in"
+ elog " /var/qmail/supervise/qmail-pop3d and"
+ elog " /var/qmail/supervise/qmail-smtpd"
+ echo
}
diff --git a/net-mail/mailfront/mailfront-0.98.ebuild b/net-mail/mailfront/mailfront-0.98.ebuild
index 39201c56ac15..abda0b580081 100644
--- a/net-mail/mailfront/mailfront-0.98.ebuild
+++ b/net-mail/mailfront/mailfront-0.98.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.4 2007/02/22 15:56:41 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.5 2008/01/25 21:10:17 bangert Exp $
inherit toolchain-funcs
@@ -32,7 +32,7 @@ src_compile() {
echo "${D}/var/qmail/bin" > conf-bin
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) -s" > conf-ld
- make || die
+ emake || die
}
src_install() {
@@ -40,18 +40,18 @@ src_install() {
emake install || die
exeinto /var/qmail/supervise/qmail-smtpd
- newexe ${FILESDIR}/run-smtpfront run.mailfront
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
exeinto /var/qmail/supervise/qmail-pop3d
- newexe ${FILESDIR}/run-pop3front run.mailfront
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
- dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README VERSION
+ dodoc ANNOUNCEMENT ChangeLog NEWS README VERSION
dohtml *.html
}
pkg_config() {
- cd /var/qmail/supervise/qmail-smtpd/
+ cd "${ROOT}"/var/qmail/supervise/qmail-smtpd/
cp run run.qmail-smtpd.`date +%Y%m%d%H%M%S` && cp run.mailfront run
- cd /var/qmail/supervise/qmail-pop3d/
+ cd "${ROOT}"/var/qmail/supervise/qmail-pop3d/
cp run run.qmail-pop3d.`date +%Y%m%d%H%M%S` && cp run.mailfront run
}
@@ -59,7 +59,7 @@ pkg_postinst() {
echo
elog "Run"
elog "emerge --config =${CATEGORY}/${PF}"
- elgo "to update your run files (backups are created) in"
+ elog "to update your run files (backups are created) in"
elog " /var/qmail/supervise/qmail-pop3d and"
elog " /var/qmail/supervise/qmail-smtpd"
echo