summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-10-21 22:01:34 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-10-21 22:01:34 +0000
commit2201857d0823f0a56f54041a33595aee23672069 (patch)
treeb4f16c8bf20f6e57a38952c30640a709402e70bc /net-mail/mailgraph/mailgraph-1.12.ebuild
parentfixed bad utf-8 in ChangeLog (diff)
downloadgentoo-2-2201857d0823f0a56f54041a33595aee23672069.tar.gz
gentoo-2-2201857d0823f0a56f54041a33595aee23672069.tar.bz2
gentoo-2-2201857d0823f0a56f54041a33595aee23672069.zip
Version bump; bug #110055
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'net-mail/mailgraph/mailgraph-1.12.ebuild')
-rw-r--r--net-mail/mailgraph/mailgraph-1.12.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-mail/mailgraph/mailgraph-1.12.ebuild b/net-mail/mailgraph/mailgraph-1.12.ebuild
new file mode 100644
index 000000000000..0d245922afd5
--- /dev/null
+++ b/net-mail/mailgraph/mailgraph-1.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/mailgraph-1.12.ebuild,v 1.1 2005/10/21 22:01:34 halcy0n Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="A mail statistics RRDtool frontend for Postfix"
+HOMEPAGE="http://people.ee.ethz.ch/~dws/software/mailgraph/"
+SRC_URI="http://people.ee.ethz.ch/~dws/software/${PN}/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Tail
+ >=net-analyzer/rrdtool-1.2.2"
+DEPEND=">=sys-apps/sed-4"
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use net-analyzer/rrdtool perl \
+ || die "net-analyzer/rrdtool must be built with USE=perl"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s|\(my \$rrd = '\).*'|\1/var/lib/mailgraph/mailgraph.rrd'|" \
+ -e "s|\(my \$rrd_virus = '\).*'|\1/var/lib/mailgraph/mailgraph_virus.rrd'|" \
+ mailgraph.cgi || die "sed mailgraph.cgi failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # for the RRDs
+ keepdir /var/lib/mailgraph
+
+ # mailgraph daemon
+ newbin mailgraph.pl mailgraph
+
+ # mailgraph CGI script
+ exeinto ${MY_CGIBINDIR}
+ doexe mailgraph.cgi
+
+ # init/conf files for mailgraph daemon
+ newinitd ${FILESDIR}/mailgraph.initd mailgraph
+ newconfd ${FILESDIR}/mailgraph.confd mailgraph
+
+ # docs
+ dodoc README CHANGES COPYING
+
+ webapp_src_install
+}