summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-08-20 06:48:42 +0000
committerEray Aslan <eras@gentoo.org>2011-08-20 06:48:42 +0000
commit96c2ec3fcf01b66bec3b0c2c6e60d5bf30f3be08 (patch)
tree65494fa27d4848c149881f211b5052ecd1583341 /net-mail/mailutils
parentCall dosym with proper second argument. Add static-libs USE flag. (diff)
downloadgentoo-2-96c2ec3fcf01b66bec3b0c2c6e60d5bf30f3be08.tar.gz
gentoo-2-96c2ec3fcf01b66bec3b0c2c6e60d5bf30f3be08.tar.bz2
gentoo-2-96c2ec3fcf01b66bec3b0c2c6e60d5bf30f3be08.zip
Use Python 2. Don't install *.pyc, *.pyo, *.a and *.la files in Python site-packages directories. Properly call python_mod_optimize() and python_mod_cleanup() (bug #377215). Patch by Arfrever.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mailutils')
-rw-r--r--net-mail/mailutils/ChangeLog7
-rw-r--r--net-mail/mailutils/mailutils-2.2.ebuild31
2 files changed, 33 insertions, 5 deletions
diff --git a/net-mail/mailutils/ChangeLog b/net-mail/mailutils/ChangeLog
index d157f7f905f1..54a3f1de49ca 100644
--- a/net-mail/mailutils/ChangeLog
+++ b/net-mail/mailutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mailutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.49 2011/07/29 18:50:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.50 2011/08/20 06:48:42 eras Exp $
+
+ 20 Aug 2011; Eray Aslan <eras@gentoo.org> mailutils-2.2.ebuild:
+ Use Python 2. Don't install *.pyc, *.pyo, *.a and *.la files in Python
+ site-packages directories. Properly call python_mod_optimize() and
+ python_mod_cleanup() (bug #377215). Patch by Arfrever.
29 Jul 2011; Fabian Groffen <grobian@gentoo.org> mailutils-2.2.ebuild:
Marked ~*-macos
diff --git a/net-mail/mailutils/mailutils-2.2.ebuild b/net-mail/mailutils/mailutils-2.2.ebuild
index 6ecc5c0881d0..7160d77475df 100644
--- a/net-mail/mailutils/mailutils-2.2.ebuild
+++ b/net-mail/mailutils/mailutils-2.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.2.ebuild,v 1.5 2011/07/29 18:50:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.2.ebuild,v 1.6 2011/08/20 06:48:42 eras Exp $
EAPI="3"
+PYTHON_DEPEND="python? 2"
inherit eutils flag-o-matic libtool python
@@ -32,9 +33,19 @@ RDEPEND="!mail-client/nmh
DEPEND="${RDEPEND}
test? ( dev-util/dejagnu )"
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.1-python.patch
elibtoolize # for Darwin bundles
+
+ # Disable bytecompilation of Python modules.
+ echo "#!/bin/sh" > build-aux/py-compile
}
src_configure() {
@@ -57,8 +68,7 @@ src_configure() {
$(use_enable pam) \
$(use_with postgres) \
$(use_with python) \
- $(use_with tokyocabinet) \
- || die "configure failed"
+ $(use_with tokyocabinet)
}
src_install() {
@@ -66,8 +76,21 @@ src_install() {
# mail.rc stolen from mailx, resolve bug #37302.
insinto /etc
doins "${FILESDIR}/mail.rc"
+
+ if use python; then
+ python_clean_installation_image
+ rm -f "${ED}$(python_get_sitedir)/mailutils/c_api.a"
+ fi
}
pkg_postinst() {
- python_mod_optimize "$(python_get_libdir)/site-packages/mailutils"
+ if use python; then
+ python_mod_optimize mailutils
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup mailutils
+ fi
}