summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-21 00:53:25 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-21 00:53:25 +0000
commit9b86846ded28cc40a47ec77fba66c66d5eb39aca (patch)
tree42c7182f690cbd5549d4f7d8897e7a90cac4c0fc /net-mail/razor
parentFix logging command-line parameters for version 5.1. (Manifest recommit) (diff)
downloadgentoo-2-9b86846ded28cc40a47ec77fba66c66d5eb39aca.tar.gz
gentoo-2-9b86846ded28cc40a47ec77fba66c66d5eb39aca.tar.bz2
gentoo-2-9b86846ded28cc40a47ec77fba66c66d5eb39aca.zip
fix install #31365
Diffstat (limited to 'net-mail/razor')
-rw-r--r--net-mail/razor/ChangeLog9
-rw-r--r--net-mail/razor/razor-2.36-r1.ebuild96
2 files changed, 53 insertions, 52 deletions
diff --git a/net-mail/razor/ChangeLog b/net-mail/razor/ChangeLog
index ffcd79335358..b6b90d7301fb 100644
--- a/net-mail/razor/ChangeLog
+++ b/net-mail/razor/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for net-mail/razor
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.10 2004/01/15 03:23:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.11 2004/01/21 00:53:25 vapier Exp $
+
+*razor-2.36-r1 (26 Sep 2003)
+
+ 20 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add install patch back in #31365.
14 Jan 2004; Aron Griffis <agriffis@gentoo.org> razor-2.36-r1.ebuild:
add ~alpha (bug 21240)
-*razor-2.36-r1 (26 Sep 2003)
-
26 Sep 2003; <rac@gentoo.org> razor-2.36-r1.ebuild, files/razor-taint.patch:
Add taint-mode patch from SpamAssassin 2.60 - see bug 29156
diff --git a/net-mail/razor/razor-2.36-r1.ebuild b/net-mail/razor/razor-2.36-r1.ebuild
index c09ae1337bf0..6e757a9b8f66 100644
--- a/net-mail/razor/razor-2.36-r1.ebuild
+++ b/net-mail/razor/razor-2.36-r1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/razor-2.36-r1.ebuild,v 1.2 2004/01/15 03:23:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/razor-2.36-r1.ebuild,v 1.3 2004/01/21 00:53:25 vapier Exp $
-inherit perl-module
+inherit perl-module eutils
-S="${WORKDIR}/razor-agents-${PV}"
-
-DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
-HOMEPAGE="http://razor.sourceforge.net"
+DESCRIPTION="a distributed & collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net/"
SRC_URI="mirror://sourceforge/razor/razor-agents-${PV}.tar.gz"
+
LICENSE="Artistic"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
-IUSE=""
+
RDEPEND="dev-lang/perl
dev-perl/Net-DNS
dev-perl/net-ping
@@ -21,59 +20,58 @@ RDEPEND="dev-lang/perl
dev-perl/URI
dev-perl/Digest-Nilsimsa"
+S=${WORKDIR}/razor-agents-${PV}
+
src_unpack() {
unpack ${A}
cd ${S}
- patch --no-backup-if-mismatch -p0 < ${FILESDIR}/razor-taint.patch
+ EPATCH_OPTS="--no-backup-if-mismatch" \
+ epatch ${FILESDIR}/razor-taint.patch #29156
}
src_install() {
-
-# seems broken in 2.36 (rac)
-# patch -p1 < ${FILESDIR}/razor_uninstall.patch
-
+ epatch ${FILESDIR}/no-install-razor-agents.patch #31365
perl-module_src_install
}
pkg_postinst() {
-
-# insures appropriate symlinks have been created
+ # insures appropriate symlinks have been created
/usr/bin/razor-client
-einfo "Run 'razor-admin -create' to create a default config file in your"
-einfo "home directory under /home/user/.razor. (Remember to change user to"
-einfo "your username from root before running razor-admin)"
-einfo ""
-einfo "Razor v2 requires reporters to be registered so their reputations can"
-einfo "be computed over time and they can participate in the revocation"
-einfo "mechanism. Registration is done with razor-admin -register. It has to be"
-einfo "manually invoked in either of the following ways:"
-einfo ""
-einfo "To register user foo with 's1kret' as password: "
-einfo ""
-einfo "razor-admin -register -user=foo -pass=s1kr3t"
-einfo ""
-einfo "To register with an email address and have the password assigned:"
-einfo ""
-einfo "razor-admin -register -user=foo@bar.com "
-einfo ""
-einfo "To have both (random) username and password assgined: "
-einfo ""
-einfo "razor-admin -register "
-einfo ""
-einfo "razor-admin -register negotiates a registration with the Nomination Server"
-einfo "and writes the identity information in"
-einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
-einfo "when invoked as root."
-einfo ""
-einfo "You can edit razor-agent.conf to change the defaults. Config options"
-einfo "and their values are defined in the razor-agent.conf(5) manpage."
+ einfo "Run 'razor-admin -create' to create a default config file in your"
+ einfo "home directory under /home/user/.razor. (Remember to change user to"
+ einfo "your username from root before running razor-admin)"
+ einfo ""
+ einfo "Razor v2 requires reporters to be registered so their reputations can"
+ einfo "be computed over time and they can participate in the revocation"
+ einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+ einfo "manually invoked in either of the following ways:"
+ einfo ""
+ einfo "To register user foo with 's1kret' as password: "
+ einfo ""
+ einfo "razor-admin -register -user=foo -pass=s1kr3t"
+ einfo ""
+ einfo "To register with an email address and have the password assigned:"
+ einfo ""
+ einfo "razor-admin -register -user=foo@bar.com "
+ einfo ""
+ einfo "To have both (random) username and password assgined: "
+ einfo ""
+ einfo "razor-admin -register "
+ einfo ""
+ einfo "razor-admin -register negotiates a registration with the Nomination Server"
+ einfo "and writes the identity information in"
+ einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+ einfo "when invoked as root."
+ einfo ""
+ einfo "You can edit razor-agent.conf to change the defaults. Config options"
+ einfo "and their values are defined in the razor-agent.conf(5) manpage."
-einfo "The next step is to integrate razor-check, razor-report and"
-einfo "razor-revoke in your mail system. If you are running Razor v1, the"
-einfo "change will be transparent, new versions of razor agents will overwrite"
-einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
-einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
-einfo "refer to manpages of razor-check(1), razor-report(1), and"
-einfo "razor-revoke(1) for integration instructions."
+ einfo "The next step is to integrate razor-check, razor-report and"
+ einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+ einfo "change will be transparent, new versions of razor agents will overwrite"
+ einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+ einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+ einfo "refer to manpages of razor-check(1), razor-report(1), and"
+ einfo "razor-revoke(1) for integration instructions."
}