summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-28 21:01:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-28 21:01:46 +0000
commite5b4a0808557eb2b93b60a801853a81624ff0eef (patch)
treed1727cd930e28f5d1668480d818cca0beff8ec3e /net-mail/spampd
parentinitial import (diff)
downloadgentoo-2-e5b4a0808557eb2b93b60a801853a81624ff0eef.tar.gz
gentoo-2-e5b4a0808557eb2b93b60a801853a81624ff0eef.tar.bz2
gentoo-2-e5b4a0808557eb2b93b60a801853a81624ff0eef.zip
initial import
Diffstat (limited to 'net-mail/spampd')
-rw-r--r--net-mail/spampd/ChangeLog8
-rw-r--r--net-mail/spampd/Manifest12
-rw-r--r--net-mail/spampd/files/conf15
-rw-r--r--net-mail/spampd/files/digest-spampd-2.111
-rw-r--r--net-mail/spampd/files/init23
-rw-r--r--net-mail/spampd/spampd-2.11.ebuild28
6 files changed, 79 insertions, 8 deletions
diff --git a/net-mail/spampd/ChangeLog b/net-mail/spampd/ChangeLog
new file mode 100644
index 000000000000..ccaa078728a1
--- /dev/null
+++ b/net-mail/spampd/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/spampd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/spampd/ChangeLog,v 1.1 2003/10/28 21:01:43 mkennedy Exp $
+
+*spampd-2.11 (28 Oct 2003)
+
+ 29 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import. Ebuild submitted by Matthew Kennedy <mkennedy@gentoo.org>.
diff --git a/net-mail/spampd/Manifest b/net-mail/spampd/Manifest
index 034773158deb..71a846f579bf 100644
--- a/net-mail/spampd/Manifest
+++ b/net-mail/spampd/Manifest
@@ -1,9 +1,5 @@
-MD5 125ee013081b112d56a1d15507d72ef2 ChangeLog 3674
-MD5 8321ae5a394ee2753d2866ccf034c26e spampd-2.11.ebuild 755
-MD5 652f011c07ca925858993d5f54bc1f06 spampd-2.11.ebuild~ 6006
-MD5 1e34acdec1e0c4fba52c1bb8bfe5c40d files/spampd 530
-MD5 75f63bbe5826a1dc1d9edf101282d9d0 files/spampd~ 521
-MD5 c9efd570a978de5facf622f10016df45 files/conf 102
-MD5 1ed9c6ddcb224ed5d2ad37aab7c0cce9 files/conf~ 265
-MD5 eb9df4ffefd7eddb3fabe8d2a832ca39 files/#conf# 105
+MD5 239935133003b7ffc30d0eab7bbf3eef ChangeLog 375
+MD5 52f644fca930d57b9b6f35a73450fced spampd-2.11.ebuild 850
+MD5 be10be310953d7a8f9eeef39e43fedaf files/init 543
+MD5 8dc3caf9e82a80473c41b5d1e64bbbd5 files/conf 665
MD5 17b3ddc9a6650576cdaddbc62052fe0b files/digest-spampd-2.11 62
diff --git a/net-mail/spampd/files/conf b/net-mail/spampd/files/conf
new file mode 100644
index 000000000000..64abe21dd1b0
--- /dev/null
+++ b/net-mail/spampd/files/conf
@@ -0,0 +1,15 @@
+# This is the configuration file that /etc/init.d/spampd sources when
+# started.
+
+# SPAMPD_OPTS defines the command-line arguments to be passed to the
+# spampd daemon upon start-up. A complete list of options can be
+# found in the documentation, or by issuing the command
+# "/usr/sbin/spampd --help"
+
+SPAMPD_OPTS="--host=localhost:10025 --relayhost=localhost:10026 --tagall"
+
+# Note: (from the Installation section in the spampd documentation)
+# "Note that spampd replaces spamd from the SpamAssassin distribution
+# in function. You do not need to run spamd in order for spampd to
+# work. This has apparently been the source of some confusion, so now
+# you know."
diff --git a/net-mail/spampd/files/digest-spampd-2.11 b/net-mail/spampd/files/digest-spampd-2.11
new file mode 100644
index 000000000000..32106a4b7529
--- /dev/null
+++ b/net-mail/spampd/files/digest-spampd-2.11
@@ -0,0 +1 @@
+MD5 5f697879767ce39a24981030ce5c6c5c spampd-2.11.tar.gz 28401
diff --git a/net-mail/spampd/files/init b/net-mail/spampd/files/init
new file mode 100644
index 000000000000..a4b3ae3bbb6f
--- /dev/null
+++ b/net-mail/spampd/files/init
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+# Note: spampd configuration file is /etc/conf.d/spampd
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting spampd"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/spampd -- --pid=/var/run/spampd.pid \
+ ${SPAMPD_OPTS}
+ eend $? "Failed to start spampd"
+}
+
+stop() {
+ ebegin "Stopping spampd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/spamd.pid
+ eend $? "Failed to stop spampd"
+}
diff --git a/net-mail/spampd/spampd-2.11.ebuild b/net-mail/spampd/spampd-2.11.ebuild
new file mode 100644
index 000000000000..de01fb03ca9d
--- /dev/null
+++ b/net-mail/spampd/spampd-2.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/spampd/spampd-2.11.ebuild,v 1.1 2003/10/28 21:01:43 mkennedy Exp $
+
+DESCRIPTION="spampd is a program used within an e-mail delivery system to scan messages for possible Unsolicited Commercial E-mail content."
+HOMEPAGE="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
+SRC_URI="mirrors://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/net-server
+ dev-perl/Mail-SpamAssassin"
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ dosbin spampd
+ dodoc COPYING README.Gentoo changelog.txt spampd-rh-rc-script
+ dohtml spampd.html
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/init spampd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf spampd
+}