summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 03:47:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 03:47:04 +0000
commit3cba1d57f5824dc4ef4964ff37a9f67f192e4ed8 (patch)
treed50e7f9f1d238f8b3dfb53642815890851e543bb /net-mail/vm-pop3d
parent$DEBUGBUILD -> use debug (diff)
downloadgentoo-2-3cba1d57f5824dc4ef4964ff37a9f67f192e4ed8.tar.gz
gentoo-2-3cba1d57f5824dc4ef4964ff37a9f67f192e4ed8.tar.bz2
gentoo-2-3cba1d57f5824dc4ef4964ff37a9f67f192e4ed8.zip
$DEBUG -> use debug
Diffstat (limited to 'net-mail/vm-pop3d')
-rw-r--r--net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild43
1 files changed, 14 insertions, 29 deletions
diff --git a/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild b/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
index 6b79a205845e..54e144324fa0 100644
--- a/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
+++ b/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild
@@ -1,48 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild,v 1.7 2003/02/13 14:43:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vm-pop3d/vm-pop3d-1.1.6.ebuild,v 1.8 2003/08/03 03:45:46 vapier Exp $
-S=${WORKDIR}/${P}
-
-DESCRIPTION="vm-pop3d - vm-pop3d is a POP3 server"
-SRC_URI="http://www.ibiblio.org/pub/Linux/system/mail/pop/${P}.tar.gz"
+DESCRIPTION="POP3 server"
HOMEPAGE="http://www.reedmedia.net/software/virtualmail-pop3d/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/system/mail/pop/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="pam debug"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc
+ pam? ( sys-libs/pam )"
src_unpack() {
-
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/makefile.in.diff || die "patch failed"
-
+ epatch ${FILESDIR}/makefile.in.diff
}
src_compile() {
-
- local myconf
-
- use pam && myconf="${myconf} --enable-pam" \
- || myconf="${myconf} --disable-pam "
-
- if [ -n "$DEBUG" ]; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- econf ${myconf} || die "configure failed"
-
+ econf \
+ `use_enable pam` \
+ `use_enable debug` \
+ || die "configure failed"
emake || die "make failed"
-
}
-src_install () {
-
+src_install() {
einstall || die "make install failed"
dodoc AUTHORS CHANGES COPYING FAQ INSTALL README TODO
@@ -51,5 +37,4 @@ src_install () {
newexe ${FILESDIR}/vm-pop3d.rc3 vm-pop3d
insinto /etc/conf.d
newins ${FILESDIR}/vm-pop3d.confd vm-pop3d
-
}