summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-02-15 20:15:03 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-02-15 20:15:03 +0000
commit5a968a6fd6debf9dc79c8f03caec81fa4c22e88d (patch)
tree0894093d00bf062138cf621f790c78a98d126bcc /net-mail
parentStable for amd64 wrt bug #495720 (diff)
downloadgentoo-2-5a968a6fd6debf9dc79c8f03caec81fa4c22e88d.tar.gz
gentoo-2-5a968a6fd6debf9dc79c8f03caec81fa4c22e88d.tar.bz2
gentoo-2-5a968a6fd6debf9dc79c8f03caec81fa4c22e88d.zip
Don't call gcc directly, honor CC and CXX. Fixes bug #500864.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog5
-rw-r--r--net-mail/notmuch/notmuch-0.17.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index ea022102f1bf..b98c785faaa0 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.85 2014/01/02 19:48:30 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.86 2014/02/15 20:15:03 aidecoe Exp $
+
+ 15 Feb 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.17.ebuild:
+ Don't call gcc directly, honor CC and CXX. Fixes bug #500864.
02 Jan 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> -notmuch-0.12.ebuild,
-notmuch-0.13.1.ebuild, -notmuch-0.14-r1.ebuild:
diff --git a/net-mail/notmuch/notmuch-0.17.ebuild b/net-mail/notmuch/notmuch-0.17.ebuild
index 7631297cc3a9..ea5421807641 100644
--- a/net-mail/notmuch/notmuch-0.17.ebuild
+++ b/net-mail/notmuch/notmuch-0.17.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.17.ebuild,v 1.1 2014/01/02 19:43:36 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.17.ebuild,v 1.2 2014/02/15 20:15:03 aidecoe Exp $
EAPI=5
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit elisp-common eutils pax-utils distutils-r1
+inherit elisp-common eutils pax-utils distutils-r1 toolchain-funcs
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="http://notmuchmail.org/"
@@ -93,6 +93,7 @@ src_configure() {
$(use_with emacs)
$(use_with zsh-completion)
)
+ tc-export CC CXX
econf "${myeconfargs[@]}"
}