summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-11 10:21:58 +0000
committerParag Mehta <pm@gentoo.org>2001-07-11 10:21:58 +0000
commit9f3f22665363ad101b9bba7cc6a373b16a3055a4 (patch)
treee38d8516b3bdc43e8d96be235ec04000fedcaca2 /net-mail
parentadded digest files and modified squid compile options to also use -arp-acl, i... (diff)
downloadgentoo-2-9f3f22665363ad101b9bba7cc6a373b16a3055a4.tar.gz
gentoo-2-9f3f22665363ad101b9bba7cc6a373b16a3055a4.tar.bz2
gentoo-2-9f3f22665363ad101b9bba7cc6a373b16a3055a4.zip
New version
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/fetchmail-5.8.13.ebuild40
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.8.131
2 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.8.13.ebuild b/net-mail/fetchmail/fetchmail-5.8.13.ebuild
new file mode 100644
index 000000000000..35bf022ee6a9
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.8.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="fetchmail"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/"${P}.tar.gz
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ] ; then
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ myconf="--with-ssl"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} --enable-inet6 \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-RPA --enable-NTLN \
+ --enable-SDPS $myconf
+ try make
+}
+
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM README.SSL \
+ TODO COPYING MANIFEST
+ docinto html
+ dodoc *.html
+ docinto contrib
+ dodoc contrib/*
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.8.13 b/net-mail/fetchmail/files/digest-fetchmail-5.8.13
new file mode 100644
index 000000000000..b89f47db6e83
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.8.13
@@ -0,0 +1 @@
+MD5 29b305208e771219269e077f7f26abb4 fetchmail-5.8.13.tar.gz