summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-04-25 03:52:30 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-04-25 03:52:30 +0000
commita27c6753a05df89c85068a9ac1fe638942464482 (patch)
treeb4687c6d0bb29f257f1611ea75077563a818c8ec /net-mail
parentVersion bump. Also fixes many MIME related issues - make launching of chm fil... (diff)
downloadgentoo-2-a27c6753a05df89c85068a9ac1fe638942464482.tar.gz
gentoo-2-a27c6753a05df89c85068a9ac1fe638942464482.tar.bz2
gentoo-2-a27c6753a05df89c85068a9ac1fe638942464482.zip
Version bump.
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.7.43
-rw-r--r--net-mail/getmail/getmail-4.7.4.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 4e558db574ff..7be9d6a1008e 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.147 2007/04/16 20:14:15 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.148 2007/04/25 03:52:30 ticho Exp $
+
+*getmail-4.7.4 (25 Apr 2007)
+
+ 25 Apr 2007; Andrej Kacian <ticho@gentoo.org> +getmail-4.7.4.ebuild:
+ Version bump.
16 Apr 2007; Daniel Gryniewicz <dang@gentoo.org> getmail-4.7.2.ebuild:
Marked stable on amd64 for bug #172722
diff --git a/net-mail/getmail/files/digest-getmail-4.7.4 b/net-mail/getmail/files/digest-getmail-4.7.4
new file mode 100644
index 000000000000..75db67696497
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.7.4
@@ -0,0 +1,3 @@
+MD5 4324745975c04646ef4a40b512548459 getmail-4.7.4.tar.gz 148558
+RMD160 70ba8fa7e507240e41a601a0ac222a2bfc32b85f getmail-4.7.4.tar.gz 148558
+SHA256 384546ff4a612ec4d354251397a0017684794cceb0f191d40a2b457e9e04e869 getmail-4.7.4.tar.gz 148558
diff --git a/net-mail/getmail/getmail-4.7.4.ebuild b/net-mail/getmail/getmail-4.7.4.ebuild
new file mode 100644
index 000000000000..e1c99b8d4d5a
--- /dev/null
+++ b/net-mail/getmail/getmail-4.7.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.7.4.ebuild,v 1.1 2007/04/25 03:52:30 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}