summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-01 01:51:12 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-01 01:51:12 +0000
commitca22e8d4750d473c0c558743994f35d0a33efd0c (patch)
tree40d62f08b4f364be4a173b30fc6fd429570b2286 /net-mail
parentRemove old. (diff)
downloadgentoo-2-ca22e8d4750d473c0c558743994f35d0a33efd0c.tar.gz
gentoo-2-ca22e8d4750d473c0c558743994f35d0a33efd0c.tar.bz2
gentoo-2-ca22e8d4750d473c0c558743994f35d0a33efd0c.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/libpst/ChangeLog9
-rw-r--r--net-mail/libpst/libpst-0.6.54.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/net-mail/libpst/ChangeLog b/net-mail/libpst/ChangeLog
index 78b21c718b47..78a74e8357ce 100644
--- a/net-mail/libpst/ChangeLog
+++ b/net-mail/libpst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/libpst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.24 2011/08/05 05:07:48 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.25 2012/01/01 01:51:12 radhermit Exp $
+
+*libpst-0.6.54 (01 Jan 2012)
+
+ 01 Jan 2012; Tim Harder <radhermit@gentoo.org> +libpst-0.6.54.ebuild:
+ Version bump.
*libpst-0.6.53 (05 Aug 2011)
diff --git a/net-mail/libpst/libpst-0.6.54.ebuild b/net-mail/libpst/libpst-0.6.54.ebuild
new file mode 100644
index 000000000000..db7d94810076
--- /dev/null
+++ b/net-mail/libpst/libpst-0.6.54.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.54.ebuild,v 1.1 2012/01/01 01:51:12 radhermit Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://www.five-ten-sg.com/libpst/"
+SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dii doc python static-libs"
+
+RDEPEND="dii? ( media-gfx/imagemagick[png] )"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ dii? ( media-libs/gd[png] )
+ python? ( >=dev-libs/boost-1.35.0-r5[python] )"
+
+src_prepare() {
+ # Don't build the static python library
+ epatch "${FILESDIR}"/${PN}-0.6.52-no-static-python-lib.patch
+
+ # Fix pkgconfig file for static linking
+ epatch "${FILESDIR}"/${PN}-0.6.53-pkgconfig-static.patch
+
+ # Conditionally install the extra documentation
+ use doc || sed -i -e "/SUBDIRS/s: html::" Makefile.am
+
+ eautomake
+}
+
+src_configure() {
+ econf \
+ --enable-libpst-shared \
+ $(use_enable debug pst-debug) \
+ $(use_enable dii) \
+ $(use_enable python) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove useless .la files
+ find "${ED}" -name '*.la' -exec rm {} +
+}