summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-10-17 18:04:15 +0000
committerTorsten Veller <tove@gentoo.org>2009-10-17 18:04:15 +0000
commitfd2930d67b27182c1a50f8bb0a32c78975390782 (patch)
tree43a279b320fc0a5c26aa81776b6d55766ce5e86f /net-mail
parentCleanup (diff)
downloadgentoo-2-fd2930d67b27182c1a50f8bb0a32c78975390782.tar.gz
gentoo-2-fd2930d67b27182c1a50f8bb0a32c78975390782.tar.bz2
gentoo-2-fd2930d67b27182c1a50f8bb0a32c78975390782.zip
Depend on libvformat (#264584)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lbdb/ChangeLog9
-rw-r--r--net-mail/lbdb/lbdb-0.36-r1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index 61c18a88092e..fca38cd05a7a 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lbdb
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.44 2008/12/25 20:45:59 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.45 2009/10/17 18:04:15 tove Exp $
+
+*lbdb-0.36-r1 (17 Oct 2009)
+
+ 17 Oct 2009; Torsten Veller <tove@gentoo.org> +lbdb-0.36-r1.ebuild:
+ Depend on libvformat (#264584)
25 Dec 2008; Torsten Veller <tove@gentoo.org> -lbdb-0.34.ebuild,
-lbdb-0.35.1.ebuild:
diff --git a/net-mail/lbdb/lbdb-0.36-r1.ebuild b/net-mail/lbdb/lbdb-0.36-r1.ebuild
new file mode 100644
index 000000000000..9dd948ed8bec
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.36-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.36-r1.ebuild,v 1.1 2009/10/17 18:04:15 tove Exp $
+
+inherit versionator eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger nis abook crypt evo"
+
+DEPEND="dev-libs/libvformat
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_compile() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if useq evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/$(get_version_component_range 1-2 ${evoversion})/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb || die
+ emake || die
+}
+
+src_install () {
+ emake install_prefix="${D}" install || die
+ dodoc README TODO debian/changelog
+}