summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-09 02:02:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-09 02:02:06 +0000
commit90c7c24a871f4e33112b45187e5df7ae5cd3ffaa (patch)
tree9b276bead0ab2d94e2961411f3f5e5781f6be1c2 /net-misc/arm
parentVersion bump (diff)
downloadgentoo-2-90c7c24a871f4e33112b45187e5df7ae5cd3ffaa.tar.gz
gentoo-2-90c7c24a871f4e33112b45187e5df7ae5cd3ffaa.tar.bz2
gentoo-2-90c7c24a871f4e33112b45187e5df7ae5cd3ffaa.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/arm')
-rw-r--r--net-misc/arm/ChangeLog7
-rw-r--r--net-misc/arm/arm-1.4.1.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/arm/ChangeLog b/net-misc/arm/ChangeLog
index bd846fac433c..a4cf8bd548ed 100644
--- a/net-misc/arm/ChangeLog
+++ b/net-misc/arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/arm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.4 2011/01/09 01:30:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.5 2011/01/09 02:02:06 blueness Exp $
+
+*arm-1.4.1.0 (09 Jan 2011)
+
+ 09 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +arm-1.4.1.0.ebuild:
+ Version bump
*arm-1.4.0.2-r1 (09 Jan 2011)
diff --git a/net-misc/arm/arm-1.4.1.0.ebuild b/net-misc/arm/arm-1.4.1.0.ebuild
new file mode 100644
index 000000000000..933c2c6404c4
--- /dev/null
+++ b/net-misc/arm/arm-1.4.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/arm-1.4.1.0.ebuild,v 1.1 2011/01/09 02:02:06 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+
+inherit python distutils
+
+DESCRIPTION="A ncurses-based status monitor for Tor relays"
+HOMEPAGE="http://www.atagar.com/arm/"
+SRC_URI="http://www.atagar.com/arm/resources/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/tor-0.2.1.27"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s:^docPath =.*$:docPath = \"/usr/share/doc/${PF}\":" setup.py
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+pkg_postinst() {
+ elog "Some graphing data issues have been noted in testing"
+ elog "when run as root. It is not recommended to run arm as"
+ elog "root until those issues have been isolated and fixed."
+ elog
+ elog "Trouble with graphs under app-misc/screen? Try:"
+ elog 'TERM="rxvt-unicode" arm'
+}