summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-08-27 22:25:39 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-08-27 22:25:39 +0000
commitdc976d605e504a364ba14e80ce6729320e00c7b9 (patch)
treee83ce0def19d7d17e1721e36189ea7d30ff386a7 /net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild
parentStable on hppa. (diff)
downloadgentoo-2-dc976d605e504a364ba14e80ce6729320e00c7b9.tar.gz
gentoo-2-dc976d605e504a364ba14e80ce6729320e00c7b9.tar.bz2
gentoo-2-dc976d605e504a364ba14e80ce6729320e00c7b9.zip
Initial import.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild')
-rw-r--r--net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild b/net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild
new file mode 100644
index 000000000000..384ccef6cf96
--- /dev/null
+++ b/net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_authenticate_ldap/asterisk-app_authenticate_ldap-0.1.3.ebuild,v 1.1 2005/08/27 22:25:39 stkn Exp $
+
+inherit eutils
+
+MY_PN="app_authenticate_ldap"
+
+DESCRIPTION="Asterisk application plugin for authentication using LDAP"
+HOMEPAGE="http://www.ionidea.ua/oss/asterisk/"
+SRC_URI="http://www.ionidea.ua/oss/asterisk/${MY_PN}-${PV}.tar.gz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# depends on iconv support
+DEPEND="sys-libs/glibc
+ >=net-misc/asterisk-1.0.7-r1
+ net-misc/asterisk-app_ldap"
+
+S=${WORKDIR}/apps
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.1.3-astcfg.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README.Authenticate_LDAP
+}