summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-02-20 20:48:51 +0000
committerPeter Weller <welp@gentoo.org>2008-02-20 20:48:51 +0000
commit278c73a1b2dee7ff1676c43f5221ae78f1452a9c (patch)
tree2cbad3f2138bfa174472dbce64a8b10704dbe874 /net-misc/dhcpcd
parentAdd support for ESCM_LOGDIR using pkg_preinst. (diff)
downloadgentoo-2-278c73a1b2dee7ff1676c43f5221ae78f1452a9c.tar.gz
gentoo-2-278c73a1b2dee7ff1676c43f5221ae78f1452a9c.tar.bz2
gentoo-2-278c73a1b2dee7ff1676c43f5221ae78f1452a9c.zip
Bump to 3.2.2
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.2.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 2b643f9c8a00..636bdc8304ae 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.177 2008/01/29 12:04:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.178 2008/02/20 20:48:51 welp Exp $
+
+*dhcpcd-3.2.2 (20 Feb 2008)
+
+ 20 Feb 2008; <welp@gentoo.org> +dhcpcd-3.2.2.ebuild:
+ Bump to 3.2.2
*dhcpcd-3.2.1 (29 Jan 2008)
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild
new file mode 100644
index 000000000000..50d4fcf46980
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.2.ebuild,v 1.1 2008/02/20 20:48:51 welp Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/dhcpcd"
+SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="vram zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use zeroconf; then
+ elog "ZeroConf support enabled"
+ else
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "/* User indicated no zeroconf support */"
+ echo "#undef ENABLE_IPV4LL"
+ } >> config.h
+ fi
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ elog "Disabling DUID support"
+ {
+ echo
+ echo "/* User indicated volatile ram storage */"
+ echo "#undef ENABLE_DUID"
+ } >> config.h
+ else
+ elog "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" INFODIR=/var/lib/dhcpcd || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ if [ -e "${duid}" ] && ! grep -q '..:..:..:..:..:..' "${duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ if ! use vram; then
+ use zeroconf && echo
+ elog "You have installed dhcpcd with DUID support."
+ elog "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ elog "This is generated from a MAC address of the card and a timestamp."
+ elog "It will be used in every subsequent DHCP transaction, along with a IAID"
+ elog "in the ClientID option. This is required by RFC 4361."
+ echo
+ elog "Some DHCP server implementations require a MAC address only in the"
+ elog "ClientID field. These DHCP servers should be updated to be RFC"
+ elog "conformant. If you cannot do this, you can revert to the old"
+ elog "behaviour by using the -I '' option OR building dhcpcd with the"
+ elog "vram USE flag enabled."
+ fi
+}