summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-01-25 11:06:28 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-01-25 11:06:28 +0000
commitaf1f2218d1188f6e14f0c985e40d5116120736af (patch)
treeb8d3821067e64d795305f79110a90c84553f8133 /net-misc/dhcpcd
parentRecommit Manifest. (diff)
downloadgentoo-2-af1f2218d1188f6e14f0c985e40d5116120736af.tar.gz
gentoo-2-af1f2218d1188f6e14f0c985e40d5116120736af.tar.bz2
gentoo-2-af1f2218d1188f6e14f0c985e40d5116120736af.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.0.ebuild81
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-3.2.03
3 files changed, 90 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 39ee6e988e21..9154d0184a2b 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.174 2008/01/09 19:44:57 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.175 2008/01/25 11:06:27 armin76 Exp $
+
+*dhcpcd-3.2.0 (25 Jan 2008)
+
+ 25 Jan 2008; Raúl Porcel <armin76@gentoo.org> +dhcpcd-3.2.0.ebuild:
+ Version bump
09 Jan 2008; <welp@gentoo.org> dhcpcd-3.1.9.ebuild:
Replace all instances of ewarn and einfo with elog
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild
new file mode 100644
index 000000000000..98518dd8b514
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.0.ebuild,v 1.1 2008/01/25 11:06:27 armin76 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/dhcpcd"
+SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="vram zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use zeroconf; then
+ elog "ZeroConf support enabled"
+ else
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "/* User indicated no zeroconf support */"
+ echo "#undef ENABLE_IPV4LL"
+ } >> config.h
+ fi
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ elog "Disabling DUID support"
+ {
+ echo
+ echo "/* User indicated volatile ram storage */"
+ echo "#undef ENABLE_DUID"
+ } >> config.h
+ else
+ elog "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" INFODIR=/var/lib/dhcpcd || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ if ! use vram; then
+ use zeroconf && echo
+ elog "You have installed dhcpcd with DUID support."
+ elog "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ elog "This is generated from a MAC address of the card and a timestamp."
+ elog "It will be used in every subsequent DHCP transaction, along with a IAID"
+ elog "in the ClientID option. This is required by RFC 4361."
+ echo
+ elog "Some DHCP server implementations require a MAC address only in the"
+ elog "ClientID field. These DHCP servers should be updated to be RFC"
+ elog "conformant. If you cannot do this, you can revert to the old"
+ elog "behaviour by using the -I '' option OR building dhcpcd with the"
+ elog "vram USE flag enabled."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-3.2.0 b/net-misc/dhcpcd/files/digest-dhcpcd-3.2.0
new file mode 100644
index 000000000000..58f0ac816382
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-3.2.0
@@ -0,0 +1,3 @@
+MD5 59947ab6dac3f777fb2c1000ebc1bd2b dhcpcd-3.2.0.tar.bz2 43896
+RMD160 ac0ce60e50671a82edc14166bf9f745e297cd305 dhcpcd-3.2.0.tar.bz2 43896
+SHA256 bd82a59400d74d26dd48e998d8b3f539fa3eb46e8d5cb969aa5311d3f21204ef dhcpcd-3.2.0.tar.bz2 43896