summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2015-02-26 06:57:43 +0000
committerAaron Bauman <bman@gentoo.org>2015-02-26 06:57:43 +0000
commitea7da90ac4614480d2f88d46f99a4d1d74c25b60 (patch)
treea4812d4da7a485fa1db314e3fced4725ccd8c77c /net-misc/gns3-gui
parentversion bump to 1.2.3 (diff)
downloadgentoo-2-ea7da90ac4614480d2f88d46f99a4d1d74c25b60.tar.gz
gentoo-2-ea7da90ac4614480d2f88d46f99a4d1d74c25b60.tar.bz2
gentoo-2-ea7da90ac4614480d2f88d46f99a4d1d74c25b60.zip
version bump to 1.2.3
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-misc/gns3-gui')
-rw-r--r--net-misc/gns3-gui/ChangeLog9
-rw-r--r--net-misc/gns3-gui/gns3-gui-1.2.3.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/net-misc/gns3-gui/ChangeLog b/net-misc/gns3-gui/ChangeLog
index d5dc1f7a71ce..04bf2ce2968d 100644
--- a/net-misc/gns3-gui/ChangeLog
+++ b/net-misc/gns3-gui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/gns3-gui
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gns3-gui/ChangeLog,v 1.2 2014/11/22 10:53:33 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gns3-gui/ChangeLog,v 1.3 2015/02/26 06:57:43 bman Exp $
+
+*gns3-gui-1.2.3 (26 Feb 2015)
+
+ 26 Feb 2015; <aaron@gentoo.org> +gns3-gui-1.2.3.ebuild:
+ version bump to 1.2.3
*gns3-gui-1.2 (22 Nov 2014)
diff --git a/net-misc/gns3-gui/gns3-gui-1.2.3.ebuild b/net-misc/gns3-gui/gns3-gui-1.2.3.ebuild
new file mode 100644
index 000000000000..a4e925ce7872
--- /dev/null
+++ b/net-misc/gns3-gui/gns3-gui-1.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gns3-gui/gns3-gui-1.2.3.ebuild,v 1.1 2015/02/26 06:57:43 bman Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Graphical Network Simulator"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#net-misc/gns3-server version should always match gns3-gui version
+#block net-misc/gns3 as it conflicts
+
+RDEPEND=">=dev-python/libcloud-0.15.1[${PYTHON_USEDEP}]
+ >=dev-python/ws4py-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.13.0[${PYTHON_USEDEP}]
+ !=dev-python/PyQt4-4.11.3_pre20141024[${PYTHON_USEDEP}]
+ >=dev-python/PyQt4-4.11.2[X,svg,${PYTHON_USEDEP}]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ net-misc/gns3-converter[${PYTHON_USEDEP}]
+ =net-misc/gns3-server-$PV[${PYTHON_USEDEP}]
+ !!net-misc/gns3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # avoid file collisions caused by required tests
+ sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doicon "${WORKDIR}/${P}/resources/images/gns3.ico"
+ make_desktop_entry "gns3" "GNS3" "/usr/share/pixmaps/gns3.ico" "Utility"
+}