summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-04-09 19:26:10 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-04-09 19:26:10 +0000
commit5f6a519981e2170ff4d031a9cbbb2145ac42e901 (patch)
tree9dd029002d327a5324c73765597e3fc7566ed67c /net-misc/icecast
parentVersion bump. (diff)
downloadgentoo-2-5f6a519981e2170ff4d031a9cbbb2145ac42e901.tar.gz
gentoo-2-5f6a519981e2170ff4d031a9cbbb2145ac42e901.tar.bz2
gentoo-2-5f6a519981e2170ff4d031a9cbbb2145ac42e901.zip
Security bump (bug #545968). Fixed slot dependency on openssl
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog10
-rw-r--r--net-misc/icecast/icecast-2.4.1.ebuild6
-rw-r--r--net-misc/icecast/icecast-2.4.2.ebuild83
3 files changed, 94 insertions, 5 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index a555106ae9bc..298ae6f99e1b 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.109 2014/12/06 09:37:13 polynomial-c Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.110 2015/04/09 19:26:10 polynomial-c Exp $
+
+*icecast-2.4.2 (09 Apr 2015)
+
+ 09 Apr 2015; Lars Wendler <polynomial-c@gentoo.org> icecast-2.4.1.ebuild,
+ +icecast-2.4.2.ebuild:
+ Security bump (bug #545968). Fixed slot dependency on openssl.
06 Dec 2014; Lars Wendler <polynomial-c@gentoo.org> -icecast-2.3.3-r2.ebuild,
-icecast-2.3.3-r3.ebuild, -icecast-2.4.0.ebuild, -files/init.d.icecast,
diff --git a/net-misc/icecast/icecast-2.4.1.ebuild b/net-misc/icecast/icecast-2.4.1.ebuild
index 062a68945e07..a925839db417 100644
--- a/net-misc/icecast/icecast-2.4.1.ebuild
+++ b/net-misc/icecast/icecast-2.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.4.1.ebuild,v 1.5 2014/12/03 09:56:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.4.1.ebuild,v 1.6 2015/04/09 19:26:10 polynomial-c Exp $
EAPI=5
inherit eutils autotools systemd user
@@ -25,7 +25,7 @@ DEPEND="dev-libs/libxslt
speex? ( media-libs/speex )
theora? ( media-libs/libtheora )
yp? ( net-misc/curl )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
pkg_setup() {
diff --git a/net-misc/icecast/icecast-2.4.2.ebuild b/net-misc/icecast/icecast-2.4.2.ebuild
new file mode 100644
index 000000000000..540d3387fa90
--- /dev/null
+++ b/net-misc/icecast/icecast-2.4.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.4.2.ebuild,v 1.1 2015/04/09 19:26:10 polynomial-c Exp $
+
+EAPI=5
+inherit eutils autotools systemd user
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="kate logrotate +speex +ssl +theora +yp"
+
+#Although there is a --with-ogg and --with-orbis configure option, they're
+#only useful for specifying paths, not for disabling.
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ media-libs/libogg
+ media-libs/libvorbis
+ kate? ( media-libs/libkate )
+ logrotate? ( app-admin/logrotate )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )
+ ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewuser icecast -1 -1 -1 nogroup
+}
+
+src_prepare() {
+ # bug #368539
+ epatch "${FILESDIR}"/${PN}-2.3.3-libkate.patch
+ # bug #430434
+ epatch "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable kate) \
+ $(use_with theora) \
+ $(use_with speex) \
+ $(use_with yp curl) \
+ $(use_with ssl openssl) \
+ $(use_enable yp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+
+ newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/icecast2
+ doins "${FILESDIR}"/icecast.xml
+ fperms 600 /etc/icecast2/icecast.xml
+
+ if use logrotate; then
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ fi
+ diropts -m0764 -o icecast -g nogroup
+ dodir /var/log/icecast
+ keepdir /var/log/icecast
+ rm -rf "${D}"/usr/share/doc/icecast
+}
+
+pkg_postinst() {
+ touch "${ROOT}"var/log/icecast/{access,error}.log
+ chown icecast:nogroup "${ROOT}"var/log/icecast/{access,error}.log
+}