summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2007-10-27 22:25:26 +0000
committerThilo Bangert <bangert@gentoo.org>2007-10-27 22:25:26 +0000
commitb044fe91342b6f7b979b598d123dc0b8d76f3027 (patch)
treec77e18291426f2b2f504b243e8c6941ee1aeba9a /net-misc/ipsvd/ipsvd-0.13.0.ebuild
parentRemoved old versions. (diff)
downloadgentoo-2-b044fe91342b6f7b979b598d123dc0b8d76f3027.tar.gz
gentoo-2-b044fe91342b6f7b979b598d123dc0b8d76f3027.tar.bz2
gentoo-2-b044fe91342b6f7b979b598d123dc0b8d76f3027.zip
add ipsvd - ipsvd is a set of internet protocol service daemons for Unix - thanks Dean Hall - bug #76522
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-misc/ipsvd/ipsvd-0.13.0.ebuild')
-rw-r--r--net-misc/ipsvd/ipsvd-0.13.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/ipsvd/ipsvd-0.13.0.ebuild b/net-misc/ipsvd/ipsvd-0.13.0.ebuild
new file mode 100644
index 000000000000..fa38df1e387e
--- /dev/null
+++ b/net-misc/ipsvd/ipsvd-0.13.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsvd/ipsvd-0.13.0.ebuild,v 1.1 2007/10/27 22:25:25 bangert Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="ipsvd is a set of internet protocol service daemons for Unix."
+HOMEPAGE="http://smarden.org/ipsvd/"
+SRC_URI="http://smarden.org/ipsvd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/inetd"
+
+S="${WORKDIR}/net/${P}"
+
+src_compile() {
+ cd ${S}/src
+ if use static ; then
+ append-ldflags -static
+ fi
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die "make failed"
+}
+
+src_install() {
+ cd ${S}
+ dobin src/{tcpsvd,udpsvd,ipsvd-cdb} || die "dobin"
+ dodoc package/{CHANGES,README}
+
+ dohtml doc/*.html
+ doman man/ipsvd-instruct.5 man/ipsvd.7 man/udpsvd.8 \
+ man/tcpsvd.8 man/ipsvd-cdb.8
+
+}