summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 04:02:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 04:02:36 +0000
commit8f0d67e1ea454c6de60fd8ff78f081159873b958 (patch)
tree33a600fd427eb09eff4a078cfbe34d2797067c52 /net-misc/iputils
parentAdd support to ipg for newer kernels #71756 by Christoph M. (Manifest recommit) (diff)
downloadgentoo-2-8f0d67e1ea454c6de60fd8ff78f081159873b958.tar.gz
gentoo-2-8f0d67e1ea454c6de60fd8ff78f081159873b958.tar.bz2
gentoo-2-8f0d67e1ea454c6de60fd8ff78f081159873b958.zip
patch shuffle
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/files/021109-syserror.patch9
-rw-r--r--net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch (renamed from net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch)0
-rw-r--r--net-misc/iputils/iputils-021109-r3.ebuild7
3 files changed, 12 insertions, 4 deletions
diff --git a/net-misc/iputils/files/021109-syserror.patch b/net-misc/iputils/files/021109-syserror.patch
new file mode 100644
index 000000000000..a4f94f409e38
--- /dev/null
+++ b/net-misc/iputils/files/021109-syserror.patch
@@ -0,0 +1,9 @@
+--- iputils/rdisc.c.orig 2005-01-03 22:53:27.852431840 -0500
++++ iputils/rdisc.c 2005-01-03 22:53:27.864430016 -0500
+@@ -1504,5 +1504,5 @@
+ if (logging)
+ syslog(LOG_ERR, "%s: %m", str);
+ else
+- (void) fprintf(stderr, "%s: %s\n", str, sys_errlist[errno]);
++ (void) fprintf(stderr, "%s: %s\n", str, strerror(errno));
+ }
diff --git a/net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch b/net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch
index e790d2b51038..e790d2b51038 100644
--- a/net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch
+++ b/net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch
diff --git a/net-misc/iputils/iputils-021109-r3.ebuild b/net-misc/iputils/iputils-021109-r3.ebuild
index adbf10c124f5..9142a744f783 100644
--- a/net-misc/iputils/iputils-021109-r3.ebuild
+++ b/net-misc/iputils/iputils-021109-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.14 2005/01/04 03:52:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.15 2005/01/04 04:02:36 vapier Exp $
inherit flag-o-matic gnuconfig eutils toolchain-funcs
@@ -39,6 +39,8 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-gcc34.patch
epatch ${FILESDIR}/${PV}-no-pfkey-search.patch
epatch ${FILESDIR}/${PV}-ipg-linux-2.6.patch #71756
+ epatch ${FILESDIR}/${PV}-syserror.patch
+ epatch ${FILESDIR}/${PV}-uclibc-no-ether_ntohost.patch
# make iputils work with newer glibc snapshots
epatch ${FILESDIR}/${P}-linux-udp-header.patch
@@ -57,9 +59,6 @@ src_unpack() {
sed -i "s:-ll:-lfl -L${ROOT}/usr/lib ${LDFLAGS}:" setkey/Makefile || die "sed setkey failed"
sed -i 's:yacc:bison -y:' libipsec/Makefile #59191
-
- use uclibc && sed -e 's/sys_errlist\[errno\]/strerror(errno)/' -i ${S}/rdisc.c
- use uclibc && epatch ${FILESDIR}/${PN}-20020927-no-ether_ntohost.patch
}
src_compile() {