summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-25 17:27:10 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-25 17:27:10 +0000
commit4e0758ee41f3a7522e7db75c4ded33f8f6e3329b (patch)
tree5ede68750a8bade05b0a5c2bcf71fe8273e57d9d /net-misc/italc/italc-2.0.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-4e0758ee41f3a7522e7db75c4ded33f8f6e3329b.tar.gz
gentoo-2-4e0758ee41f3a7522e7db75c4ded33f8f6e3329b.tar.bz2
gentoo-2-4e0758ee41f3a7522e7db75c4ded33f8f6e3329b.zip
net-misc/italc: Fix for gcc-4.7, #423183
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/italc/italc-2.0.0.ebuild')
-rw-r--r--net-misc/italc/italc-2.0.0.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/net-misc/italc/italc-2.0.0.ebuild b/net-misc/italc/italc-2.0.0.ebuild
index 4ec669d9fb84..a361405d80a4 100644
--- a/net-misc/italc/italc-2.0.0.ebuild
+++ b/net-misc/italc/italc-2.0.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/italc-2.0.0.ebuild,v 1.1 2012/05/27 15:34:52 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/italc-2.0.0.ebuild,v 1.2 2012/06/25 17:27:10 jlec Exp $
EAPI=4
-inherit qt4-r2 eutils cmake-utils
+inherit qt4-r2 eutils cmake-utils user
DESCRIPTION="Intelligent Teaching And Learning with Computers (iTALC) supports working with computers in school"
HOMEPAGE="http://italc.sourceforge.net/"
@@ -13,15 +13,14 @@ SRC_URI="mirror://sourceforge/italc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE=""
-PROPERTIES="interactive"
-RDEPEND="dev-libs/lzo
+RDEPEND="
+ dev-libs/lzo
+ dev-libs/openssl
sys-apps/tcp-wrappers
- virtual/jpeg
sys-libs/zlib
- dev-libs/openssl
+ virtual/jpeg
x11-libs/qt-core
x11-libs/qt-xmlpatterns
x11-libs/libICE
@@ -37,15 +36,16 @@ RDEPEND="dev-libs/lzo
DEPEND="${RDEPEND}
x11-proto/inputproto"
+PROPERTIES="interactive"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
+
+DOCS=( TODO README AUTHORS INSTALL ChangeLog )
+
pkg_setup() {
enewgroup italc
}
-src_install() {
- cmake-utils_src_install
- dodoc TODO README AUTHORS INSTALL ChangeLog
-}
-
pkg_postinst() {
elog "On the master, please run "
elog "# emerge --config =${CATEGORY}/${PF}"
@@ -53,7 +53,7 @@ pkg_postinst() {
elog "Please add the logins of master users (teachers) to the italc group by running"
elog "# usermod -a -G italc <loginname>"
- elog ""
+ echo ""
}
pkg_config() {