summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 08:05:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 08:05:30 +0000
commitad8c1ec29cabe106543ef50d7e0ca039d52f8e20 (patch)
tree0b51e436aff72d915a5821fed36cfd2df99f6282 /net-misc/italc
parentSwitch to using the real committed patch, which is codewise identical to the ... (diff)
downloadgentoo-2-ad8c1ec29cabe106543ef50d7e0ca039d52f8e20.tar.gz
gentoo-2-ad8c1ec29cabe106543ef50d7e0ca039d52f8e20.tar.bz2
gentoo-2-ad8c1ec29cabe106543ef50d7e0ca039d52f8e20.zip
Fix building with GCC 4.4 wrt #278462.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/italc')
-rw-r--r--net-misc/italc/ChangeLog6
-rw-r--r--net-misc/italc/files/italc-1.0.9-gcc44.patch23
-rw-r--r--net-misc/italc/italc-1.0.9.ebuild3
3 files changed, 30 insertions, 2 deletions
diff --git a/net-misc/italc/ChangeLog b/net-misc/italc/ChangeLog
index fbc17c6da16c..23a41f141c23 100644
--- a/net-misc/italc/ChangeLog
+++ b/net-misc/italc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/italc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/ChangeLog,v 1.17 2009/06/08 13:22:40 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/ChangeLog,v 1.18 2009/07/30 08:05:30 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> italc-1.0.9.ebuild,
+ +files/italc-1.0.9-gcc44.patch:
+ Fix building with GCC 4.4 wrt #278462.
08 Jun 2009; Rémi Cardona <remi@gentoo.org> italc-1.0.3-r1.ebuild,
italc-1.0.9.ebuild:
diff --git a/net-misc/italc/files/italc-1.0.9-gcc44.patch b/net-misc/italc/files/italc-1.0.9-gcc44.patch
new file mode 100644
index 000000000000..44f2904d18c9
--- /dev/null
+++ b/net-misc/italc/files/italc-1.0.9-gcc44.patch
@@ -0,0 +1,23 @@
+diff -ur italc-1.0.9.orig/lib/include/types.h italc-1.0.9/lib/include/types.h
+--- italc-1.0.9.orig/lib/include/types.h 2008-02-10 01:03:25.000000000 +0200
++++ italc-1.0.9/lib/include/types.h 2009-07-30 11:03:00.000000000 +0300
+@@ -25,6 +25,8 @@
+ #ifndef _TYPES_H
+ #define _TYPES_H
+
++#include <stdint.h>
++
+ typedef signed char Q_INT8; /* 8 bit signed */
+ typedef unsigned char Q_UINT8; /* 8 bit unsigned */
+ typedef short Q_INT16; /* 16 bit signed */
+diff -ur italc-1.0.9.orig/lib/src/fast_qimage.cpp italc-1.0.9/lib/src/fast_qimage.cpp
+--- italc-1.0.9.orig/lib/src/fast_qimage.cpp 2008-03-17 10:02:33.000000000 +0200
++++ italc-1.0.9/lib/src/fast_qimage.cpp 2009-07-30 10:56:19.000000000 +0300
+@@ -52,6 +52,7 @@
+ pete@shinners.org
+ */
+
++#include <stdint.h>
+
+ #define ALIGN_SIZE 16
+
diff --git a/net-misc/italc/italc-1.0.9.ebuild b/net-misc/italc/italc-1.0.9.ebuild
index b08c0aae7265..a3e74100037e 100644
--- a/net-misc/italc/italc-1.0.9.ebuild
+++ b/net-misc/italc/italc-1.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/italc-1.0.9.ebuild,v 1.4 2009/06/08 13:22:40 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/italc-1.0.9.ebuild,v 1.5 2009/07/30 08:05:30 ssuominen Exp $
EAPI=2
@@ -46,6 +46,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-qt4-libpath.patch
epatch "${FILESDIR}"/${P}-strip.patch
use system-libvncserver && epatch "${FILESDIR}"/${P}-system-libvncserver.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}