summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2010-03-08 22:35:30 +0000
committerSven Wegener <swegener@gentoo.org>2010-03-08 22:35:30 +0000
commit992ce56f28cdca60e00ba6289cf5c59ca56a461a (patch)
treef7892282603c81e02cb36c926b1b2e757cc85439 /net-misc/neon
parentSpecify <python-3 since only python-2.x works. (diff)
downloadgentoo-2-992ce56f28cdca60e00ba6289cf5c59ca56a461a.tar.gz
gentoo-2-992ce56f28cdca60e00ba6289cf5c59ca56a461a.tar.bz2
gentoo-2-992ce56f28cdca60e00ba6289cf5c59ca56a461a.zip
Pull in a patch from Debian to fix SNI support.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog6
-rw-r--r--net-misc/neon/files/neon-0.29-sni-fix.patch18
-rw-r--r--net-misc/neon/neon-0.29.1.ebuild8
-rw-r--r--net-misc/neon/neon-0.29.2.ebuild6
-rw-r--r--net-misc/neon/neon-0.29.3.ebuild6
5 files changed, 36 insertions, 8 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 7c175c5897f4..09504c03d8aa 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.152 2010/03/04 15:23:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.153 2010/03/08 22:35:30 swegener Exp $
+
+ 08 Mar 2010; Sven Wegener <swegener@gentoo.org> neon-0.29.1.ebuild,
+ neon-0.29.2.ebuild, neon-0.29.3.ebuild, +files/neon-0.29-sni-fix.patch:
+ Pull in a patch from Debian to fix SNI support.
04 Mar 2010; Jeroen Roovers <jer@gentoo.org> neon-0.29.3.ebuild:
Stable for HPPA (bug #305181).
diff --git a/net-misc/neon/files/neon-0.29-sni-fix.patch b/net-misc/neon/files/neon-0.29-sni-fix.patch
new file mode 100644
index 000000000000..e9fb33ae85cf
--- /dev/null
+++ b/net-misc/neon/files/neon-0.29-sni-fix.patch
@@ -0,0 +1,18 @@
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569639
+http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=15;filename=sni-fix.patch;att=1;bug=569639
+
+diff --git a/src/ne_session.c b/src/ne_session.c
+index 117c25a..c65848c 100644
+--- a/src/ne_session.c
++++ b/src/ne_session.c
+@@ -183,8 +183,9 @@ ne_session *ne_session_create(const char *scheme,
+ ia = ne_iaddr_parse(hostname, ne_iaddr_ipv6);
+
+ if (ia) {
+- sess->flags[NE_SESSFLAG_TLS_SNI] = 1;
+ ne_iaddr_free(ia);
++ } else {
++ sess->flags[NE_SESSFLAG_TLS_SNI] = 1;
+ }
+ NE_DEBUG(NE_DBG_SSL, "ssl: SNI %s by default.\n",
+ sess->flags[NE_SESSFLAG_TLS_SNI] ?
diff --git a/net-misc/neon/neon-0.29.1.ebuild b/net-misc/neon/neon-0.29.1.ebuild
index 2e870b8f70b5..70ff1e762753 100644
--- a/net-misc/neon/neon-0.29.1.ebuild
+++ b/net-misc/neon/neon-0.29.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.1.ebuild,v 1.1 2009/12/19 20:31:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.1.ebuild,v 1.2 2010/03/08 22:35:30 swegener Exp $
EAPI="2"
-inherit autotools libtool versionator
+inherit autotools libtool versionator eutils
DESCRIPTION="HTTP and WebDAV client library"
HOMEPAGE="http://www.webdav.org/neon/"
@@ -44,6 +44,8 @@ src_prepare() {
done
sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+ epatch "${FILESDIR}"/neon-0.29-sni-fix.patch
+
AT_M4DIR="macros" eautoreconf
elibtoolize
diff --git a/net-misc/neon/neon-0.29.2.ebuild b/net-misc/neon/neon-0.29.2.ebuild
index 70f6e9cccc6b..8caf97be7cf8 100644
--- a/net-misc/neon/neon-0.29.2.ebuild
+++ b/net-misc/neon/neon-0.29.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.2.ebuild,v 1.2 2010/01/07 15:56:39 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.2.ebuild,v 1.3 2010/03/08 22:35:30 swegener Exp $
EAPI="2"
-inherit autotools libtool versionator
+inherit autotools libtool versionator eutils
DESCRIPTION="HTTP and WebDAV client library"
HOMEPAGE="http://www.webdav.org/neon/"
@@ -44,6 +44,8 @@ src_prepare() {
done
sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+ epatch "${FILESDIR}"/neon-0.29-sni-fix.patch
+
AT_M4DIR="macros" eautoreconf
elibtoolize
diff --git a/net-misc/neon/neon-0.29.3.ebuild b/net-misc/neon/neon-0.29.3.ebuild
index 4ca08cf02712..96b7f8cfde32 100644
--- a/net-misc/neon/neon-0.29.3.ebuild
+++ b/net-misc/neon/neon-0.29.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.3.ebuild,v 1.4 2010/03/04 15:23:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.29.3.ebuild,v 1.5 2010/03/08 22:35:30 swegener Exp $
EAPI="2"
-inherit autotools libtool versionator
+inherit autotools libtool versionator eutils
DESCRIPTION="HTTP and WebDAV client library"
HOMEPAGE="http://www.webdav.org/neon/"
@@ -44,6 +44,8 @@ src_prepare() {
done
sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+ epatch "${FILESDIR}"/neon-0.29-sni-fix.patch
+
AT_M4DIR="macros" eautoreconf
elibtoolize