summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-01-18 19:30:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-01-18 19:30:25 +0000
commitea13e684ec6b901d3c186534bc83a250c19f9678 (patch)
treeee498275101ff1f11d13aa6df44bc41fae1417a8 /net-misc/netctl
parentConvert to python-single-r1. (diff)
downloadgentoo-2-ea13e684ec6b901d3c186534bc83a250c19f9678.tar.gz
gentoo-2-ea13e684ec6b901d3c186534bc83a250c19f9678.tar.bz2
gentoo-2-ea13e684ec6b901d3c186534bc83a250c19f9678.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog9
-rw-r--r--net-misc/netctl/netctl-1.10.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index 24553bebd63a..1825398700ed 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/netctl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.24 2014/10/24 23:06:13 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.25 2015/01/18 19:30:25 hwoarang Exp $
+
+*netctl-1.10 (18 Jan 2015)
+
+ 18 Jan 2015; Markos Chandras <hwoarang@gentoo.org> +netctl-1.10.ebuild:
+ Version bump
24 Oct 2014; Michał Górny <mgorny@gentoo.org> netctl-1.9.ebuild:
Add missing aliases for completions, bug #526310.
diff --git a/net-misc/netctl/netctl-1.10.ebuild b/net-misc/netctl/netctl-1.10.ebuild
new file mode 100644
index 000000000000..7306ffebd405
--- /dev/null
+++ b/net-misc/netctl/netctl-1.10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.10.ebuild,v 1.1 2015/01/18 19:30:25 hwoarang Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-6.4.0
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ bashcomp_alias netctl netctl-auto wifi-menu
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 for ${desc}"
+ else
+ elog " [ ] $1 for ${desc}"
+ fi
+ shift
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To get additional features, a number of optional runtime dependencies may be"
+ elog "installed."
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+ fi
+}