summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-03-17 12:31:06 +0000
committerThomas Kahle <tomka@gentoo.org>2013-03-17 12:31:06 +0000
commitc3b0f32f27a3e947e3c3e1c046862901a03e8da4 (patch)
treec1dc6091fa29597985a1a9a2a02c2d3cd868a47e /net-misc/ofono
parentEAPI=5 and poppler subslot dependency (diff)
downloadgentoo-2-c3b0f32f27a3e947e3c3e1c046862901a03e8da4.tar.gz
gentoo-2-c3b0f32f27a3e947e3c3e1c046862901a03e8da4.tar.bz2
gentoo-2-c3b0f32f27a3e947e3c3e1c046862901a03e8da4.zip
1.10: QA and EAPI=5, 1.12: QA
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'net-misc/ofono')
-rw-r--r--net-misc/ofono/ChangeLog8
-rw-r--r--net-misc/ofono/ofono-1.10-r1.ebuild63
-rw-r--r--net-misc/ofono/ofono-1.12.ebuild9
3 files changed, 72 insertions, 8 deletions
diff --git a/net-misc/ofono/ChangeLog b/net-misc/ofono/ChangeLog
index 197c62de0926..1d6f33058730 100644
--- a/net-misc/ofono/ChangeLog
+++ b/net-misc/ofono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ofono
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ChangeLog,v 1.49 2013/03/16 08:31:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ChangeLog,v 1.50 2013/03/17 12:31:06 tomka Exp $
+
+*ofono-1.10-r1 (17 Mar 2013)
+
+ 17 Mar 2013; Thomas Kahle <tomka@gentoo.org> +ofono-1.10-r1.ebuild,
+ ofono-1.12.ebuild:
+ 1.10: QA and EAPI=5, 1.12: QA
16 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ofono-1.10.ebuild:
Stable for x86, wrt bug #461802
diff --git a/net-misc/ofono/ofono-1.10-r1.ebuild b/net-misc/ofono/ofono-1.10-r1.ebuild
new file mode 100644
index 000000000000..6fae3295139a
--- /dev/null
+++ b/net-misc/ofono/ofono-1.10-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ofono-1.10-r1.ebuild,v 1.1 2013/03/17 12:31:06 tomka Exp $
+
+EAPI="5"
+
+inherit eutils multilib systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon."
+HOMEPAGE="http://ofono.org/"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+atmodem bluetooth +cdmamodem doc examples +isimodem +phonesim threads tools +udev"
+
+RDEPEND=">=sys-apps/dbus-1.4
+ >=dev-libs/glib-2.28
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_prepare() {
+ default
+ epatch "${FILESDIR}/${PN}-1.12-sys-types.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable tools) \
+ --enable-test \
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_unitdir)"
+}
+
+src_install() {
+ default
+
+ if ! use examples ; then
+ rm -rf "${D}/usr/$(get_libdir)/ofono/test" || die
+ fi
+
+ if use tools ; then
+ dobin tools/{auto-enable,huawei-audio}
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}
diff --git a/net-misc/ofono/ofono-1.12.ebuild b/net-misc/ofono/ofono-1.12.ebuild
index 36c194b986a9..6fe370bd5657 100644
--- a/net-misc/ofono/ofono-1.12.ebuild
+++ b/net-misc/ofono/ofono-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ofono-1.12.ebuild,v 1.1 2013/02/22 13:56:27 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ofono-1.12.ebuild,v 1.2 2013/03/17 12:31:06 tomka Exp $
EAPI=5
@@ -31,13 +31,8 @@ DOCS=( ChangeLog AUTHORS )
src_prepare() {
default
- # backport upstream patches
- epatch "${FILESDIR}"/${P}-sys-types.patch
- # Fix build with newer glib due to G_DISABLE_SINGLE_INCLUDES
- grep -lre '<glib/gtypes.h>' "${S}" | while read i; do
- sed -ie 's:glib/gtypes.h:glib.h:' "${i}" || die "Unable to sed \"$i\""
- done
+ epatch "${FILESDIR}"/${P}-sys-types.patch
}
src_configure() {