summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-08-22 04:28:25 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-08-22 04:28:25 +0000
commit4ad027f576f4f4af0ef9220a28245eee7931b29a (patch)
treeaf249d3439ef13a391e319d5dd36dfd1b3d57371 /net-misc/openvswitch
parentbump (diff)
downloadgentoo-2-4ad027f576f4f4af0ef9220a28245eee7931b29a.tar.gz
gentoo-2-4ad027f576f4f4af0ef9220a28245eee7931b29a.tar.bz2
gentoo-2-4ad027f576f4f4af0ef9220a28245eee7931b29a.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/ChangeLog10
-rw-r--r--net-misc/openvswitch/openvswitch-2.1.3.ebuild (renamed from net-misc/openvswitch/openvswitch-1.9.0-r1.ebuild)40
-rw-r--r--net-misc/openvswitch/openvswitch-2.3.0.ebuild (renamed from net-misc/openvswitch/openvswitch-1.9.0.ebuild)31
3 files changed, 49 insertions, 32 deletions
diff --git a/net-misc/openvswitch/ChangeLog b/net-misc/openvswitch/ChangeLog
index 19ba75f07d6d..e61f002881fd 100644
--- a/net-misc/openvswitch/ChangeLog
+++ b/net-misc/openvswitch/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/openvswitch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.23 2014/08/10 20:46:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.24 2014/08/22 04:28:25 prometheanfire Exp $
+
+*openvswitch-2.1.3 (22 Aug 2014)
+*openvswitch-2.3.0 (22 Aug 2014)
+
+ 22 Aug 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +openvswitch-2.1.3.ebuild, +openvswitch-2.3.0.ebuild,
+ -openvswitch-1.9.0-r1.ebuild, -openvswitch-1.9.0.ebuild:
+ bup
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> openvswitch-1.11.0.ebuild,
openvswitch-1.9.0-r1.ebuild, openvswitch-1.9.0.ebuild:
diff --git a/net-misc/openvswitch/openvswitch-1.9.0-r1.ebuild b/net-misc/openvswitch/openvswitch-2.1.3.ebuild
index f767624e9754..051a2d561490 100644
--- a/net-misc/openvswitch/openvswitch-1.9.0-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.9.0-r1.ebuild,v 1.2 2014/08/10 20:46:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.1.3.ebuild,v 1.1 2014/08/22 04:28:25 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils linux-info linux-mod python-single-r1
+inherit eutils linux-info linux-mod python-single-r1 systemd autotools
DESCRIPTION="Production quality, multilayer virtual switch"
HOMEPAGE="http://openvswitch.org"
@@ -15,36 +15,35 @@ SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug modules monitor +pyside +ssl"
+IUSE="debug modules monitor +ssl"
RDEPEND=">=sys-apps/openrc-0.10.5
ssl? ( dev-libs/openssl )
monitor? (
${PYTHON_DEPS}
- dev-python/twisted-core[${PYTHON_USEDEP}]
- dev-python/twisted-conch[${PYTHON_USEDEP}]
- dev-python/twisted-web[${PYTHON_USEDEP}]
- pyside? ( dev-python/pyside[${PYTHON_USEDEP}] )
- !pyside? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
+ dev-python/twisted-core
+ dev-python/twisted-conch
+ dev-python/twisted-web
+ dev-python/PyQt4[${PYTHON_USEDEP}]
net-zope/zope-interface[${PYTHON_USEDEP}] )
debug? ( dev-lang/perl )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="brcompat(net:${S}/datapath/linux) openvswitch(net:${S}/datapath/linux)"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
BUILD_TARGETS="all"
pkg_setup() {
if use modules ; then
CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 2 6 32 || die "Linux >= 2.6.32 and <= 3.12 required for userspace modules"
+ kernel_is lt 3 12 || die "Linux >= 2.6.32 and <= 3.12 required for userspace modules"
linux-mod_pkg_setup
else
CONFIG_CHECK+=" ~OPENVSWITCH"
linux-info_pkg_setup
fi
- kernel_is ge 2 6 18 || die "Linux >=2.6.18 and <3.2.9 required"
- kernel_is lt 3 9 || die "Linux >=2.6.18 and <3.9 required"
use monitor && python-single-r1_pkg_setup
}
@@ -53,14 +52,18 @@ src_prepare() {
sed -i \
-e '/^SUBDIRS/d' \
datapath/Makefile.in || die "sed failed"
+ epatch "${FILESDIR}/xcp-interface-reconfigure.patch"
+ epatch "${FILESDIR}/kernel-3.12-support.patch"
+ eautoreconf
}
src_configure() {
set_arch_to_kernel
use monitor || export ovs_cv_python="no"
- use pyside || export ovs_cv_pyuic4="no"
+ #pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
local linux_config
- use modules && linux_config="--with-linux=${KERNEL_DIR}"
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
econf ${linux_config} \
--with-rundir=/var/run/openvswitch \
@@ -76,8 +79,7 @@ src_compile() {
use monitor && python_fix_shebang \
utilities/ovs-{pcap,tcpundump,test,vlan-test} \
- utilities/bugtool/ovs-bugtool \
- ovsdb/ovsdbmonitor/ovsdbmonitor
+ utilities/bugtool/ovs-bugtool
use modules && linux-mod_src_compile
}
@@ -102,12 +104,14 @@ src_install() {
use monitor || rmdir "${ED}/usr/share/ovsdbmonitor"
use debug || rm "${ED}/usr/bin/ovs-parse-leaks"
- newconfd "${FILESDIR}/ovsdb-server_conf" ovsdb-server
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
- newconfd "${FILESDIR}/ovs-controller_conf" ovs-controller
newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
- newinitd "${FILESDIR}/ovs-controller-r1" ovs-controller
+
+ systemd_dounit "${FILESDIR}/ovsdb-server.service"
+ systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
insinto /etc/logrotate.d
newins rhel/etc_logrotate.d_openvswitch openvswitch
diff --git a/net-misc/openvswitch/openvswitch-1.9.0.ebuild b/net-misc/openvswitch/openvswitch-2.3.0.ebuild
index 8760be0c98fd..380dec2ede40 100644
--- a/net-misc/openvswitch/openvswitch-1.9.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.3.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.9.0.ebuild,v 1.5 2014/08/10 20:46:09 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-2.3.0.ebuild,v 1.1 2014/08/22 04:28:25 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils linux-info linux-mod python-single-r1
+inherit eutils linux-info linux-mod python-single-r1 systemd autotools
DESCRIPTION="Production quality, multilayer virtual switch"
HOMEPAGE="http://openvswitch.org"
@@ -15,7 +15,7 @@ SRC_URI="http://openvswitch.org/releases/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug modules monitor +pyside +ssl"
+IUSE="debug modules monitor +ssl"
RDEPEND=">=sys-apps/openrc-0.10.5
ssl? ( dev-libs/openssl )
@@ -24,20 +24,21 @@ RDEPEND=">=sys-apps/openrc-0.10.5
dev-python/twisted-core
dev-python/twisted-conch
dev-python/twisted-web
- pyside? ( dev-python/pyside[${PYTHON_USEDEP}] )
- !pyside? ( dev-python/PyQt4[${PYTHON_USEDEP}] )
+ dev-python/PyQt4[${PYTHON_USEDEP}]
net-zope/zope-interface[${PYTHON_USEDEP}] )
debug? ( dev-lang/perl )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="brcompat(net:${S}/datapath/linux) openvswitch(net:${S}/datapath/linux)"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
BUILD_TARGETS="all"
pkg_setup() {
if use modules ; then
CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 2 6 32 || die "Linux >= 2.6.32 and <= 3.14 required for userspace modules"
+ kernel_is lt 3 14 || die "Linux >= 2.6.32 and <= 3.14 required for userspace modules"
linux-mod_pkg_setup
else
CONFIG_CHECK+=" ~OPENVSWITCH"
@@ -51,14 +52,17 @@ src_prepare() {
sed -i \
-e '/^SUBDIRS/d' \
datapath/Makefile.in || die "sed failed"
+ epatch "${FILESDIR}/xcp-interface-reconfigure.patch"
+ eautoreconf
}
src_configure() {
set_arch_to_kernel
use monitor || export ovs_cv_python="no"
- use pyside || export ovs_cv_pyuic4="no"
+ #pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
local linux_config
- use modules && linux_config="--with-linux=${KERNEL_DIR}"
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
econf ${linux_config} \
--with-rundir=/var/run/openvswitch \
@@ -74,8 +78,7 @@ src_compile() {
use monitor && python_fix_shebang \
utilities/ovs-{pcap,tcpundump,test,vlan-test} \
- utilities/bugtool/ovs-bugtool \
- ovsdb/ovsdbmonitor/ovsdbmonitor
+ utilities/bugtool/ovs-bugtool
use modules && linux-mod_src_compile
}
@@ -100,12 +103,14 @@ src_install() {
use monitor || rmdir "${ED}/usr/share/ovsdbmonitor"
use debug || rm "${ED}/usr/bin/ovs-parse-leaks"
- newconfd "${FILESDIR}/ovsdb-server_conf" ovsdb-server
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
- newconfd "${FILESDIR}/ovs-controller_conf" ovs-controller
newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
- newinitd "${FILESDIR}/ovs-controller-r1" ovs-controller
+
+ systemd_dounit "${FILESDIR}/ovsdb-server.service"
+ systemd_dounit "${FILESDIR}/ovs-vswitchd.service"
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
insinto /etc/logrotate.d
newins rhel/etc_logrotate.d_openvswitch openvswitch