summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-29 20:02:10 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-29 20:02:10 +0000
commit3c4040b6342d6526344942c36ea967ce819aed7c (patch)
treeb8251ac359778b88d3c0f96800c1c79944f8b183 /net-misc/partysip
parentMarked stable on amd64 for bug #219512 (diff)
downloadgentoo-2-3c4040b6342d6526344942c36ea967ce819aed7c.tar.gz
gentoo-2-3c4040b6342d6526344942c36ea967ce819aed7c.tar.bz2
gentoo-2-3c4040b6342d6526344942c36ea967ce819aed7c.zip
Change berkdb and libosip deps wrt #218477, #206464, thanks to Peter Alfredsen and Weeve.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-misc/partysip')
-rw-r--r--net-misc/partysip/ChangeLog8
-rw-r--r--net-misc/partysip/partysip-2.2.3.ebuild40
2 files changed, 23 insertions, 25 deletions
diff --git a/net-misc/partysip/ChangeLog b/net-misc/partysip/ChangeLog
index a63bbd049234..54a4b6c8794b 100644
--- a/net-misc/partysip/ChangeLog
+++ b/net-misc/partysip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/partysip
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.13 2007/01/04 16:37:51 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/ChangeLog,v 1.14 2008/04/29 20:02:10 drac Exp $
+
+ 29 Apr 2008; Samuli Suominen <drac@gentoo.org> partysip-2.2.3.ebuild:
+ Change berkdb and libosip deps wrt #218477, #206464, thanks to Peter
+ Alfredsen and Weeve.
04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> partysip-2.2.3.ebuild:
Fix broken autotools handling.
diff --git a/net-misc/partysip/partysip-2.2.3.ebuild b/net-misc/partysip/partysip-2.2.3.ebuild
index 57c540dcc9e4..ba993fc74aac 100644
--- a/net-misc/partysip/partysip-2.2.3.ebuild
+++ b/net-misc/partysip/partysip-2.2.3.ebuild
@@ -1,11 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.2.3.ebuild,v 1.5 2007/01/04 16:37:51 flameeyes Exp $
-
-IUSE="berkdb debug syslog"
-
-WANT_AUTOMAKE="latest"
-WANT_AUTOCONF="latest"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/partysip/partysip-2.2.3.ebuild,v 1.6 2008/04/29 20:02:10 drac Exp $
inherit eutils autotools
@@ -13,29 +8,28 @@ DESCRIPTION="Modular and extensible SIP proxy"
HOMEPAGE="http://savannah.nongnu.org/projects/partysip/"
SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2" # not 100% about -2, but core is LGPL
+SLOT="0"
KEYWORDS="~ppc ~sparc ~x86"
+IUSE="berkdb debug syslog"
-DEPEND="virtual/libc
- >=net-libs/libosip-2.2.1
- berkdb? ( =sys-libs/db-3* )"
+DEPEND="=net-libs/libosip-2*
+ berkdb? ( >=sys-libs/db-3.2 )"
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-configure.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.diff
# fix libresolv check in configure.in (#107885)
# instead of res_query, we search for the real (internal)
# function name __res_query, because res_query isn't in the symbol
# list of libresolv on amd64
- epatch ${FILESDIR}/${P}-libresolv-check.diff
+ epatch "${FILESDIR}"/${P}-libresolv-check.diff
# remove unused check in auth plugin (#107886)
# breaks authentication otherwise
- epatch ${FILESDIR}/${P}-fix_auth.diff
+ epatch "${FILESDIR}"/${P}-fix_auth.diff
# put partysip binary into /usr/sbin
sed -i -e "s:^bin_PROGRAMS:sbin_PROGRAMS:" \
@@ -69,20 +63,20 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
insinto /etc/partysip
doins conf/partysip.conf
- chmod 750 ${D}etc/partysip
- chmod 640 ${D}etc/partysip/partysip.conf
+ chmod 750 "${D}"etc/partysip
+ chmod 640 "${D}"etc/partysip/partysip.conf
- newinitd ${FILESDIR}/partysip.rc6 partysip
- newconfd ${FILESDIR}/partysip.confd partysip
+ newinitd "${FILESDIR}"/partysip.rc6 partysip
+ newconfd "${FILESDIR}"/partysip.confd partysip
- dodoc README ChangeLog COPYING COPYING-2 TODO AUTHORS INSTALL NEWS
+ dodoc README ChangeLog TODO AUTHORS NEWS
}
pkg_postinst() {
- einfo "Please edit /etc/partysip/partysip.conf!"
+ elog "Remember to edit /etc/partysip/partysip.conf!"
}