summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-08-23 14:43:37 +0000
committerJeroen Roovers <jer@gentoo.org>2012-08-23 14:43:37 +0000
commit89b8f6c5f66b2c20e1937563f22a52ea9959c1d7 (patch)
treeca365be4d7d7e92f79ce2c4372e97f14a9d1f968 /net-misc/putty
parentppc stable (bug 419325). (diff)
downloadgentoo-2-89b8f6c5f66b2c20e1937563f22a52ea9959c1d7.tar.gz
gentoo-2-89b8f6c5f66b2c20e1937563f22a52ea9959c1d7.tar.bz2
gentoo-2-89b8f6c5f66b2c20e1937563f22a52ea9959c1d7.zip
Snapshot version bump.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/putty-0.62.20120823.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 66307ada0a5d..df9e0f44d209 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.69 2012/05/21 20:01:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.70 2012/08/23 14:43:37 jer Exp $
+
+*putty-0.62.20120823 (23 Aug 2012)
+
+ 23 Aug 2012; Jeroen Roovers <jer@gentoo.org> +putty-0.62.20120823.ebuild:
+ Snapshot version bump.
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> putty-0.62.ebuild:
inherit eutils for make_desktop_entry
diff --git a/net-misc/putty/putty-0.62.20120823.ebuild b/net-misc/putty/putty-0.62.20120823.ebuild
new file mode 100644
index 000000000000..848976f7ec09
--- /dev/null
+++ b/net-misc/putty/putty-0.62.20120823.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.62.20120823.ebuild,v 1.1 2012/08/23 14:43:37 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)-2012-08-23"
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://tartarus.org/~simon/${PN}-snapshots/${PN}-${MY_PV}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos"
+
+RDEPEND="
+ !net-misc/pssh
+ dev-libs/glib
+ kerberos? ( virtual/krb5 )
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ cd "${S}"/unix || die "cd unix failed"
+ sed \
+ -i configure.ac \
+ -e '/^AM_PATH_GTK(/d' \
+ -e 's|-Wall -Werror||g' || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die "cd failed"
+ econf $(use_with kerberos gssapi)
+}
+
+src_compile() {
+ cd "${S}"/unix || die "cd unix failed"
+ emake $(use ipv6 || echo COMPAT=-DNO_IPV6)
+}
+
+src_install() {
+ if use doc; then
+ dodoc doc/puttydoc.txt
+ dohtml doc/*.html
+ fi
+
+ cd "${S}"/unix
+ default
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry putty PuTTY putty Network
+}