summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2014-03-18 16:45:02 +0000
committerChristian Birchinger <joker@gentoo.org>2014-03-18 16:45:02 +0000
commitad37fc4f5bbb3751c36594122be8b258cc3eb692 (patch)
tree03562f2dd07127b546f60033b8883aee2fe80d55 /net-misc/r8168
parentStable for ia64, wrt bug #499472 (diff)
downloadgentoo-2-ad37fc4f5bbb3751c36594122be8b258cc3eb692.tar.gz
gentoo-2-ad37fc4f5bbb3751c36594122be8b258cc3eb692.tar.bz2
gentoo-2-ad37fc4f5bbb3751c36594122be8b258cc3eb692.zip
Version bump. I no longer have the hardware to verify it's runtime functionality.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x0151863A67652900!)
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/ChangeLog11
-rw-r--r--net-misc/r8168/r8168-8.038.00.ebuild32
2 files changed, 40 insertions, 3 deletions
diff --git a/net-misc/r8168/ChangeLog b/net-misc/r8168/ChangeLog
index ef9df6c84a11..392a6dc1f061 100644
--- a/net-misc/r8168/ChangeLog
+++ b/net-misc/r8168/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/r8168
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.15 2013/03/06 21:37:48 joker Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/ChangeLog,v 1.16 2014/03/18 16:45:02 joker Exp $
+
+*r8168-8.038.00 (18 Mar 2014)
+
+ 18 Mar 2014; Christian Birchinger <joker@gentoo.org> +r8168-8.038.00.ebuild:
+ Version bump. I no longer have the hardware to verify it's runtime
+ functionality.
*r8168-8.035.00-r1 (06 Mar 2013)
@@ -72,4 +78,3 @@
13 Nov 2011; Christian Birchinger <joker@gentoo.org> +r8168-8.026.00.ebuild,
+metadata.xml:
Initial import. Based on the ebuild by thegryghost@gmail.com
-
diff --git a/net-misc/r8168/r8168-8.038.00.ebuild b/net-misc/r8168/r8168-8.038.00.ebuild
new file mode 100644
index 000000000000..a1954b94a2db
--- /dev/null
+++ b/net-misc/r8168/r8168-8.038.00.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.038.00.ebuild,v 1.1 2014/03/18 16:45:02 joker Exp $
+
+EAPI=4
+
+inherit linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://r8168dl.appspot.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="!R8169"
+
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}