summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-05-31 17:05:34 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-05-31 17:05:34 +0000
commit8f9c62c2654031df002db123f8f56d3af4056077 (patch)
treeca8e4dedc9d74c211a48e3c57f052d72ec6c5df4 /net-misc/rsync/files
parentInitial import. GPL licensed alternative to dev-java/sun-jaf-bin which is abo... (diff)
downloadgentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.tar.gz
gentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.tar.bz2
gentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.zip
Adding rsync patch for livecd/installer until python 2.4 goes stable.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/rsync/files')
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.0-r53
-rw-r--r--net-misc/rsync/files/rsync-2.6.0-livecd-sigmask.patch50
2 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.6.0-r5 b/net-misc/rsync/files/digest-rsync-2.6.0-r5
new file mode 100644
index 000000000000..42e8d077802b
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.6.0-r5
@@ -0,0 +1,3 @@
+MD5 3f24bf31aec0a657eb3b6844c3f09f21 rsync-2.6.0.tar.gz 464920
+MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
+MD5 16cbffdcd9c6c318761c6c0d86400197 rsync-2.6.0-acl.diff.bz2 60721
diff --git a/net-misc/rsync/files/rsync-2.6.0-livecd-sigmask.patch b/net-misc/rsync/files/rsync-2.6.0-livecd-sigmask.patch
new file mode 100644
index 000000000000..c96bdaeb7003
--- /dev/null
+++ b/net-misc/rsync/files/rsync-2.6.0-livecd-sigmask.patch
@@ -0,0 +1,50 @@
+diff -au rsync-2.6.0/Makefile.in rsync-2.6.0.new/Makefile.in
+--- rsync-2.6.0/Makefile.in 2003-07-30 01:12:25.000000000 -0500
++++ rsync-2.6.0.new/Makefile.in 2005-04-22 11:44:18.660090168 -0500
+@@ -6,7 +6,7 @@
+ bindir=@bindir@
+ mandir=@mandir@
+
+-LIBS=@LIBS@
++LIBS=@LIBS@ -lpthread
+ CC=@CC@
+ CFLAGS=@CFLAGS@
+ CPPFLAGS=@CPPFLAGS@
+Common subdirectories: rsync-2.6.0/doc and rsync-2.6.0.new/doc
+Common subdirectories: rsync-2.6.0/lib and rsync-2.6.0.new/lib
+diff -au rsync-2.6.0/main.c rsync-2.6.0.new/main.c
+--- rsync-2.6.0/main.c 2003-12-20 10:57:24.000000000 -0600
++++ rsync-2.6.0.new/main.c 2005-04-22 11:43:44.896223056 -0500
+@@ -978,10 +978,15 @@
+ extern int write_batch;
+ int orig_argc;
+ char **orig_argv;
++ sigset_t set, old_set;
+
+ orig_argc = argc;
+ orig_argv = argv;
+
++ // Added to defensively set sigmask
++ sigfillset(&set);
++ pthread_sigmask(SIG_UNBLOCK, &set, &old_set);
++
+ signal(SIGUSR1, sigusr1_handler);
+ signal(SIGUSR2, sigusr2_handler);
+ signal(SIGCHLD, sigchld_handler);
+Common subdirectories: rsync-2.6.0/packaging and rsync-2.6.0.new/packaging
+Common subdirectories: rsync-2.6.0/patches and rsync-2.6.0.new/patches
+Common subdirectories: rsync-2.6.0/popt and rsync-2.6.0.new/popt
+diff -au rsync-2.6.0/rsync.h rsync-2.6.0.new/rsync.h
+--- rsync-2.6.0/rsync.h 2003-12-16 17:04:59.000000000 -0600
++++ rsync-2.6.0.new/rsync.h 2005-04-22 11:43:44.897222904 -0500
+@@ -686,3 +686,7 @@
+ #define UNUSED(x) x __attribute__((__unused__))
+
+ extern const char *io_write_phase, *io_read_phase;
++
++// Added to defensively set the sigmask
++#include <pthread.h>
++#include <signal.h>
+Common subdirectories: rsync-2.6.0/testhelp and rsync-2.6.0.new/testhelp
+Common subdirectories: rsync-2.6.0/testsuite and rsync-2.6.0.new/testsuite
+Common subdirectories: rsync-2.6.0/zlib and rsync-2.6.0.new/zlib