summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-05-31 17:05:34 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-05-31 17:05:34 +0000
commit8f9c62c2654031df002db123f8f56d3af4056077 (patch)
treeca8e4dedc9d74c211a48e3c57f052d72ec6c5df4 /net-misc/rsync/rsync-2.6.0-r5.ebuild
parentInitial import. GPL licensed alternative to dev-java/sun-jaf-bin which is abo... (diff)
downloadgentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.tar.gz
gentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.tar.bz2
gentoo-2-8f9c62c2654031df002db123f8f56d3af4056077.zip
Adding rsync patch for livecd/installer until python 2.4 goes stable.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/rsync/rsync-2.6.0-r5.ebuild')
-rw-r--r--net-misc/rsync/rsync-2.6.0-r5.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/rsync/rsync-2.6.0-r5.ebuild b/net-misc/rsync/rsync-2.6.0-r5.ebuild
new file mode 100644
index 000000000000..c202de37f1ab
--- /dev/null
+++ b/net-misc/rsync/rsync-2.6.0-r5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.0-r5.ebuild,v 1.1 2005/05/31 17:05:33 wolf31o2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/old-versions/${P}.tar.gz
+ http://www.imada.sdu.dk/~bardur/personal/40-patches/rsync-proxy-auth/rsync-2.5.6-proxy-auth-1.patch
+ acl? ( http://www.saout.de/misc/${P}-acl.diff.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="build static acl livecd"
+
+RDEPEND="!build? ( >=dev-libs/popt-1.5 )
+ acl? ( sys-apps/acl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sanitize.patch
+ epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
+ use acl && epatch "${DISTDIR}"/${P}-acl.diff.bz2
+ use livecd && epatch ${FILESDIR}/${P}-livecd-sigmask.patch
+
+ # apply security patch from bug #60309
+ epatch "${FILESDIR}"/${PN}-pathsanitize.patch
+}
+
+src_compile() {
+ [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
+ use static && append-ldflags -static
+ export LDFLAGS
+ econf \
+ $(use_with build included-popt) \
+ $(use_with acl acl-support) \
+ || die
+ emake || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/rsync/rsyncd.conf ]] && [[ ! -e ${ROOT}/etc/rsyncd.conf ]] ; then
+ mv "${ROOT}"/etc/rsync/rsyncd.conf "${ROOT}"/etc/rsyncd.conf
+ rm -f "${ROOT}"/etc/rsync/.keep
+ rmdir "${ROOT}"/etc/rsync >& /dev/null
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
+ if ! use build ; then
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ doins "${FILESDIR}"/rsyncd.conf
+ else
+ rm -r "${D}"/usr/share
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The rsyncd.conf file has been moved for you to /etc/rsyncd.conf"
+ echo
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsyncd.conf and make sure"
+ ewarn "it says: use chroot = yes"
+ echo
+ einfo 'This patch enables usage of user:pass@proxy.foo:port'
+ einfo 'in the RSYNC_PROXY environment variable to support'
+ einfo 'the "Basic" proxy authentication scheme if you are'
+ einfo 'behind a password protected HTTP proxy.'
+}