summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-03-21 19:33:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-03-21 19:33:50 +0000
commit9270c97aa702d37ca07af1543a182eebd72e53db (patch)
tree2407891a7625e44db437accd715a2707e2d9b383 /net-misc/suite3270
parentupdating prettytable-0.6 to r1 for distutils-r1 support (diff)
downloadgentoo-2-9270c97aa702d37ca07af1543a182eebd72e53db.tar.gz
gentoo-2-9270c97aa702d37ca07af1543a182eebd72e53db.tar.bz2
gentoo-2-9270c97aa702d37ca07af1543a182eebd72e53db.zip
Bump per sec bug #462614.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/suite3270')
-rw-r--r--net-misc/suite3270/ChangeLog8
-rw-r--r--net-misc/suite3270/suite3270-3.3.12_p12.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/net-misc/suite3270/ChangeLog b/net-misc/suite3270/ChangeLog
index 43c0703f546d..0613596905a4 100644
--- a/net-misc/suite3270/ChangeLog
+++ b/net-misc/suite3270/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/suite3270
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.43 2013/03/17 15:08:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.44 2013/03/21 19:33:50 robbat2 Exp $
+
+*suite3270-3.3.12_p12 (21 Mar 2013)
+
+ 21 Mar 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +suite3270-3.3.12_p12.ebuild:
+ Bump per sec bug #462614.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/net-misc/suite3270/suite3270-3.3.12_p12.ebuild b/net-misc/suite3270/suite3270-3.3.12_p12.ebuild
new file mode 100644
index 000000000000..86aa2a33cc9d
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.12_p12.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.12_p12.ebuild,v 1.1 2013/03/21 19:33:50 robbat2 Exp $
+
+EAPI="4"
+
+MY_PV=${PV/_p/ga}
+MY_P=${PN}-${MY_PV}
+SUB_PV=${PV:0:3}
+
+S=${WORKDIR}
+
+# only the x3270 package installs fonts
+FONT_PN="x3270"
+FONT_S=${WORKDIR}/${FONT_PN}-${SUB_PV}
+
+inherit eutils font multiprocessing
+
+DESCRIPTION="Complete 3270 access package"
+HOMEPAGE="http://x3270.bgp.nu/"
+SRC_URI="mirror://sourceforge/x3270/${MY_P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE="cjk doc ncurses ssl tcl X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-misc/imake
+ x11-misc/xbitmaps
+ x11-proto/xproto
+ app-text/rman
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf
+ )"
+
+suite3270_makelist() {
+ echo pr3287 s3270 \
+ $(usex ncurses c3270 '') \
+ $(usex tcl tcl3270 '') \
+ $(usex X x3270 '')
+}
+
+src_configure() {
+ local p myconf
+ # Run configures in parallel!
+ multijob_init
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ if [[ ${p} == "x3270" ]] ; then
+ myconf=(
+ $(use_with X x)
+ $(use_with X fontdir "${FONTDIR}")
+ )
+ else
+ myconf=()
+ fi
+ multijob_child_init econf \
+ --cache-file="${S}"/config.cache \
+ $(use_enable cjk dbcs) \
+ $(use_enable ssl) \
+ "${myconf[@]}"
+ done
+ multijob_finish
+}
+
+src_compile() {
+ local p
+ for p in $(suite3270_makelist) ; do
+ emake -C "${S}/${p}-${SUB_PV}"
+ done
+}
+
+src_install() {
+ use X && dodir "${FONTDIR}"
+ local p
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ emake DESTDIR="${D}" install install.man
+ docinto ${p}
+ local d=$(echo README*)
+ [[ -n ${d} ]] && dodoc ${d}
+ use doc && dohtml html/*
+ done
+ chmod a-x "${D}"/usr/share/man/*/*
+
+ use X && font_src_install
+}
+
+pkg_postinst() { use X && font_pkg_postinst ; }
+pkg_postrm() { use X && font_pkg_postrm ; }