summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-01-08 15:24:56 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-01-08 15:24:56 +0000
commit1a3de5c892264362537e8345d9b56e7b8bfaa702 (patch)
treef6ffc6a6046f30167cb3d6cf8e6cf21dd236f2e5 /net-misc/tigervnc
parentThanks to xarthisius for reviewing, move S higher in file and fix missing || ... (diff)
downloadgentoo-2-1a3de5c892264362537e8345d9b56e7b8bfaa702.tar.gz
gentoo-2-1a3de5c892264362537e8345d9b56e7b8bfaa702.tar.bz2
gentoo-2-1a3de5c892264362537e8345d9b56e7b8bfaa702.zip
Fix missing deps: bug #395405, bug #397343, apply patch to fix bug #395099, straight to stable
(Portage version: 2.1.10.44/cvs/Linux ia64, RepoMan options: --force)
Diffstat (limited to 'net-misc/tigervnc')
-rw-r--r--net-misc/tigervnc/ChangeLog9
-rw-r--r--net-misc/tigervnc/files/1.1.0-gethomedir.patch20
-rw-r--r--net-misc/tigervnc/tigervnc-1.1.0-r3.ebuild187
3 files changed, 215 insertions, 1 deletions
diff --git a/net-misc/tigervnc/ChangeLog b/net-misc/tigervnc/ChangeLog
index e0b035468f3e..25293da60962 100644
--- a/net-misc/tigervnc/ChangeLog
+++ b/net-misc/tigervnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/tigervnc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tigervnc/ChangeLog,v 1.117 2012/01/01 11:57:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tigervnc/ChangeLog,v 1.118 2012/01/08 15:24:56 armin76 Exp $
+
+*tigervnc-1.1.0-r3 (08 Jan 2012)
+
+ 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> +files/1.1.0-gethomedir.patch,
+ +tigervnc-1.1.0-r3.ebuild:
+ Fix missing deps: bug #395405, bug #397343, apply patch to fix bug #395099,
+ straight to stable
*tigervnc-1.1.0-r2 (01 Jan 2012)
diff --git a/net-misc/tigervnc/files/1.1.0-gethomedir.patch b/net-misc/tigervnc/files/1.1.0-gethomedir.patch
new file mode 100644
index 000000000000..fd07be3bb5e2
--- /dev/null
+++ b/net-misc/tigervnc/files/1.1.0-gethomedir.patch
@@ -0,0 +1,20 @@
+diff -up tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am.gethomedir tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am
+--- tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am.gethomedir 2011-03-22 10:53:05.206429397 +0100
++++ tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am 2011-03-22 10:53:30.550388457 +0100
+@@ -5,6 +5,7 @@ RFB_LIB=$(LIB_DIR)/rfb/librfb.la
+ RDR_LIB=$(LIB_DIR)/rdr/librdr.la $(GNUTLS_LDFLAGS)
+ NETWORK_LIB=$(LIB_DIR)/network/libnetwork.la
+ XREGION_LIB=$(LIB_DIR)/Xregion/libXregion.la
++OS_LIB=$(LIB_DIR)/os/libos.la
+ COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
+
+ noinst_LTLIBRARIES = libvnccommon.la
+@@ -52,7 +53,7 @@ libvnc_la_CPPFLAGS = $(XVNC_CPPFLAGS) -I
+
+ libvnc_la_LDFLAGS = -module -avoid-version -Wl,-z,now
+
+-libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS)
++libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS) $(OS_LIB)
+
+ EXTRA_DIST = Xvnc.man
+
diff --git a/net-misc/tigervnc/tigervnc-1.1.0-r3.ebuild b/net-misc/tigervnc/tigervnc-1.1.0-r3.ebuild
new file mode 100644
index 000000000000..af3f2afebdb2
--- /dev/null
+++ b/net-misc/tigervnc/tigervnc-1.1.0-r3.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tigervnc/tigervnc-1.1.0-r3.ebuild,v 1.1 2012/01/08 15:24:56 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils toolchain-funcs multilib autotools
+
+XSERVER_VERSION="1.11.2"
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="Remote desktop viewer display system"
+HOMEPAGE="http://www.tigervnc.org"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2
+# http://dev.gentoo.org/~armin76/dist/${P}.tar.bz2
+SRC_URI="mirror://sourceforge/tigervnc/${P}.tar.gz
+ mirror://gentoo/${PN}.png
+ server? ( ftp://ftp.freedesktop.org/pub/xorg/individual/xserver/xorg-server-${XSERVER_VERSION}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc x86"
+IUSE="nptl +opengl server +xorgmodule"
+
+RDEPEND="virtual/jpeg
+ sys-libs/zlib
+ media-libs/freetype
+ x11-libs/libSM
+ x11-libs/libXtst
+ app-admin/eselect-opengl
+ server? (
+ x11-libs/libXi
+ x11-libs/libXfont
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXrender
+ x11-libs/pixman
+ x11-apps/xauth
+ x11-apps/xsetroot
+ x11-misc/xkeyboard-config
+ media-fonts/font-adobe-100dpi
+ media-fonts/font-adobe-75dpi
+ media-fonts/font-alias
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ xorgmodule? ( ~x11-base/xorg-server-${XSERVER_VERSION} )
+ )
+ !net-misc/vnc
+ !net-misc/tightvnc
+ !net-misc/xf4vnc"
+DEPEND="${RDEPEND}
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )
+ >=x11-proto/inputproto-1.5
+ >=x11-proto/xextproto-7.0.3
+ >=x11-proto/xproto-7.0.13
+ server? (
+ dev-util/pkgconfig
+ media-fonts/font-util
+ x11-misc/util-macros
+ x11-proto/bigreqsproto
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/dri2proto
+ x11-proto/fixesproto
+ x11-proto/fontsproto
+ >=x11-proto/randrproto-1.2.99
+ x11-proto/resourceproto
+ x11-proto/scrnsaverproto
+ x11-proto/trapproto
+ x11-proto/videoproto
+ x11-proto/xcmiscproto
+ x11-proto/xineramaproto
+ x11-proto/xf86bigfontproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86driproto
+ x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto
+ opengl? ( >=x11-proto/glproto-1.4.10 )
+ >=media-libs/mesa-7.1
+ >=x11-proto/renderproto-0.9.3
+ x11-libs/libpciaccess
+ >=x11-libs/xtrans-1.2.2
+ )"
+
+#S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if ! use server ; then
+ echo
+ einfo "The 'server' USE flag will build tigervnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ else
+ ewarn "Forcing on xorg-x11 for new enough glxtokens.h..."
+ OLD_IMPLEM="$(eselect opengl show)"
+ eselect opengl set ${OPENGL_DIR}
+ fi
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set ${OLD_IMPLEM}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use server ; then
+ cp -r "${WORKDIR}"/xorg-server-${XSERVER_VERSION}/* unix/xserver
+ fi
+
+ eautoreconf
+ cd unix
+
+ if use server ; then
+ epatch xserver110.patch
+ epatch "${FILESDIR}"/xserver111.patch
+ cd xserver
+ epatch "${FILESDIR}"/1.1.0-export_missing_symbol.patch
+ epatch "${FILESDIR}"/1.1.0-gethomedir.patch
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ econf --without-included-zlib --with-system-jpeg || die "econf failed"
+ emake || die "emake failed"
+
+ if use server ; then
+ cd unix/xserver
+ econf \
+ --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
+ --disable-xwin --disable-xephyr --disable-kdrive --with-pic \
+ --disable-static --disable-xinerama \
+ --disable-composite \
+ --with-default-font-path=/usr/share/fonts/misc,/usr/share/fonts/75dpi,/usr/share/fonts/100dpi,/usr/share/fonts/TTF,/usr/share/fonts/Type1 \
+ --enable-install-libxf86config \
+ --enable-dri2 \
+ --disable-config-dbus \
+ --disable-config-hal \
+ --with-xmlto=no \
+ --disable-unit-tests \
+ $(use_enable opengl glx) \
+ $(use_enable nptl glx-tls) \
+ || die "econf server failed"
+ emake || die "emake server failed"
+ fi
+}
+
+src_install() {
+ dodoc README.txt
+
+ cd unix
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newman vncviewer/vncviewer.man vncviewer.1
+
+ newicon "${DISTDIR}"/tigervnc.png vncviewer.png
+ make_desktop_entry vncviewer vncviewer vncviewer Network
+
+ if use server ; then
+ cd xserver/hw/vnc
+ emake DESTDIR="${D}" install || die "emake install failed"
+ ! use xorgmodule && rm -rf "${D}"/usr/$(get_libdir)/xorg
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ rm "${D}"/usr/$(get_libdir)/xorg/modules/extensions/libvnc.la
+ else
+ cd "${D}"
+ for f in vncserver vncpasswd x0vncserver vncconfig; do
+ rm usr/bin/$f
+ rm usr/share/man/man1/$f.1
+ done
+ fi
+}
+
+pkg_postinst() {
+ use server && switch_opengl_implem
+}