summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOmkhar Arasaratnam <omkhar@gentoo.org>2005-06-09 15:07:20 +0000
committerOmkhar Arasaratnam <omkhar@gentoo.org>2005-06-09 15:07:20 +0000
commitbfa73ff90da833623a066a6dad62562dc368998e (patch)
tree4ed0f3a4e90f4248232f343ce8dda1302d050786 /net-misc/vnc
parentStable on sparc (diff)
downloadgentoo-2-bfa73ff90da833623a066a6dad62562dc368998e.tar.gz
gentoo-2-bfa73ff90da833623a066a6dad62562dc368998e.tar.bz2
gentoo-2-bfa73ff90da833623a066a6dad62562dc368998e.zip
fix for eieio compile error with 2.6 headers and vnc server on ppc64
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/vnc')
-rw-r--r--net-misc/vnc/ChangeLog6
-rw-r--r--net-misc/vnc/files/xc.patch-eieio.patch17
-rw-r--r--net-misc/vnc/vnc-4.0-r1.ebuild8
3 files changed, 27 insertions, 4 deletions
diff --git a/net-misc/vnc/ChangeLog b/net-misc/vnc/ChangeLog
index 9a78667b9e42..22c9371afe77 100644
--- a/net-misc/vnc/ChangeLog
+++ b/net-misc/vnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/vnc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.35 2005/05/18 04:18:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.36 2005/06/09 15:07:20 omkhar Exp $
+
+ 09 Jun 2005; <omkhar@gentoo.org> +files/xc.patch-eieio.patch,
+ vnc-4.0-r1.ebuild:
+ fix for eieio compile error with 2.6 headers and vnc server on ppc64
18 May 2005; Michael Sterrett <mr_bones_@gentoo.org> vnc-4.0.ebuild,
vnc-4.0-r1.ebuild:
diff --git a/net-misc/vnc/files/xc.patch-eieio.patch b/net-misc/vnc/files/xc.patch-eieio.patch
new file mode 100644
index 000000000000..cb6966e6c25d
--- /dev/null
+++ b/net-misc/vnc/files/xc.patch-eieio.patch
@@ -0,0 +1,17 @@
+--- xc.orig/programs/Xserver/hw/xfree86/common/compiler.h 2004-12-22 08:24:22.364106000 -0800
++++ xc/programs/Xserver/hw/xfree86/common/compiler.h 2004-12-22 08:26:39.869202576 -0800
+@@ -1076,7 +1076,12 @@
+
+ extern volatile unsigned char *ioBase;
+
+-# define eieio() __asm__ __volatile__ ("eieio" ::: "memory")
++#if defined(linux) && defined(__powerpc64__)
++# include <asm/memory.h>
++#endif /* defined(linux) && defined(__powerpc64__) */
++#ifndef eieio /* We deal with arch-specific eieio() routines above... */
++# define eieio() __asm__ __volatile__ ("eieio" ::: "memory")
++#endif /* eieio */
+
+ static __inline__ unsigned char
+ xf86ReadMmio8(__volatile__ void *base, const unsigned long offset)
+
diff --git a/net-misc/vnc/vnc-4.0-r1.ebuild b/net-misc/vnc/vnc-4.0-r1.ebuild
index 7b187c78bf54..da12289e1204 100644
--- a/net-misc/vnc/vnc-4.0-r1.ebuild
+++ b/net-misc/vnc/vnc-4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.0-r1.ebuild,v 1.8 2005/05/18 04:18:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.0-r1.ebuild,v 1.9 2005/06/09 15:07:20 omkhar Exp $
inherit eutils toolchain-funcs
@@ -18,14 +18,15 @@ SRC_URI="http://www.realvnc.com/dist/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc amd64 ~alpha ~ia64"
+KEYWORDS="~x86 ~sparc ~ppc amd64 ~alpha ~ia64 ppc64"
IUSE="server"
DEPEND="sys-libs/zlib
- !net-misc/tightvnc
media-libs/freetype
+ !virtual/vnc
x11-base/xorg-x11"
+PROVIDE="virtual/vnc"
S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -52,6 +53,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}/imake-tmpdir.patch
epatch ${FILESDIR}/xc.patch-cfbglblt8.patch
+ epatch ${FILESDIR}/xc.patch-eieio.patch
epatch xc.patch
echo "#define CcCmd $(tc-getCC)" >> ${S}/xc/config/cf/vnc.def