summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-05 16:39:06 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-05 16:39:06 +0000
commit4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef (patch)
tree4ac5d286cfa40077678821c9d3cc5c64aa35a406 /net-misc/wput/files
parentFixed build error with gcc-4 and modular X dependencies. Thanks to Gilles Dar... (diff)
downloadgentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.tar.gz
gentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.tar.bz2
gentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.zip
Version bump thanks to masterdriverz, closes bug 126828 and bug 128899
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'net-misc/wput/files')
-rw-r--r--net-misc/wput/files/digest-wput-0.63
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff57
-rw-r--r--net-misc/wput/files/wput-0.6-respectldflags.patch13
3 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/wput/files/digest-wput-0.6 b/net-misc/wput/files/digest-wput-0.6
new file mode 100644
index 000000000000..547485783315
--- /dev/null
+++ b/net-misc/wput/files/digest-wput-0.6
@@ -0,0 +1,3 @@
+MD5 7ddb03154262df66e0e33f0676373ceb wput-0.6.tgz 252823
+RMD160 ebe32dd745b0d713102980268acce65aa8f41d51 wput-0.6.tgz 252823
+SHA256 98548282c031433be3222fbdadded7c1ad780137dda9bb00314ebbf5958cd4b5 wput-0.6.tgz 252823
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
new file mode 100644
index 000000000000..4ca604602c13
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -0,0 +1,57 @@
+diff --exclude='*~' -urN wput.orig/Makefile.in wput/Makefile.in
+--- wput.orig/Makefile.in 2005-04-18 13:14:14.000000000 -0400
++++ wput/Makefile.in 2005-04-18 13:17:46.000000000 -0400
+@@ -15,10 +15,10 @@
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- install -d $(bindir) wput
+- install -m0755 wput $(bindir)
+- install -d $(mandir) doc/wput.1.gz
+- install -m0644 doc/wput.1.gz $(mandir)
++ install -d $(DESTDIR)$(bindir)
++ install -m0755 wput $(DESTDIR)$(bindir)
++ install -d $(DESTDIR)$(mandir)
++ install -m0644 doc/wput.1.gz $(DESTDIR)$(mandir)
+ @echo "----------------"
+ @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
+ @echo "Further documentation is located in the doc/USAGE.* files."
+Files wput.orig/.Makefile.in.swo and wput/.Makefile.in.swo differ
+diff --exclude='*~' -urN wput.orig/src/ftp.c wput/src/ftp.c
+--- wput.orig/src/ftp.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp.c 2005-04-18 13:19:01.000000000 -0400
+@@ -88,7 +88,7 @@
+ * path and change there again */
+ /* error-levels: ERR_RECONNECT, ERR_FAILED, ERR_SKIP (failed for '/'), 1 */
+ int try_do_cwd(ftp_con * ftp, char * path, int mkd) {
+- int res;
++ int res = -1;
+ if(!strcmp(path, "."))
+ return mkd;
+ if(!strcmp(path, ".."))
+@@ -201,7 +201,7 @@
+ }
+
+ int open_input_file(_fsession * fsession) {
+- int fd;
++ int fd = -1;
+ int oflags = O_RDONLY;
+ char * cmd;
+ FILE * pipe;
+Files wput.orig/src/.ftp.c.swp and wput/src/.ftp.c.swp differ
+diff --exclude='*~' -urN wput.orig/src/ftp-ls.c wput/src/ftp-ls.c
+--- wput.orig/src/ftp-ls.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp-ls.c 2005-04-18 13:20:30.000000000 -0400
+@@ -42,6 +42,11 @@
+ #include <sys/types.h>
+ #include <errno.h>
+
++#ifndef _XOPEN_SOURCE
++# define _XOPEN_SOURCE
++#endif
++#include <time.h>
++
+ #include "wget.h"
+ #include "utils.h"
+ #include "ftp.h"
+Files wput.orig/src/.ftp-ls.c.swp and wput/src/.ftp-ls.c.swp differ
diff --git a/net-misc/wput/files/wput-0.6-respectldflags.patch b/net-misc/wput/files/wput-0.6-respectldflags.patch
new file mode 100644
index 000000000000..d2b460b339b3
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-respectldflags.patch
@@ -0,0 +1,13 @@
+Index: wput/src/Makefile.in
+===================================================================
+--- wput.orig/src/Makefile.in
++++ wput/src/Makefile.in
+@@ -23,7 +23,7 @@ ftplib.o: socketlib.h ftplib.h
+ ftp-ls.o: ftp.h wget.h url.h
+
+ wput: $(OBJ)
+- $(CC) -o $(EXE) $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXE) $(OBJ) $(LIBS)
+ clean:
+ rm -f *.o *~ *.bak ../wput getopt/*.o
+ win-clean: clean