summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-12 19:08:58 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-12 19:08:58 +0000
commit980b86b478af16338a81ce728cdf1c559ec0e987 (patch)
treebbdbc676d426dfd83b48eb965e38b8dba49bfdc3 /net-misc/wput/files
parentCorrected warning message and dep. The ebuild is still masked and nonfunction... (diff)
downloadgentoo-2-980b86b478af16338a81ce728cdf1c559ec0e987.tar.gz
gentoo-2-980b86b478af16338a81ce728cdf1c559ec0e987.tar.bz2
gentoo-2-980b86b478af16338a81ce728cdf1c559ec0e987.zip
Version bump; updated metadata.xml.
Diffstat (limited to 'net-misc/wput/files')
-rw-r--r--net-misc/wput/files/digest-wput-0.51
-rw-r--r--net-misc/wput/files/wput-0.5-gentoo.diff37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/wput/files/digest-wput-0.5 b/net-misc/wput/files/digest-wput-0.5
new file mode 100644
index 000000000000..34f75972f753
--- /dev/null
+++ b/net-misc/wput/files/digest-wput-0.5
@@ -0,0 +1 @@
+MD5 441b2e07219f78167b29a7ac33488fff wput-0.5.tgz 121543
diff --git a/net-misc/wput/files/wput-0.5-gentoo.diff b/net-misc/wput/files/wput-0.5-gentoo.diff
new file mode 100644
index 000000000000..f362ab45aa52
--- /dev/null
+++ b/net-misc/wput/files/wput-0.5-gentoo.diff
@@ -0,0 +1,37 @@
+diff -urN wput.orig/Makefile.in wput/Makefile.in
+--- wput.orig/Makefile.in 2004-12-12 13:40:04.146801506 -0500
++++ wput/Makefile.in 2004-12-12 13:48:08.352295485 -0500
+@@ -1,14 +1,18 @@
+ #wput makefile
++
+ prefix = @prefix@
+-mandir = $(prefix)/man/man1
++datadir = $(prefix)/share
++mandir = $(datadir)/man/man1
+ exec_prefix = @exec_prefix@
+ bindir=@bindir@
+
+ all clean win-clean:
+ cd src && $(MAKE) $@
+ install: all
+- cp wput $(bindir)
+- cp doc/wput.1.gz $(mandir)
++ install -d $(DESTDIR)$(bindir)
++ install -m0755 wput $(DESTDIR)$(bindir)
++ install -d $(DESTDIR)$(mandir)
++ install -m0644 doc/wput.1.gz $(DESTDIR)$(mandir)
+ @echo "----------------"
+ @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
+ @echo "Further documentation is located in the doc/USAGE.* files."
+diff -urN wput.orig/src/ftp.c wput/src/ftp.c
+--- wput.orig/src/ftp.c 2004-12-12 13:40:04.085811666 -0500
++++ wput/src/ftp.c 2004-12-12 13:42:26.493103988 -0500
+@@ -531,7 +531,7 @@
+
+ #define DBUFSIZE 1024
+
+- int fd;
++ int fd = -1;
+ FILE * pipe = NULL;
+ char databuf[DBUFSIZE];
+ int readbytes = 0;