summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-18 17:25:10 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-18 17:25:10 +0000
commitcc3a87583790081593b1917af5af0fde31a6a166 (patch)
tree029383ac68757fdaa7193480ed398396541f50d3 /net-misc/wput/files
parentbump (diff)
downloadgentoo-2-cc3a87583790081593b1917af5af0fde31a6a166.tar.gz
gentoo-2-cc3a87583790081593b1917af5af0fde31a6a166.tar.bz2
gentoo-2-cc3a87583790081593b1917af5af0fde31a6a166.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/wput/files')
-rw-r--r--net-misc/wput/files/digest-wput-0.6_pre1
-rw-r--r--net-misc/wput/files/wput-0.6_pre-gentoo.diff57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/wput/files/digest-wput-0.6_pre b/net-misc/wput/files/digest-wput-0.6_pre
new file mode 100644
index 000000000000..fb2581653864
--- /dev/null
+++ b/net-misc/wput/files/digest-wput-0.6_pre
@@ -0,0 +1 @@
+MD5 63b99c1b02db81d8dbb89f2caf0fe00a wput-pre0.6.tgz 240481
diff --git a/net-misc/wput/files/wput-0.6_pre-gentoo.diff b/net-misc/wput/files/wput-0.6_pre-gentoo.diff
new file mode 100644
index 000000000000..4ca604602c13
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6_pre-gentoo.diff
@@ -0,0 +1,57 @@
+diff --exclude='*~' -urN wput.orig/Makefile.in wput/Makefile.in
+--- wput.orig/Makefile.in 2005-04-18 13:14:14.000000000 -0400
++++ wput/Makefile.in 2005-04-18 13:17:46.000000000 -0400
+@@ -15,10 +15,10 @@
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- install -d $(bindir) wput
+- install -m0755 wput $(bindir)
+- install -d $(mandir) doc/wput.1.gz
+- install -m0644 doc/wput.1.gz $(mandir)
++ install -d $(DESTDIR)$(bindir)
++ install -m0755 wput $(DESTDIR)$(bindir)
++ install -d $(DESTDIR)$(mandir)
++ install -m0644 doc/wput.1.gz $(DESTDIR)$(mandir)
+ @echo "----------------"
+ @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
+ @echo "Further documentation is located in the doc/USAGE.* files."
+Files wput.orig/.Makefile.in.swo and wput/.Makefile.in.swo differ
+diff --exclude='*~' -urN wput.orig/src/ftp.c wput/src/ftp.c
+--- wput.orig/src/ftp.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp.c 2005-04-18 13:19:01.000000000 -0400
+@@ -88,7 +88,7 @@
+ * path and change there again */
+ /* error-levels: ERR_RECONNECT, ERR_FAILED, ERR_SKIP (failed for '/'), 1 */
+ int try_do_cwd(ftp_con * ftp, char * path, int mkd) {
+- int res;
++ int res = -1;
+ if(!strcmp(path, "."))
+ return mkd;
+ if(!strcmp(path, ".."))
+@@ -201,7 +201,7 @@
+ }
+
+ int open_input_file(_fsession * fsession) {
+- int fd;
++ int fd = -1;
+ int oflags = O_RDONLY;
+ char * cmd;
+ FILE * pipe;
+Files wput.orig/src/.ftp.c.swp and wput/src/.ftp.c.swp differ
+diff --exclude='*~' -urN wput.orig/src/ftp-ls.c wput/src/ftp-ls.c
+--- wput.orig/src/ftp-ls.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp-ls.c 2005-04-18 13:20:30.000000000 -0400
+@@ -42,6 +42,11 @@
+ #include <sys/types.h>
+ #include <errno.h>
+
++#ifndef _XOPEN_SOURCE
++# define _XOPEN_SOURCE
++#endif
++#include <time.h>
++
+ #include "wget.h"
+ #include "utils.h"
+ #include "ftp.h"
+Files wput.orig/src/.ftp-ls.c.swp and wput/src/.ftp-ls.c.swp differ