summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-09 00:56:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-09 00:56:30 +0000
commit50d204561602dccba6c4fc0dd082095e68cf1562 (patch)
tree88e934f48ff91f3a697d78f6a0df0381e76dac42 /net-misc
parentnow part of neverball (diff)
downloadgentoo-2-50d204561602dccba6c4fc0dd082095e68cf1562.tar.gz
gentoo-2-50d204561602dccba6c4fc0dd082095e68cf1562.tar.bz2
gentoo-2-50d204561602dccba6c4fc0dd082095e68cf1562.zip
add nls to IUSE; error messages; tidy
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gnomba/ChangeLog5
-rw-r--r--net-misc/gnomba/gnomba-0.6.2.ebuild27
2 files changed, 18 insertions, 14 deletions
diff --git a/net-misc/gnomba/ChangeLog b/net-misc/gnomba/ChangeLog
index ebd3be365e11..7298c2296062 100644
--- a/net-misc/gnomba/ChangeLog
+++ b/net-misc/gnomba/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/gnomba
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/ChangeLog,v 1.7 2004/03/19 10:10:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/ChangeLog,v 1.8 2004/04/09 00:56:30 mr_bones_ Exp $
+
+ 08 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> gnomba-0.6.2.ebuild:
+ add nls to IUSE; error messages; tidy
19 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> gnomba-0.6.2.ebuild:
fix depend (bug #45110); tidy
diff --git a/net-misc/gnomba/gnomba-0.6.2.ebuild b/net-misc/gnomba/gnomba-0.6.2.ebuild
index da968b5121ca..d1b715e87b03 100644
--- a/net-misc/gnomba/gnomba-0.6.2.ebuild
+++ b/net-misc/gnomba/gnomba-0.6.2.ebuild
@@ -1,34 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/gnomba-0.6.2.ebuild,v 1.9 2004/03/19 10:10:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/gnomba-0.6.2.ebuild,v 1.10 2004/04/09 00:56:30 mr_bones_ Exp $
DESCRIPTION="Gnome Samba Browser"
-SRC_URI="http://gnomba.sourceforge.net/src/${P}.tar.gz"
HOMEPAGE="http://gnomba.sourceforge.net"
+SRC_URI="http://gnomba.sourceforge.net/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc"
-IUSE=""
-
-DEPEND="virtual/glibc
- gnome-base/gnome-libs"
+IUSE="nls"
RDEPEND="gnome-base/gnome-libs"
+DEPEND="${RDEPEND}
+ virtual/glibc"
-src_compile()
-{
- ./configure --prefix=/usr --host=${CHOST} --mandir=/usr/share/man || die
+src_compile() {
+ ./configure \
+ $(use_enable nls) \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man || die "configure failed"
emake || die "emake failed"
}
-src_install()
-{
+src_install() {
#remove control chars from desktop file
mv gnomba.desktop gnomba.desktop.bad
tr -d '\015' < gnomba.desktop.bad > gnomba.desktop
-
make prefix=${D}/usr \
mandir=${D}/usr/share/man \
- install || die
+ install || die "make install failed"
+
}