summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-01-16 11:14:46 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-01-16 11:14:46 +0000
commit51efe4d1045235586fd003d4c95d45c33dfb55af (patch)
treee063b7d8c37bda2c9809d2ae98a25699866568fa /net-misc
parentStable on alpha, bug #287932 (diff)
downloadgentoo-2-51efe4d1045235586fd003d4c95d45c33dfb55af.tar.gz
gentoo-2-51efe4d1045235586fd003d4c95d45c33dfb55af.tar.bz2
gentoo-2-51efe4d1045235586fd003d4c95d45c33dfb55af.zip
version bump, bug 301169 by Tim O'Kelly <bugs_gentoo_org DOT Tim_OKelly AT neverbox DOT org>
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/ChangeLog10
-rw-r--r--net-misc/tor/tor-0.2.1.21.ebuild78
2 files changed, 86 insertions, 2 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index c720cb1fbb84..963a69cb688c 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.189 2009/12/27 17:27:23 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.190 2010/01/16 11:14:46 fauli Exp $
+
+*tor-0.2.1.21 (16 Jan 2010)
+
+ 16 Jan 2010; Christian Faulhammer <fauli@gentoo.org> +tor-0.2.1.21.ebuild:
+ version bump, bug 301169 by Tim O'Kelly <bugs_gentoo_org DOT Tim_OKelly AT
+ neverbox DOT org>
27 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
-files/tor-0.2.0.30-logrotate.patch,
diff --git a/net-misc/tor/tor-0.2.1.21.ebuild b/net-misc/tor/tor-0.2.1.21.ebuild
new file mode 100644
index 000000000000..9522568df974
--- /dev/null
+++ b/net-misc/tor/tor-0.2.1.21.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.21.ebuild,v 1.1 2010/01/16 11:14:46 fauli Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+MY_PV=${PV/_/-}
+SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+RDEPEND="${DEPEND}
+ net-proxy/tsocks"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
+ # Normally tor uses a bundled libevent fragment to provide
+ # asynchronous DNS requests. This is generally a bad idea, but at
+ # the moment the official libevent does not have the 0x20 hack, so
+ # anonymity is higher with the bundled variant. Remove patch as
+ # soon as upstream has installed the autoconf option to use
+ # system's libevent. This hasn't happened, so we
+ # have to live with the bundled libevent for this release, as the
+ # current version in tree won't suffice for tor to build
+ # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
+ # for upstream's report
+ # Let's revisit this when libevent-2* is unmasked
+ # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ elog "To have privoxy and tor working together you must add:"
+ elog "forward-socks4a / localhost:9050 ."
+ elog "(notice the . at the end of the line)"
+ elog "to /etc/privoxy/config"
+}