summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-02-04 09:49:06 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-02-04 09:49:06 +0000
commit564a68750eff8b94ffa6f7458be094a00886d615 (patch)
treee0df159dbc6755f2bb6a0109d80b3fd5135a96c5 /net-misc
parent* bump (diff)
downloadgentoo-2-564a68750eff8b94ffa6f7458be094a00886d615.tar.gz
gentoo-2-564a68750eff8b94ffa6f7458be094a00886d615.tar.bz2
gentoo-2-564a68750eff8b94ffa6f7458be094a00886d615.zip
revamp logic to pkg_setup(); add another built_with_use check for USE=fax on net-dialup/mgetty
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hylafax/ChangeLog8
-rw-r--r--net-misc/hylafax/hylafax-4.3.1.ebuild21
2 files changed, 21 insertions, 8 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index a67e520dd84a..0f584059df3d 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/hylafax
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.78 2007/10/17 21:19:36 nerdboy Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.79 2008/02/04 09:49:06 opfer Exp $
+
+ 04 Feb 2008; Christian Faulhammer <opfer@gentoo.org> hylafax-4.3.1.ebuild:
+ revamp logic to pkg_setup(); add another built_with_use check for USE=fax on
+ net-dialup/mgetty
17 Oct 2007; Steve Arnold <nerdboy@gentoo.org> hylafax-4.2.5.ebuild,
hylafax-4.3.0.ebuild, hylafax-4.3.1.ebuild:
diff --git a/net-misc/hylafax/hylafax-4.3.1.ebuild b/net-misc/hylafax/hylafax-4.3.1.ebuild
index d08a1bf1e0ad..2fd79b59501c 100644
--- a/net-misc/hylafax/hylafax-4.3.1.ebuild
+++ b/net-misc/hylafax/hylafax-4.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.7 2007/10/17 21:19:36 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.8 2008/02/04 09:49:06 opfer Exp $
inherit eutils multilib pam flag-o-matic toolchain-funcs
@@ -29,12 +29,19 @@ RDEPEND="${DEPEND}
export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc /usr/lib/fax"
-src_compile() {
+pkg_setup() {
if use faxonly; then
if use mgetty; then
- eerror "You cannot set both faxonly and mgetty, please remove one." && die "invalid use flags"
+ eerror "You cannot set both faxonly and mgetty, please remove one."
+ die "invalid USE flags"
fi
fi
+
+ if built_with_use --missing true net-dialup/mgetty fax; then
+ eerror "net-dialup/mgetty must be installed without USE=fax"
+ die "merge net-dialup/mgetty without USE=fax"
+ fi
+
if use jbig; then
einfo "Checking for tiff compiled with jbig support..."
if built_with_use media-libs/tiff jbig; then
@@ -45,7 +52,9 @@ src_compile() {
die "Tiff not merged with jbig USE flag"
fi
fi
+}
+src_compile() {
# Hylafax doesn't play nice with gcc-3.4 and SSP (bug #74457)
# so drop the flags until a better solution comes along
[ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
@@ -97,7 +106,7 @@ src_compile() {
fi
use faxonly && my_conf="${my_conf} --with-PATH_GETTY=/bin/false
- --with-PATH_VGETTY=/bin/false"
+ --with-PATH_VGETTY=/bin/false"
#--enable-pam isn't valid
use pam || my_conf="${my_conf} $(use_enable pam)"
@@ -132,7 +141,7 @@ src_install() {
keepdir /var/spool/fax/{status,sendq,log,info,doneq,docq,dev}
dosed "s:hostname:hostname -f:g" \
- /var/spool/fax/bin/{faxrcvd,pollrcvd} || die "dosed failed"
+ /var/spool/fax/bin/{faxrcvd,pollrcvd} || die "dosed failed"
einfo "Adding env.d entry for Hylafax"
newenvd "${FILESDIR}/99hylafax-4.2" 99hylafax