summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-03-23 01:35:50 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-03-23 01:35:50 +0000
commit62ce5076a41f8efe2210e1dae11686a0de8d3f38 (patch)
treea888b4dd695751268d9a2184ae71351d2e64853d /net-misc
parentVersion bump, remove older unstables (diff)
downloadgentoo-2-62ce5076a41f8efe2210e1dae11686a0de8d3f38.tar.gz
gentoo-2-62ce5076a41f8efe2210e1dae11686a0de8d3f38.tar.bz2
gentoo-2-62ce5076a41f8efe2210e1dae11686a0de8d3f38.zip
convert live ebuild to use fossil for bug #505126, thanks to Mike Gilbert.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8568F528)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog5
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild28
2 files changed, 29 insertions, 4 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 0bab9e17def4..2d34d016f08c 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.393 2014/03/20 03:52:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.394 2014/03/23 01:35:50 williamh Exp $
+
+ 23 Mar 2014; William Hubbs <williamh@gentoo.org> dhcpcd-9999.ebuild:
+ convert live ebuild to use fossil for bug #505126, thanks to Mike Gilbert.
20 Mar 2014; Mike Gilbert <floppym@gentoo.org> dhcpcd-6.3.1-r1.ebuild,
dhcpcd-9999.ebuild:
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index bd6cb7335826..47a48dd2b0a9 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.12 2014/03/20 03:52:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.13 2014/03/23 01:35:50 williamh Exp $
EAPI=5
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://roy.marples.name/${PN}.git"
- inherit git-r3
+ FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
@@ -28,6 +27,29 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
+if [[ ${PV} == "9999" ]]; then
+ DEPEND+=" dev-vcs/fossil"
+
+ src_unpack()
+ {
+ local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
+ local repo=${distdir}/fossil/${PN}.fossil
+
+ addwrite "${distdir}"
+
+ if [[ -e "${repo}" ]]; then
+ fossil pull "${FOSSIL_URI}" -R "${repo}" || die
+ else
+ mkdir -p "${distdir}/fossil" || die
+ fossil clone "${FOSSIL_URI}" "${repo}" || die
+ fi
+
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ fossil open "${repo}" || die
+ }
+fi
+
src_prepare()
{
epatch_user