summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-04-13 14:22:13 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-04-13 14:22:13 +0000
commit6ef7f0cabf915d4a22c51a04d7846b6c22b15536 (patch)
treeb9ac2c56023cfe956b56898f2c8ffc22de3a1689 /net-misc
parentVersion bump. (diff)
downloadgentoo-2-6ef7f0cabf915d4a22c51a04d7846b6c22b15536.tar.gz
gentoo-2-6ef7f0cabf915d4a22c51a04d7846b6c22b15536.tar.bz2
gentoo-2-6ef7f0cabf915d4a22c51a04d7846b6c22b15536.zip
fix sock support; remove old version
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/neon/ChangeLog7
-rw-r--r--net-misc/neon/files/neon-0.27.2-linguas.patch42
-rw-r--r--net-misc/neon/neon-0.26.4.ebuild4
-rw-r--r--net-misc/neon/neon-0.27.2.ebuild92
-rw-r--r--net-misc/neon/neon-0.28.1.ebuild6
5 files changed, 11 insertions, 140 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 6940cc8c31a1..4182f7448b93 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.101 2008/03/23 11:42:00 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.102 2008/04/13 14:22:12 hollow Exp $
+
+ 13 Apr 2008; Benedikt Böhm <hollow@gentoo.org>
+ -files/neon-0.27.2-linguas.patch, neon-0.26.4.ebuild, -neon-0.27.2.ebuild,
+ neon-0.28.1.ebuild:
+ fix sock support; remove old version
23 Mar 2008; Benedikt Böhm <hollow@gentoo.org> neon-0.28.1.ebuild:
fix LINGUAS
diff --git a/net-misc/neon/files/neon-0.27.2-linguas.patch b/net-misc/neon/files/neon-0.27.2-linguas.patch
deleted file mode 100644
index 7560a2ce2797..000000000000
--- a/net-misc/neon/files/neon-0.27.2-linguas.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: neon-0.27.2/Makefile.in
-===================================================================
---- neon-0.27.2.orig/Makefile.in
-+++ neon-0.27.2/Makefile.in
-@@ -181,8 +181,10 @@ install-nls-no:
-
- install-nls-yes:
- @for f in $(LINGUAS); do \
-- $(INSTALL) -d $(DESTDIR)$(localedir)/$$f/LC_MESSAGES; \
-- $(INSTALL_DATA) $(srcdir)/po/$$f.gmo $(DESTDIR)$(localedir)/$$f/LC_MESSAGES/neon.mo; \
-+ if test -e $(srcdir)/po/$$f.gmo; then \
-+ $(INSTALL) -d $(DESTDIR)$(localedir)/$$f/LC_MESSAGES; \
-+ $(INSTALL_DATA) $(srcdir)/po/$$f.gmo $(DESTDIR)$(localedir)/$$f/LC_MESSAGES/neon.mo; \
-+ fi \
- done
-
- ChangeLog:
-@@ -191,15 +193,19 @@ ChangeLog:
- update-po:
- @xgettext $(XGETTEXT_OPTS) $(top_srcdir)/src/ne*.c -o $(POTFILE)
- @for f in $(LINGUAS); do \
-- echo "> Updating \"$$f\" catalog:"; \
-- $(MSGMERGE) --update $(top_srcdir)/po/$$f.po $(POTFILE); \
-- $(MSGFMT) --output /dev/null --check-format $(top_srcdir)/po/$$f.po || exit 1; \
-+ if test -e $(srcdir)/po/$$f.gmo; then \
-+ echo "> Updating \"$$f\" catalog:"; \
-+ $(MSGMERGE) --update $(top_srcdir)/po/$$f.po $(POTFILE); \
-+ $(MSGFMT) --output /dev/null --check-format $(top_srcdir)/po/$$f.po || exit 1; \
-+ fi \
- done
-
- compile-gmo:
- @for f in $(LINGUAS); do \
-- echo "> Compiling \"$$f\" catalog:"; \
-- $(MSGFMT) --statistics -c -o po/$$f.gmo $(top_srcdir)/po/$$f.po; \
-+ if test -e $(srcdir)/po/$$f.gmo; then \
-+ echo "> Compiling \"$$f\" catalog:"; \
-+ $(MSGFMT) --statistics -c -o po/$$f.gmo $(top_srcdir)/po/$$f.po; \
-+ fi \
- done
-
- doc-status:
diff --git a/net-misc/neon/neon-0.26.4.ebuild b/net-misc/neon/neon-0.26.4.ebuild
index 75579d580320..d545fd7c8815 100644
--- a/net-misc/neon/neon-0.26.4.ebuild
+++ b/net-misc/neon/neon-0.26.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.4.ebuild,v 1.8 2008/01/10 09:14:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.4.ebuild,v 1.9 2008/04/13 14:22:12 hollow Exp $
inherit eutils libtool versionator autotools
@@ -53,7 +53,7 @@ src_compile() {
--enable-shared \
$(use_with zlib) \
$(use_with kerberos gssapi) \
- $(use_enable socks5 socks) \
+ $(use_with socks5 socks) \
$(use_enable nls) \
${myconf} \
|| die "econf failed"
diff --git a/net-misc/neon/neon-0.27.2.ebuild b/net-misc/neon/neon-0.27.2.ebuild
deleted file mode 100644
index 70914b6ab7b5..000000000000
--- a/net-misc/neon/neon-0.27.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.27.2.ebuild,v 1.2 2008/01/27 20:43:23 hollow Exp $
-
-inherit eutils libtool versionator autotools
-
-DESCRIPTION="HTTP and WebDAV client library"
-HOMEPAGE="http://www.webdav.org/neon/"
-SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="expat kerberos nls socks5 ssl zlib"
-RESTRICT="test"
-
-DEPEND="expat? ( dev-libs/expat )
- !expat? ( dev-libs/libxml2 )
- kerberos? ( virtual/krb5 )
- nls? ( virtual/libintl )
- socks5? ( net-proxy/dante )
- ssl? ( >=dev-libs/openssl-0.9.6f )
- zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-linguas.patch
- sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${LINGUAS}\"/g" \
- ./configure.in
- AT_M4DIR=./macros eautoreconf
-}
-
-src_compile() {
- local myconf=
-
- if has_version sys-libs/glibc; then
- if built_with_use --missing true sys-libs/glibc nptlonly \
- || built_with_use --missing true sys-libs/glibc nptl; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf="${myconf} --enable-threadsafe-ssl=posix"
- fi
- fi
-
- if use expat; then
- myconf="${myconf} --with-expat"
- else
- myconf="${myconf} --with-libxml2"
- fi
-
- if use ssl; then
- myconf="${myconf} --with-ssl=openssl"
- fi
-
- econf \
- --enable-static \
- --enable-shared \
- $(use_with zlib) \
- $(use_with kerberos gssapi) \
- $(use_enable socks5 socks) \
- $(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- make check || die "Trying make check without success."
-}
-
-src_install() {
- make DESTDIR="${D}" install || die 'install failed'
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
-}
-
-pkg_postinst() {
- ewarn "There are new features in this version; please beware that"
- ewarn "upstream considers the socks support experimental. If you"
- ewarn "experience test failures (eg, bug 135863) then try rebuilding"
- ewarn "glibc."
- ewarn
- ewarn "Neon has a policy of breaking API across versions, this means"
- ewarn "that any packages that links against neon will be broken after"
- ewarn "updating. They will remain broken until they are ported to the"
- ewarn "new API. You can downgrade neon to the previous version by doing:"
- ewarn
- ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
- ewarn
- ewarn "You may also have to downgrade any packages that have already been"
- ewarn "ported to the new API."
-}
diff --git a/net-misc/neon/neon-0.28.1.ebuild b/net-misc/neon/neon-0.28.1.ebuild
index e968d69842f0..462a67574fdb 100644
--- a/net-misc/neon/neon-0.28.1.ebuild
+++ b/net-misc/neon/neon-0.28.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.1.ebuild,v 1.3 2008/03/30 03:55:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.1.ebuild,v 1.4 2008/04/13 14:22:12 hollow Exp $
inherit autotools eutils libtool versionator
@@ -12,7 +12,7 @@ SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="doc expat gnutls kerberos nls pkcs11 socks5 ssl zlib"
IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
for lingua in ${IUSE_LINGUAS}; do
@@ -74,7 +74,7 @@ src_compile() {
$(use_with kerberos gssapi) \
$(use_enable nls) \
$(use_with pkcs11 pakchois) \
- $(use_enable socks5 socks) \
+ $(use_with socks5 socks) \
$(use_with zlib) \
${myconf}
emake || die "emake failed"