summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2013-06-30 15:00:22 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2013-06-30 15:00:22 +0000
commit9470f55d35ffba3a10704b1e45cacfe3dbf794d5 (patch)
tree8e32e12662f907911bc7613ceeeafc5551e65526 /net-misc
parentapp-accessibility/speech-dispatcher: Fix usage of python-r1.eclass (diff)
downloadgentoo-2-9470f55d35ffba3a10704b1e45cacfe3dbf794d5.tar.gz
gentoo-2-9470f55d35ffba3a10704b1e45cacfe3dbf794d5.tar.bz2
gentoo-2-9470f55d35ffba3a10704b1e45cacfe3dbf794d5.zip
Adding support for networkmanager, fixing bug #472436.
Bumping to EAPI 5. (Portage version: 2.2.0_alpha186/cvs/Linux i686, signed Manifest commit with key 15AE484C)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/strongswan/ChangeLog6
-rw-r--r--net-misc/strongswan/strongswan-5.0.4.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/strongswan/ChangeLog b/net-misc/strongswan/ChangeLog
index 2fca09c90114..a809f93e38ef 100644
--- a/net-misc/strongswan/ChangeLog
+++ b/net-misc/strongswan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/strongswan
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.117 2013/06/09 23:02:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.118 2013/06/30 15:00:22 gurligebis Exp $
+
+ 30 Jun 2013; <gurligebis@gentoo.org> strongswan-5.0.4.ebuild:
+ Adding support for networkmanager, fixing bug #472436.
+ Bumping to EAPI 5.
09 Jun 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml:
Add upstream CPE tag (security info) from ChromiumOS.
diff --git a/net-misc/strongswan/strongswan-5.0.4.ebuild b/net-misc/strongswan/strongswan-5.0.4.ebuild
index eddb47b1f4da..46faddb11679 100644
--- a/net-misc/strongswan/strongswan-5.0.4.ebuild
+++ b/net-misc/strongswan/strongswan-5.0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-5.0.4.ebuild,v 1.5 2013/05/11 11:18:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-5.0.4.ebuild,v 1.6 2013/06/30 15:00:22 gurligebis Exp $
-EAPI=2
+EAPI=5
inherit eutils linux-info user
DESCRIPTION="IPsec-based VPN solution focused on security and ease of use, supporting IKEv1/IKEv2 and MOBIKE"
@@ -12,7 +12,7 @@ SRC_URI="http://download.strongswan.org/${P}.tar.bz2"
LICENSE="GPL-2 RSA DES"
SLOT="0"
KEYWORDS="amd64 arm ppc ~ppc64 x86"
-IUSE="+caps curl debug dhcp eap farp gcrypt ldap mysql +non-root +openssl sqlite pam"
+IUSE="+caps curl debug dhcp eap farp gcrypt ldap mysql networkmanager +non-root +openssl sqlite pam"
COMMON_DEPEND="!net-misc/openswan
>=dev-libs/gmp-4.1.5
@@ -133,11 +133,12 @@ src_configure() {
$(use_enable sqlite) \
$(use_enable dhcp) \
$(use_enable farp) \
+ $(use_enable networkmanager nm) \
${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${D}" install
doinitd "${FILESDIR}"/ipsec