summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-29 00:20:35 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-29 00:20:35 +0000
commitb42e3319ca93a35cac715df8e8f1dee8e330cf78 (patch)
tree5072a7702604ca956972fafe94c42589778333bc /net-misc
parentupdate with logger dep target (diff)
downloadgentoo-2-b42e3319ca93a35cac715df8e8f1dee8e330cf78.tar.gz
gentoo-2-b42e3319ca93a35cac715df8e8f1dee8e330cf78.tar.bz2
gentoo-2-b42e3319ca93a35cac715df8e8f1dee8e330cf78.zip
new version
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/files/digest-wget-1.8.12
-rw-r--r--net-misc/wget/wget-1.8.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/wget/files/digest-wget-1.8.1 b/net-misc/wget/files/digest-wget-1.8.1
new file mode 100644
index 000000000000..3ae1cd5a6fac
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.8.1
@@ -0,0 +1,2 @@
+MD5 6ca8e939476e840f0ce69a3b31c13060 wget-1.8.1.tar.gz 1105920
+MD5 8da1e4f2991384ddbd575f4109c2ab4a wget-new-percentage-cvs-20011209.tar.gz 12288
diff --git a/net-misc/wget/wget-1.8.1.ebuild b/net-misc/wget/wget-1.8.1.ebuild
new file mode 100644
index 000000000000..6357ba2f64d4
--- /dev/null
+++ b/net-misc/wget/wget-1.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.1.ebuild,v 1.1 2001/12/29 00:20:35 azarah Exp $
+
+NPVER=20011209
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
+ http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack wget-new-percentage-cvs-${NPVER}.tar.gz
+ cd ${S}/src
+ patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+ [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ ./configure --prefix=/usr --sysconfdir=/etc/wget \
+ --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
+ if use static; then
+ make LDFLAGS="--static" || die
+ else
+ make || die
+ fi
+}
+
+src_install() {
+ if use build || use bootcd; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}