summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-09-16 12:15:43 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-09-16 12:15:43 +0000
commitdf3ea2d26cadf1fe9d51f6882e334aa1ffe368f8 (patch)
treeabeb9451b244299c5259603517cf7e2741ffa695 /net-misc
parentVersion bump. (diff)
downloadgentoo-2-df3ea2d26cadf1fe9d51f6882e334aa1ffe368f8.tar.gz
gentoo-2-df3ea2d26cadf1fe9d51f6882e334aa1ffe368f8.tar.bz2
gentoo-2-df3ea2d26cadf1fe9d51f6882e334aa1ffe368f8.zip
Revision bump. Use shared libraries by default. Fix some QA warnings during compile.
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cfengine/ChangeLog11
-rw-r--r--net-misc/cfengine/cfengine-3.0.5_p1-r1.ebuild (renamed from net-misc/cfengine/cfengine-3.0.5_p1.ebuild)4
-rw-r--r--net-misc/cfengine/files/cfengine-3.0.5_p1-Makefile.am.patch29
-rw-r--r--net-misc/cfengine/files/cfengine-3.0.5_p1-configure.ac.patch40
-rw-r--r--net-misc/cfengine/files/cfengine-3.0.5_p1-regex.c.patch12
5 files changed, 79 insertions, 17 deletions
diff --git a/net-misc/cfengine/ChangeLog b/net-misc/cfengine/ChangeLog
index 1fa8872c777a..f3f8032538c7 100644
--- a/net-misc/cfengine/ChangeLog
+++ b/net-misc/cfengine/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/cfengine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.105 2010/09/01 20:23:20 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.106 2010/09/16 12:15:42 idl0r Exp $
+
+*cfengine-3.0.5_p1-r1 (16 Sep 2010)
+
+ 16 Sep 2010; Christian Ruppert <idl0r@gentoo.org> -cfengine-3.0.5_p1.ebuild,
+ +cfengine-3.0.5_p1-r1.ebuild, +files/cfengine-3.0.5_p1-Makefile.am.patch,
+ files/cfengine-3.0.5_p1-configure.ac.patch,
+ +files/cfengine-3.0.5_p1-regex.c.patch:
+ Revision bump. Use shared libraries by default. Fix some QA warnings during
+ compile.
*cfengine-3.0.5_p1 (01 Sep 2010)
diff --git a/net-misc/cfengine/cfengine-3.0.5_p1.ebuild b/net-misc/cfengine/cfengine-3.0.5_p1-r1.ebuild
index 50ca38c894b1..66294a83e634 100644
--- a/net-misc/cfengine/cfengine-3.0.5_p1.ebuild
+++ b/net-misc/cfengine/cfengine-3.0.5_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.0.5_p1.ebuild,v 1.2 2010/09/01 20:25:47 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.0.5_p1-r1.ebuild,v 1.1 2010/09/16 12:15:42 idl0r Exp $
EAPI="3"
@@ -41,6 +41,8 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}/${P}-configure.ac.patch"
+ epatch "${FILESDIR}/${P}-Makefile.am.patch"
+ epatch "${FILESDIR}/${P}-regex.c.patch"
eautoreconf
}
diff --git a/net-misc/cfengine/files/cfengine-3.0.5_p1-Makefile.am.patch b/net-misc/cfengine/files/cfengine-3.0.5_p1-Makefile.am.patch
new file mode 100644
index 000000000000..999c9a92f3f0
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.0.5_p1-Makefile.am.patch
@@ -0,0 +1,29 @@
+diff --git a/pub/Makefile.am b/pub/Makefile.am
+index 14ad1a2..6ef675a 100644
+--- a/pub/Makefile.am
++++ b/pub/Makefile.am
+@@ -2,9 +2,9 @@
+ AM_CFLAGS = @CFLAGS@ @GCC_CFLAG@
+ INCLUDES = @BERKELEY_DB_CFLAGS@ @OPENSSL_LIB_CPPFLAGS@
+
+-noinst_LIBRARIES = libcfpub.a
++noinst_LTLIBRARIES = libcfpub.la
+
+-libcfpub_a_SOURCES = \
++libcfpub_la_SOURCES = \
+ getopt.c \
+ getopt1.c \
+ full-write.c \
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e48bb5b..c69ce0e 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -5,7 +5,7 @@ LDADD = libpromises.la # $(BERKELEY_DB_LDFLAGSD) $(BERKELEY_DB_LIB) $(OPENSSL_LI
+ INCLUDES = $(BERKELEY_DB_CFLAGS) $(OPENSSL_LIB_CPPFLAGS)
+ AM_LDFLAGS = $(BERKELEY_DB_LDFLAGS) $(OPENSSL_LIB_LDFLAGS) @LDFLAGS@
+
+-lib_LTLIBRARIES = libpromises.la
++pkglib_LTLIBRARIES = libpromises.la
+
+ libpromises_la_LDFLAGS = -version-info 1:0:0 -no-undefined
+ libpromises_la_LIBADD = $(BERKELEY_DB_LDFLAGSD) $(BERKELEY_DB_LIB) $(OPENSSL_LIB_LDFLAGS) $(OPENSSL_LIB_LIB)
diff --git a/net-misc/cfengine/files/cfengine-3.0.5_p1-configure.ac.patch b/net-misc/cfengine/files/cfengine-3.0.5_p1-configure.ac.patch
index e746f51c4e9b..64bdab4891ed 100644
--- a/net-misc/cfengine/files/cfengine-3.0.5_p1-configure.ac.patch
+++ b/net-misc/cfengine/files/cfengine-3.0.5_p1-configure.ac.patch
@@ -1,8 +1,18 @@
diff --git a/configure.ac b/configure.ac
-index 64b2a13..09821a5 100644
+index 64b2a13..8202c6c 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -84,13 +84,9 @@ AC_CHECK_LIB(m,main)
+@@ -68,8 +68,7 @@ AC_PROG_CC
+ AM_PROG_LEX
+ AC_PROG_YACC
+ AC_PROG_RANLIB
+-AC_DISABLE_SHARED
+-dnl AC_DISABLE_STATIC - maybe use shared libs later
++AC_DISABLE_STATIC
+ AC_PROG_LIBTOOL
+ AC_PROG_INSTALL
+ AC_CONFIG_LIBOBJ_DIR(pub)
+@@ -84,13 +83,9 @@ AC_CHECK_LIB(m,main)
dnl Look for ldap
@@ -19,7 +29,7 @@ index 64b2a13..09821a5 100644
dnl Now check for database connectors
-@@ -99,15 +95,9 @@ dnl ######################################################################
+@@ -99,15 +94,9 @@ dnl ######################################################################
dnl Look for SQL connectors.
dnl ######################################################################
@@ -38,7 +48,7 @@ index 64b2a13..09821a5 100644
if test $WITH_SQL = 1; then
case "$target_os" in
-@@ -124,31 +114,17 @@ if test $WITH_SQL = 1; then
+@@ -124,31 +113,17 @@ if test $WITH_SQL = 1; then
fi
@@ -79,7 +89,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_FUNC(door_create,door)
AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt))
-@@ -162,18 +138,12 @@ dnl
+@@ -162,18 +137,12 @@ dnl
dnl Choose a database
dnl
@@ -102,7 +112,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_LIB(tokyocabinet,main, [], [AC_MSG_ERROR(Cannot find Tokyo Cabinet)])
AC_CHECK_HEADERS(tcutil.h)
AC_CHECK_HEADERS(tchdb.h)
-@@ -182,18 +152,12 @@ fi
+@@ -182,18 +151,12 @@ fi
dnl else qdbm?
@@ -125,7 +135,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_LIB(qdbm,main, [], [AC_MSG_ERROR(Cannot find Quick Database Manager)])
AC_CHECK_HEADERS(depot.h)
AC_DEFINE(QDB, 1, [Define if QDBM is available.])
-@@ -471,18 +435,12 @@ AC_SUBST(OPENSSL_LIB_LIB)
+@@ -471,18 +434,12 @@ AC_SUBST(OPENSSL_LIB_LIB)
# Others
#
@@ -148,7 +158,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_LIB(virt,main, [], [AC_MSG_ERROR(Cannot find libvirt)])
fi
-@@ -491,60 +449,52 @@ dnl ######################################################################
+@@ -491,60 +448,52 @@ dnl ######################################################################
dnl Checks for perl compatible regular expressions
dnl ######################################################################
@@ -247,7 +257,7 @@ index 64b2a13..09821a5 100644
dnl ######################################################################
dnl Checks for header files.
dnl ######################################################################
-@@ -564,7 +514,6 @@ AC_CHECK_HEADERS(sys/param.h)
+@@ -564,7 +513,6 @@ AC_CHECK_HEADERS(sys/param.h)
AC_CHECK_HEADERS(fcntl.h)
AC_CHECK_HEADERS(sys/filesys.h)
AC_CHECK_HEADERS(dustat.h)
@@ -255,7 +265,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_HEADERS(sys/systeminfo.h)
AC_CHECK_HEADERS(sys/acl.h winsock2.h)
-@@ -579,32 +528,23 @@ dnl ######################################################################
+@@ -579,32 +527,23 @@ dnl ######################################################################
dnl Checks for graph support
dnl ######################################################################
@@ -298,7 +308,7 @@ index 64b2a13..09821a5 100644
dnl ######################################################################
dnl Checks for data types
-@@ -627,7 +567,7 @@ dnl Check for special functions
+@@ -627,7 +566,7 @@ dnl Check for special functions
dnl ######################################################################
AC_CHECK_FUNCS(getcwd getnetgrent waitpid seteuid setegid setreuid setregid)
@@ -307,7 +317,7 @@ index 64b2a13..09821a5 100644
AC_CHECK_FUNCS(strstr strsep putenv drand48 srand48 getaddrinfo)
AC_CHECK_FUNCS(bcopy mkfifo statfs statvfs door)
AC_CHECK_FUNCS(sysinfo setsid strdup strrchr strerror snprintf sysconf)
-@@ -691,30 +631,27 @@ AC_CHECK_FUNC(lchown, AC_DEFINE(HAVE_LCHOWN))
+@@ -691,30 +630,27 @@ AC_CHECK_FUNC(lchown, AC_DEFINE(HAVE_LCHOWN))
AC_CHECK_FUNC(pthread_attr_setstacksize, AC_DEFINE(HAVE_PTHREAD_ATTR_SETSTACKSIZE), AC_CHECK_LIB(pthread, pthread_create))
AC_CHECK_FUNC(pthread_sigmask, AC_DEFINE(HAVE_PTHREAD_SIGMASK), AC_CHECK_LIB(pthread, pthread_create))
@@ -354,7 +364,7 @@ index 64b2a13..09821a5 100644
dnl ######################################################################
-@@ -995,7 +932,7 @@ AC_MSG_RESULT( )
+@@ -995,7 +931,7 @@ AC_MSG_RESULT( )
AC_MSG_RESULT( Summary of options...)
@@ -363,7 +373,7 @@ index 64b2a13..09821a5 100644
AC_MSG_RESULT( -> Configured with PCRE libraries)
else
AC_MSG_RESULT( -> No PCRE library support - reverting to POSIX builtins)
-@@ -1003,11 +940,11 @@ fi
+@@ -1003,11 +939,11 @@ fi
if test $WITH_SQL = 1; then
@@ -377,7 +387,7 @@ index 64b2a13..09821a5 100644
AC_MSG_RESULT( -> Configured with Postgres libraries)
fi
-@@ -1016,14 +953,14 @@ else
+@@ -1016,14 +952,14 @@ else
fi
if test $WITH_GVC = 1; then
diff --git a/net-misc/cfengine/files/cfengine-3.0.5_p1-regex.c.patch b/net-misc/cfengine/files/cfengine-3.0.5_p1-regex.c.patch
new file mode 100644
index 000000000000..2874a9439370
--- /dev/null
+++ b/net-misc/cfengine/files/cfengine-3.0.5_p1-regex.c.patch
@@ -0,0 +1,12 @@
+diff --git a/pub/regex.c b/pub/regex.c
+index ba15918..dcaa9b4 100644
+--- a/pub/regex.c
++++ b/pub/regex.c
+@@ -40,6 +40,7 @@
+
+ /* We need this for `regex.h', and perhaps for the Emacs include files. */
+ #include <sys/types.h>
++#include <string.h>
+ #include "gnuregex.h"
+
+ /* The `emacs' switch turns on certain matching commands